Пояснения

Введение

Введение >

Введение

 Return to chapter overview

Мы включили в комлект это руководство, чтобы каждый, кто хочет немедленно создать с помощью программы WebSite X5 собственный сайт, интернет-магазин или блог, могли это сделать с нашей помощью на каждом шаге.

Каждый этап разработки проекта сопровождается ясными указаниями по каждой части программного интерфейса, с которым вы работаете, с подробным пояснением всех команд и параметров различных меню, панелей и окон.

С помощью пояснений и информации из данного руководства, логичной и наглядной схемой работы и с дополнительной помощью возможностей предварительного просмотра вашей работы, обновляющихся в реальном времени, у вас не будет трудностей в создании с помощью программы WebSite X5 привлекательных интересных и профессиональных сайтов.

Это руководство к программе WebSite X5 относится к версии Evolution v. 10, но может использоваться и с другими версиями программы с учетом различия определенной функциональности между различными версиями.

Руководство организовано в три раздела:

- | Рабочая среда Этот раздел описывает все функции, предоставляемые программой в различных окнах, открываемых по мере создания и публикации вами сайта.
- | Лучшая практика Этот раздел содержит руководства, которые моделируют все этапы, применяемые для решения определенных задач, таких как назначение паролей защищенным страницам и создание форм отправки данных.
- | Родственные темы Этот раздел содержит дополнительную информацию к различным темам, относящимся к созданию сайтов.

Последнее обновление: версия 10


WebSite X5: Возможности программы

Incomedia WebSite X5: Возможности программы

Введение >

Incomedia WebSite X5: Возможности программы

 Return to chapter overview

Incomedia WebSite X5 позволяет быстро и легко создавать сайты, интернет-магазины, блоги, цифровые фотоальбомы и интерактивные презентации. Поддерживаются проекты с развитой сетевой структурой и многоуровневыми меню, с неограниченным количеством страниц.

Пользователь может отдельно настроить компоновку каждой страницы и наполнить ее объектами самых разных типов: текстами, изображениями, таблицами, галереями, видео, почтовыми формами обратной связи, социальными сетями, гостевыми книгами, анимациями Flash™, каталогами товаров, HTML-объектами и виджетами.

Программа WebSite X5 предлагает множество интересных функций для редактирования изображений, благодаря чему отпадает надобность в использовании других графических редакторов. Автоматическое сохранение изображений в сжатом формате означает, что пользователю не придется специально оптимизировать фотографии перед размещением на сайте.

Большой архив графических шаблонов, встроенный редактор для создания «объемных» кнопок, широкие возможности по настройке графического оформления, добавление введений, поддержка многоязычных сайтов, пользовательских разделов, блогов и RSS-лент, а также возможность создания интернет-магазинов с оплатой товаров посредством кредитных карт — весь этот богатый функционал позволяет разрабатывать полноценные профессиональные сайты.

А как только вы будете готовы, программа WebSite X5 предлагает встроенные средства для работы с FTP (протокол передачи файлов), что позволяет сразу опубликовать проект в Интернете, без использования дополнительных FTP-программ.

Работа с программой WebSite X5

WebSite X5 представляет собой «мастер» (визуальный конструктор) по созданию сайтов: пользователь переходит от одного окна к другому, вводя данные, необходимые для создания полноценного сайта профессионального уровня, которым вполне можно гордиться!

Весь путь от идеи до готового сайта разбит в программе на 5 основных этапов:

1. Общие настройки

После выбора проекта и добавления общей информации о сайте (такой, как описание и ключевые слова для индексирования сайта поисковыми системами), WebSite X5 помогает задать внешний вид вашего сайта. Пользователь может либо выбрать какой-то из 1.500 готовых шаблонов, либо создать свой собственный с нуля. С помощью встроенного редактора можно настроить верхнюю и нижнюю части сайта на свой вкус.

2. Создание карты сайта

Начиная с главной страницы в программе WebSite X5 вы задаете иерархическую структуру своего сайта. Карта сайта может иметь неограниченное число уровней, подуровней и страниц. На основе карты сайта программа автоматически создаст меню для перемещения по сайту. Карту сайта можно в любое время изменить, если вы хотите внести в нее изменения или обновить сайт.

3. Создание страницы

Можно создать страницы и поработать над их макетом, простым перетаскиванием наполнив страницы объектами самых разных типов: текстами, изображениями, таблицами, галереями, видео и аудио, почтовыми формами обратной связи, социальными сетями, гостевыми книгами, картой сайта, анимациями, каталогами товаров, HTML-объектами и виджетами. Можно настроить импортированные объекты и дополнить их ссылками на внутренние или внешние объекты. В программе есть встроенный графический редактор, позволяющий вращать изображения, корректировать их, применять фильтры, маски и рамки, и все это - без внешних графических программ.

4. Расширенные настройки

Когда сайт в основном уже настроен, можно двинуться дальше и задать стиль различных элементов сайта, таких как меню навигации, тексты, окно ShowBox и почтовые формы обратной связи. Встроенный графический редактор позволяет создавать «объемные» кнопки, меняющиеся при наведении на них курсора мыши. Можно дополнить сайт различными дополнительными функциями, например, для добавления страницы приветствия, куда можно добавить даже звук, выбором языка отображения сайта, пользовательских разделов, блогом и даже интернет-магазином.

5. Экспорт

WebSite X5 помогает выгрузить готовый сайт в Интернет: можно открыть сессию FTP, где все нужные файлы скопируются на сервер. Программа WebSite X5 поддерживает защищенное соединение и экономит ваше время, работая в мнопоточном режиме и загружая на сервер лишь те файлы, которые изменились с прошлой выгрузки.

Помимо выгрузки сайта в Интернет, можно также экспортировать свой проект на диск вашего компьютера или на другой компьютер, чтобы создать резервную копию всего проекта.


Различия версий

Доступные версии

Введение >

Доступные версии

 Return to chapter overview

Программа WebSite X5 доступна в нескольких версиях, в том числе основная: Professional, Professional и Compact («Компактная»).

Для просмотра информации о различиях доступных версий, пожалуйста, посетите страницу: http://www.websitex5.com/compare


Представляя WebSite X5

Рабочая среда >

Представляя WebSite X5

 Return to chapter overview

Создавайте сайты, интернет-магазины и блоги всего за 5 этапов

Программа WebSite X5 идеально подходит для создания сайта вашей мечты. Чтобы ее использовать, не обязательно быть программистом! Интуитивный, полностью визуальный интерфейс программы позволяет просматривать промежуточные результаты по ходу работы.

Программа WebSite X5 сопровождает вас на каждом этапе создания сайта и его публикации в Интернет. Она очень проста в использовании и позволяет гибко настраивать буквально все аспекты сайта.

WebSite X5 автоматически создает код страниц в HTML5 + CSS 2.1 или 3 по вашему выбору и в зависимости от настроек для каждой страницы. Гарантируется полная совместимость со всеми браузерами и мобильными устройствами, а также эффективная индексация поисковыми машинами.

Профессиональные инструменты для сайта

WebSite X5 настолько легко использовать, что у вас не вызовет трудностей добавить на свой сайт сложные профессиональные компоненты, например:

§Интернет-магазины с оплатой кредитной картой

§Блог с аудиоподкастом и видеоподкастом

§Встроенная поисковая система для сайта

§Формы обратной связи с фильтрами антиспам

§Новости и RSS-ленты

§Масштабирование и панорамный просмотр фотографий

§Галереи изображений и видеозаписей

§Управление доступом

§Управление рекламными баннерами

§Многоязычные сайты

Комплексное решение («всё в одном»)

Важно также, что с помощью программы WebSite X5 вы экономите время и деньги, поскольку в программе уже есть все, что нужно для создания полноценного сайта:

§Редактор для настройки шаблонов

§Графический редактор

§Автоматическое создание меню

§Встроеная FTP-программа для размещения сайта

§1.500 настраиваемых шаблонов

§6 000 изображений для бесплатного использования

§Библиотеки кнопок

§Коллекция виджетов

Программа WebSite X5 обрела популярность благодаря полному набору функций, простоте и продуманности. Это идеальный выбор для любого, кто желает создавать сайты!


Рабочая среда

Рабочая среда >

Рабочая среда

 Return to chapter overview
Покажите/скройте невидемый текст

Как мы уже рассказывали, WebSite X5 работает как мастер, т.е. когда вы работаете с программой, вы поочередно выполняете различные этапы под ее руководством: на каждом этапе открывается окно, где нужно ввести или добавить необходимую информацию, чтобы в итоге создать, обновить и опубликовать полный, профессиональный и привлекательный сайт.

Все окна Программы имеют одинаковый графический интерфейс с панелями инструментов, расположенными вверху, внизу и сбоку. От окна к окну изменяется лишь центральная область, соответствующая той части Сайта, над которой в данный момент ведется работа. В этой области задаются все необходимые данные.

Кликните, чтобы развернуть/уменьшить
Рабочая среда
Кликните, чтобы развернуть/уменьшить Верхняя панель инструментов

На верхней панели кнопок размещены команды, которые нужны постоянно, независимо от того, в какой части проекта вы сейчас работаете. В основном эти команды предназначены для того, чтобы открывать разделы справки онлайн и получать информацию о состоянии программы, сохранять данные проекта и создавать его резервную копию, а также для предварительного просмотра результатов работы в собственном браузере программы.

§Справка: нажатие кнопки «Помощь» открывает данное он-лайн Руководство Пользователя. Если нажать на стрелку слева от кнопки Справка то можно будет использовать следующие команды:

-Краткое описание...: открывает данное он-лайн Руководство Пользователя.

-Видео-учебник: открывает страницу сайта со списком учебных видеороликов, поясняющих как начать работу с программой WebSite X5.

-WebSite X5 Gallery: открывает раздел WebSite X5 Answers , содержащий сайты, созданные с помощью программы WebSite X5 , выложенные непосредственно авторами этих сайтов.

-Шаблоны WebSite X5 Templates: открывает раздел WebSite X5 Answers , относящийся к шаблонам. В нем содержатся новые шаблоны, созданные автором Incomedia и другими авторами. Их можно просмотреть и загрузить. Некоторые из них бесплатны!

-Техническая поддержка: открывает WebSite X5 Answers, это сайт, где можно получить техническую помощь по программе WebSite X5. На WebSite X5 Answers можно посмотреть часто задаваемые вопросы и руководства или отправить свою просьбу о помощи.

-www.websitex5.com: открывает сайт WebSite X5.

-О WebSite X5: отображает общую информацию о версии программы WebSite X5 установленной на вашем компьютере.

§Сохранить [CTRL + S]: сохраняет текущий Проект. Проект будет сохранен в Папка проектов заданной в окне Предпочтения. Можно использовать стрелку влево на кнопке Сохранить чтобы увидеть эти команды:

-Сохранять при каждом предпросмотре: автоматически сохраняет проект каждый раз при использовании команды Предпросмотр для предварительного просмотра сайта.

-Создать резервную копию при первом сохранении проекта: автоматически создает резервную копию вашего проекта (Backup.iwprj file) после того, как вы в первый раз за текущий сеанс работы сохранили данные.

-Создавать резервную копию каждый раз при выгрузке сайта: автоматически создает резервную копию вашего проекта (Uploaded_timestamp.iwprj file) перед публикацией сайта в Интернет.

Резервные копии, созданные командами Создать резервную копию при первом сохранении проекта и Создавать резервную копию каждый раз при выгрузке сайта сохраняются в папке для резервных копий, которую вы задаете в окне Предпочтения, и можете посмотреть здесь: Папка проектов.

Если вы хотите создавать резервную копию вашего проекта вместо использования команды Сохранить как можно использовать Сделать копию в окне Выбор проекта.

-Предпросмотр: предварительный просмотр сайта средствами встроенного браузера.

Если оставить включенной опцию Обновлять страницы по мере внесения изменений в проект в окне Предпочтения, то при каждом подтверждении изменения (путем нажатия кнопки OK или Далее Программа будет отображать все произошедшие изменения. При этом будет постоянно обновляться информация для предварительного просмотра Сайта в режиме офф-лайн, что позволит моментально загрузить нужную Страницу.

Если включить опцию Сохранять при каждом предпросмотре, то при каждом нажатии кнопки Предпросмотр будет создаваться копия Проекта.

Кликните, чтобы развернуть/уменьшить Боковая панель инструментов

Программа WebSite X5 позволяет создать Сайт за 5 простых этапов. Кнопки в левой части окна Программы всегда видны и указывают на текущий этап создания Сайта. От этапа к этапу можно переходить в любом порядке.

 | Выбор проекта
1. | Общие настройки
2. | Создание карты сайта
3. | Создание страницы
4. | Расширенные настройки
5. | Экспорт
Кликните, чтобы развернуть/уменьшить Нижняя панель инструментов

Нижняя панель кнопок представляет книпки, необходимые для навигации по программе:

§Назад: можно вернуться к предыдущему окну и внести изменения в выполненную ранее работу.

§Далее: можно перейти к следующему окну, чтобы продолжить создание Сайта.


Страница приветствия программы WebSite X5

Добро пожаловать в Incomedia WebSite X5

Рабочая среда >

Добро пожаловать в Incomedia WebSite X5

 Return to chapter overview

Страница приветствия — это первое окно, которое вы видите после запуска программы WebSite X5. Она включает несколько ссылок на интернет-ресурсы и вспомогательные материалы для работы с программой. Эти ссылки отображаются на вертикальной панели инструментов в левой части окна и выглядят вот так:

Обучающий видеокурс: открывает страницу сайта со списком учебных видеороликов, поясняющих как начать работу с программой WebSite X5.

WebSite X5 Галерея: открывает раздел WebSite X5 Answers , содержащий сайты, созданные с помощью программы WebSite X5 , выложенные непосредственно авторами этих сайтов.

WebSite X5 Шаблоны: открывает раздел WebSite X5 Answers , относящийся к шаблонам. В нем содержатся новые шаблоны, созданные автором Incomedia и другими авторами. Их можно просмотреть и загрузить. Некоторые из них бесплатны!

WebSite X5 Ответы: открывает WebSite X5 Answers, это сайт, где можно получить техническую помощь по программе WebSite X5. На WebSite X5 Answers можно посмотреть часто задаваемые вопросы и руководства или отправить свою просьбу о помощи.

Проверить наличие обновлений: проверяет наличие обновлений для установленной версии программы WebSite X5. Настоятельно рекомендуется всегда проверять, есть ли новые обновления, и устанавливать их. Только так вы сможете получить максимум от своей программы.

Предпочтения: открывает окно Предпочтения , где можно задать некоторые общие настройки программы.

Помимо этой панели инструментов, на странице приветствия также дается информация, обновляемая в режиме реального времени (если вы подключены к Интернету). Это сведения о последних версиях программы, доступных онлайн, новости, специальное содержимое (статьи, технические описания, полезные советы), новые обучающие видео-руководства и специальные предложения.

Если вы не подключены к Интернету, то страница приветствия показывает стандартную страницу. Такая же страница показывается, если окно Проверять наличие обновлений при запуске программы параметр Предпочтения не выбрано.

По завершении просмотра содержимого страницы приветствия можно начать работу, нажав кнопку Пуск.


Окно Предпочтения

Рабочая среда >

Окно Предпочтения

Return to chapter overview
Покажите/скройте невидемый текст

Это окно открывается при нажатии кнопки Предпочтения на Странице Приветствия. Здесь можно задать общие параметры работы Программы.

Кликните, чтобы развернуть/уменьшить Справка: Команды в окне Предпочтения

Параметры в разделе Общие следующие:

§Папка проектов— введите имя папки, где будет сохраняться файл Проекта (Project.IWPRJ), для нового Проекта и для существующего Проекта, который нужно импортировать (см. Выбор проекта | Импорт...). Если нажать кнопку Сохранить в процессе работы над Проектом, то файл Проекта будет автоматически сохранен в заданной папке.

§Проверять наличие обновлений при запуске программы— при каждом запуске Программа автоматически проверяет доступность своих обновлений. Программа устанавливает соединение с сервером Incomedia в поисках обновлений.

Мы рекомендуем оставить этот параметр выбранным, чтобы вы всегда работали с самой последней из возможных версий WebSite X5.

Настройки для Создание файла :

§Обновлять файлы предпросмотра при работе над проектом— гарантирует, что предварительный просмотр сайта постоянно обновляется по мере разработки вашего проекта. В основном это означает, что каждый раз, когда вы добавляете что-то новое или что-то меняете и нажимаете на кнопку OK или Далее , программа автоматически обновляет предварительный просмотр, который вы можете увидеть локально, на своем компьютере во встроенном браузере.

§Обновлять страницы по мере внесения изменений в проект— синхронизирует страницы, которые вы создаете для сайта по мере работы над проектом. Так что каждый раз, когда вы подтверждаете добавление или изменение (нажатием кнопки OK или Далее ), программа заново создает все части других страниц проекта, которые затронуты изменениями. Это свойство поддерживает предварительный просмотр сайта в актуальном состоянии. Если вы нажмимаете на кнопку Предпросмотр , чтобы увидеть, насколько вы продвинулись в разработке, вы увидите все добавления и изменения немедленно.

§Максимальное количество одновременных процессов— можно ограничить число запускаемых Программой процессов (потоков), которое будет одновременно выполняться компьютером.

Что такое многопоточность?

Разделение процесса на несколько одновременно выполняемых подпроцессов называется многопоточностью. Как правило, ваш компьютер должен уметь это делать. Окно Многопоточность это свойство позволяет добиться от компьютера максимальной производительности за счет выполнения нескольких потоков в одно и то же время. Благодаря этой технологии, такие программы, как %PRODUCT%>, специально разработаны для выполнения рабочей нагрузки с использованием нескольких потоков, что может заметно улучшить производительность.

Нужно точно оценить параметры аппаратной части вашего компьютера, чтобы убедиться, что он способен дать возможность воспользоваться преимуществами многопоточности. Попробуйте начать с 5 одновременных процессов, а затем постепенно увеличивайте это число до тех пор, пока не найдете оптимальное число потоков для данного компьютера.

И, наконец, параметр Локальный предпросмотр настроек веб-сервера влияет на правильность отображения предварительного просмотра сайта:

§Порт— — это порт, который WebSite X5 сообщает локальному веб-серверу, что нужно переключиться в режим предварительного просмотра, чтобы отображать сайт корректно.

§IP-адрес— это IP-адрес, который WebSite X5 сообщает локальному веб-серверу, что нужно отслеживать, чтобы отображать сайт корректно. По умолчанию значение IP-адреса равно 127.0.0.1, т.е. адрес настроен на ваш локальный компьютер. В большинстве случаев вам не нужно менять этот адрес.

Мы советуем не менять значения, которые вы уже настроили для Порт и IP-адрес параметры, за исключением случаев, когда вы абсолютно уверены в том, что делаете.

Лучшая практика:

-

Как организовать резервное копирование вашего проекта


Выбор проекта

Этап 0 - Выбор проекта >

Выбор проекта

 Return to chapter overview
Покажите/скройте невидемый текст

После запуска программы WebSite X5 сначала открывается Страница Приветствия, а затем — окно Выбор проекта, где можно выбрать нужный Проект.

Можно либо создать новый Проект, либо открыть существующий.

Кликните, чтобы развернуть/уменьшить Справка: Команды в окне Выбор проекта

§Создать новый проект— выберите эту опцию, чтобы создать новый Проект Сайта с нуля. Прежде всего, нужно задать имя новому проекту: напечатайте имя в поле внизу. Проект можно сохранить, нажав кнопку Сохранить, которая всегда отображается на верхней панели инструментов.

Полное имя пути при сохранении Проектов указывать не требуется, поскольку программа WebSite X5 автоматически сохраняет их в Папка проектов, указанной посредством окна Предпочтения.

§Редактировать существующий проект— эта команда открывает существующий Проект Сайта для продолжения работы над ним (или его обновления). Названия всех существующих Проектов показываются в списке. Есть несколько возможностей для того, чтобы выбрать и открыть проект, над которым вы хотите работать, вот они:

Показать большие значки - Показать заголовки - Показать список - Показать подробно

Эти параметры определяют способ отображения проекта при предварительном просмотре.

Отображать группы по порядку дат последнего редактирования

Этот пункт группирует и отображает проекты в соответствии с датами последнего редактирования.

Для организации своих проектов используйте следующие команды:

§Импорт...— эта команда импортирует проект, который ранее был создан и экспортирован (см. Экспортировать проект) с помощью WebSite X5 с другого компьютера.

§Переименовать— название выбранного Проекта можно изменить. Либо можно дважды щелкнуть на имени проекта, чтобы сменить его.

§Сделать копию— можно создать копию выбранного Проекта.

§Удалить— выбранный Проект можно удалить.

Лучшая практика:

-

Как организовать резервное копирование вашего проекта


Общие настройки

Этап 1 - Общие настройки >

Общие настройки

 Return to chapter overview
Покажите/скройте невидемый текст

Это первое окно Этапа 1. Информация, введенная в этом окне, определяет основные параметры проекта, над которым вы работаете.

В этом окне вводится важная информация, например название проекта, URL (интернет-адрес), используемый язык и коды и метатэги, необходимые для активации внешних сервисов, таких как статистика сайта. Эти параметры можно ввести сразу или задать позже.

Доступные параметры этого окна организованы в два раздела: Основной и Эксперт.

Кликните, чтобы развернуть/уменьшить Справка: Параметры раздела Основной

§Название сайта: введите в это поле название своего сайта. Название будет отображаться в строке заголовка браузера в точно таком же виде, как здесь. Название, как правило, важный параметр, поскольку позволяет посетителям и поисковым системам идентифицировать ваш сайт.

По умолчанию это поле содержит название, первоначально данное проекту (см. Выбор проекта). Однако название сайта можно изменить в любое время, например, при поисковой оптимизации сайта.

§Автор сайта: введите имя автора сайта, например, фамилию разработчика или название фирмы, клуба или организации. Имя автора будет вставлено в мета-тег <author> в HTML-коде страницы сайта и является своеобразным электронным эквивалентом авторской подписи.

§URL сайта: введите URL-адрес, по которому сайт можно будет найти после размещения в Интернете (например, http://www.mywebsite.ru. Этот адрес важен для правильной работы RSS-лент, Корзины и карты сайта для правильной работы (программа автоматически создает карту сайта и создает ссылки на разные страницы сайта).

§Описание сайта: введите в это поле краткое описание сайта. Важно сформулировать описание четко и по существу. Этот текст используется для заполнения мета-тега <description> в HTML-коде, так что поисковые системы смогут искать по нему сайт и включить его в выдачу результатов поисковых систем.

§Ключевые слова сайта: введите список ключевых слов, имеющих отношение к вашему сайту (через запятую). Ключевые слова используются для заполнения мета-тега <keywords> в HTML-коде страницы и считываются поисковыми роботами для индексации сайта.

Код Описание сайта и Ключевые слова сайта которые вы ввели в этих полях, автоматически связываются с главной страницей сайта.

Однако, вы можете провести поисковую оптимизацию сайта, если введете описание и список ключевых слов не только обие по сайту, но и свои для каждой страницы (или хотя бы важнейших из них). Чтобы сделать это, перейдите в раздел Создание карты сайта, выберите нужную страницу и нажмите кнопку Свойства....

§Язык контента:: укажите в этом поле язык, используемый на сайте. Выбранный язык будет использоваться для всех текстовых элементов, автоматически вставляемых программой, таких как встроенные закладки, надписи Объект-форма обратной связи, надписи и текст для Корзины, а также текст на карте сайта.

Чтобы изменить автоматически вставляемый программой текст или добавить новый язык, нажмите кнопку [image] и задайте настройки в окне Управление языковым контентом. ..

§Значок сайта: введите имя для пиктограммы (файл формата *.ICO, *.GIF, *.JPG или *.PNG), связанной со страницами сайта. Эта пиктограмма будет отображаться слева от URL-адреса в адресной строке браузера.

Пиктограммы, связанные с сайтом, часто называют фавиконами (от favorite icons; букв. «любимая пиктограмма»). Можно использовать форматы изображений .ICO, .PNG, .GIF and .JPG. Файлы .ICO импортируются, а если вы используете файлы любых размеров в форматах .PNG, .GIF и .JPG, WebSite X5 автоматически создает копии в формате .PNG размером 16 на 16 пиксел и использует из в качестве фавикона.
Кликните, чтобы развернуть/уменьшить Справка: Параметры в разделе Эксперт

§Пользовательский код: указывает, где находится пользовательский код, который нужно добавить к HTML-коду страницы: Перед закрывающим тегом HTML, Перед закрывающим тегом HEAD, Атрибуты тега BODY (style, onload и т.д.) (т.е. в качестве части тэга <BODY>, например, так: <BODY onload="alert('Hello!')">), Перед закрывающим тегом BODY, После закрывающего тега BODY. Когда вы определитесь, куда нужно помещать ваш код, напечатайте его там или скопируйте часть кода в поле.

Это поле можно использовать, например, для активации сервиса сбора статистики по посещаемости сайта, такого как Google Analytics™.

Для получения дополнительной информации о сервисе Google Analytics™ и для заведения на нем своей учетной записи, нажмите на [image] кнопку доступа на официальный сайт: http://www.google.it/analytics/.

§Мета-тег для распознавания в Google Webmaster Central: введите проверочный мета-тег для использования инструментов Google Webmaster Central™.

Для получения дополнительной информации о сервисе Google Webmaster Central™ и для регистрации в нем нажмите кнопку [image], чтобы перейти на официальный сайт http://www.google.com/webmasters/.

§Автоматически создать карту сайта: активно по умолчанию и карта сайта и ссылка на нее создаются автоматически.

Чтобы созданная карта сайта была работоспособна, важно указать правильный URL-адрес в поле URL сайта в разделе Общие настройки | Основной.

§Включить защиту HTML-кода: это включает применение защиты при публикации страниц сайта тем, что запрещает нажатие правой кнопки мыши. Посетитель не может посмотреть исходный код страниц с помощью контекстного меню, которое открывается при нажатии правой кнопки мыши на странице.

Лучшая практика:

- | Как автоматически переводить вводимый текст
- | Как пользоваться Google Webmaster Central™
- | Как получить доступ к сервису сбора статистики, например, к Google Analytics™

-

Как создать карту сайта и ссылку на нее

Родственные темы:

-

Веб-браузер и встроенный браузер WebSite X5


Окно Управление языковым контентом. .

Этап 1 - Общие настройки > Общие настройки >

Окно Управление языковым контентом. .

 Return to chapter overview

Это окно открывается по нажатию кнопки [image] пункта Язык контента: в окне Общие настройки | Основной. Можно работать над текстом, который программа создает автоматически, например ссылки для построения внутренних указателей, кнопки для Объект в галерее, заголовки для Объект-форма обратной связи, заголовки и текст для Корзина, текст на карте сайта.

Окно Управление языковым контентом. отображает слева список возможных языков, а справа таблицу с переводами на различные языки. Первый столбец в таблице содержит указания: где в программе используются различные элементы. Затем идут три столбца для каждого активного языка (т.е. выбранные из списка доступных языков). Можно работать непосредственно с этой таблицей, добавляя и редактируя новые элементы.

Окно Управление языковым контентом. отображает следующие кнопки:

Добавить новый язык: введите название нового языка, чтобы добавить его к диалоговому окну. Нужно использовать формат «ID - название языка», например, «EN - English».

Удалить выбранный язык: удаляет выбранный язык из списка.

Импортировать новый язык: импортирует новый язык, сохраненный в виде файла *.XML, и добавляет его к списку доступных языков.

Экспорт выбранного языка: экспортирует язык, выбранный из списка в файл *.XML.

Пункты Экспорт выбранного языка и Импортировать новый язык полезны, когда вы хотите сохранить перевод на конкретный язык в виде файла *.XML и использовать его на другом компьютере.

Лучшая практика:

- | Как автоматически переводить текст
- | Как создать многоязычный сайт


Выбор шаблона

Этап 1 - Общие настройки >

Выбор шаблона

 Return to chapter overview
Покажите/скройте невидемый текст

Для успеха Сайта весьма немаловажно привлекательно его оформить. Как говорится, встречают по одежке, и первое впечатление новых посетителей о сайте — еще до ознакомления с его содержимым — будет определяться внешним видом сайта. Сайт с продуманным, профессионально выглядящим дизайном производит впечатление качественного ресурса, с которым стоит ознакомиться.

WebSite X5 дает вам две возможности для разработки своих сайтов:

1. можно создать свой шаблон, либо начав с нуля, либо взяв за основу один из готовых шаблонов;

2. можно использовать готовый шаблон, выбрав его из галерею из более 1.500 шаблонов, включенную в поставку программы.

В обоих случаях - и свой и готовый шаблон - можно менять, что-то добавлять к нему, используя разнообразную функциональность, рпредлагаемую встроенным редактором, показанным в окне Редактировать шаблон.

Все готовые шаблоны оптимизированы для отображения при разрешении экрана в 1024 x 768 пиксел. Если хотите использовать другое разрешение, примените Настроить шаблон.
Кликните, чтобы развернуть/уменьшить Справка: Команды в окне Выбор шаблона

Большая часть окна Выбор шаблона предназначена для отбражения доступных шаблонов. Можно использовать следующие команды для того, чтобы отфильтровать шаблоны при отображении (чтобы было легче выбирать):

Список категорий

Этот пункт показывает список различных категорий, в которые организованы шаблоны, так что можно выбрать одну для просмотра. Первая категория содержит все пользовательские шаблоны, созданные с нуля. Ее видно только если там уже есть хотя бы один шаблон. Другие категории содержат различные готовые шаблоны, которыми можно воспользоваться.

Меню

Этот пункт выбирает готовые шаблоны в соответствии с их типами меню. Можно выбрать шаблоны либо с горизонтальным, либо с вертикальными меню, либо с обоими.

Маленькое изображение - Среднее изображение - Большое изображение

Эти параметры определяют способ отображения шаблонов.

Редактировать цвета шаблона

Эта команда открывает окно Цвета шаблона, в котором можно изменить цвета выбранного шаблона.

Для работы с шаблонами доступны следующие команды:

§Новый шаблон: начинает создание нового шаблона с нуля. Эти шаблоны добавляются в категорию пользовательских шаблонов.

§Переименовать: используйте эту команду, если хотите переименовать шаблон. Переименовывать можно только пользовательские шаблоны. Нельзя изменить названия готовых шаблонов. Нельзя также сменить название шаблона двойным щелчком мыши на его имени.

§Сделать копию: эта команда создает копию выбранного шаблона.

§Удалить: эта команда удаляет выбранный шаблон. Команда применима только к пользовательским шаблонам: готовые шаблоны удалять нельзя.

§Редактировать...: эта команда открывает шаблон в окне Редактировать шаблон, где его можно редактировать. Редактировать можно только пользовательские шаблоны. Если вы хотите отредактировать готовый шаблон, в начале нужно сделать его копию, нажав на кнопку Сделать копию.

§Импорт...: эта команда импортирует новый шаблон (в виде файла .IWTPL), созданный в программе WebSite X5 и экспортированный из нее.

§Экспорт...: эта команда экспортирует выбранный шаблон (в виде файла .IWTPL) в указанную папку. Шаблоном можно поделиться с другими и использовать его на других компьютерах.

Замечания о совместимости с предыдущими версиями:

§Горизонтальные и вертикальные меню - В предыдущих версиях программы (до 8 версии) выбор между горизонтальными и вертикальными меню производился в окне Выбор меню , а в 9 версии был специальный пункт Тип меню . В 10 версии вы просто должны взять готовый шаблон с нужным типом меню. Если вы создаете свой шаблон, нужно указать для параметра Тип меню желаемое значение.

§Цвета - В 8 версии каждый готовый шаблон был доступен в четырех различных цветовых схемах. В 9 версии цветовые схемы заменили на цветовые стили, которые предлагали различные цветовые палитры, настройки и изображения. В 10 версии различия между различными стилями ликвидировали: теперь каждый шаблон имеет собственный стиль и/или настройки, и каждый появляется в полном списке шаблонов.

Лучшая практика:

- | Как работать с шаблонами
- | Где можно найти новые шаблоны для программы WebSite X5


Окно Цвета шаблона

Выбор шаблона | Цвета шаблона

Этап 1 - Общие настройки > Выбор шаблона >

Выбор шаблона | Цвета шаблона

 Return to chapter overview

Это окно открывается при нажатии кнопки [image] в окне Выбор шаблона. Можно сменить цвета собственного или готового шаблона, над которым вы работаете.

Чтобы установить желаемый цвет, просто перемещайте курсор по элементу управления Цвет слева направо.

Благодаря этой возможности, количество вариантов внешнего вида шаблона практически неограничено.

Подстройка цвета затрагивает все элементы шаблона, хотя ее действие не заметно на черном, белом и сером.

Лучшая практика:

- | Как работать с шаблонами
- | Где можно найти новые шаблоны для программы WebSite X5


Настроить шаблон

Этап 1 - Общие настройки >

Настроить шаблон

 Return to chapter overview
Покажите/скройте невидемый текст

WebSite X5 позволяет создать свой собственный шаблон, начав с чистого листа. Нажмите на кнопку Новый шаблон в окне Выбор шаблона чтобы запустить предварительный просмотр нового шаблона в категории Пользовательские: дважды щелкните на превью, чтобы открыть окно Настроить шаблон, где можно начать создание своего шаблона.

Чтобы облегчить задачу, в окне Настроить шаблон есть окошко Предпросмотр компоновки Страницы. Выберите в списке участок шаблона, с которым нужно работать, или просто нажмите на нужный участок Страницы. После этого можно применять доступные опции и сразу увидеть результат.

Кликните, чтобы развернуть/уменьшить Справка: Параметры типа меню

Сначала задайте Тип меню, т. е. определите, где и как будет отображаться главное меню на Страницах Сайта. Можно выбрать один из этих вариантов:

Горизонтально - меню над 'шапкой' сайта

Горизонтально - меню под 'шапкой' сайта

Вертикально - меню слева

Вертикально - меню справа
Кликните, чтобы развернуть/уменьшить Справка: Параметры раздела страницы

После выбора типа Меню следует выбрать Раздел страницы для настройки. Страницы разбиты на следующие части:

Фон страницы— это область, окружающая Страницу Сайта. Фон показывается в случае, если размеры окна Браузера превышают размер Страницы Сайта.

Фон 'шапки' страницы— это часть Фон страницы , точно соответствующая Шапка' страницы.

Шапка' страницы— «шапка» - это то, что находится сверху страницы. Обычно в основном эта часть состоит из графических элементов. К тому же это идеальное место для названия сайта и подзаголовка, логотипа компании, полей поиска, служебных меню со ссылками на такие элементы, как карта сайта и выбор языка отображения.

Меню— здесь располагается фиксированное навигационное меню. Это меню отображает первый уровень возможного выбора и появляется в этом же месте на любой странице сайта. Этот раздел может быть сверху, снизу, слева или справа на странице в зависимости от выбранного типа меню.

Контент страницы— здесь задается реальное содержимое Страницы, а также подменю (если таковые используются).

Подвал' страницы— этот раздел находится внизу страницы и, также как и «шапка» сайта в основном содержит графику. Визуально он завершает страницу. Часто используется для размещения замечаний, разъяснений, записей об авторских правах, бизнес-реквизитов, электронных адресов и т.д.

Фон 'подвала' страницы— это часть Фон страницы, точно соответствующая по высоте Подвал' страницы.

Если настроить Фон 'шапки' страницы или Фон 'подвала' страницы в качестве прозрачного, его можно использовать как часть Фон страницы и тогда он будет выглядеть точно. Если они не прозрачны то Шапка' страницы и/или Подвал' страницы будут выглядеть как полоски, перекрывающие всю ширину окна браузера.
Кликните, чтобы развернуть/уменьшить Справка: Графика раздела страницы свойства

Можно задать следующее Свойства графики для различных разделов страницы:

§Цвет фона— указывает цвет для заливки фона.

§Фоновое изображение— указывает на файл изображения (в форматах .JPG, .GIF или .PNG), используемого в качестве фона. В Шапка' страницы или Подвал' страницытакже можно поместить Flash-анимацию (файл формата SWF).

§Положение— эта опция позволяет повторять изображение фона. Оно может повторяться горизонтально, вертикально или в обоих направлениях (так, чтобы покрыть всё имеющееся пространство). При настройке Фон страницы можно также сделать так, что изображение покроет весь фон. Следует учитывать, что в этом случае исходные пропорции изображения могут не сохраниться

§Выравнивание— укажите, как вставленное изображение должно быть выровнено в текущем разделе страницы.

В разделе Фон страницы доступна следующая настройка:

§Фиксированный фон— при выборе этой возможности, фоновое изображение страницы, остается на месте даже при прокрутке страницы.
Кликните, чтобы развернуть/уменьшить Справка: Размеры области страницы

Можно задать Размеры для некоторых разделов страницы.

В разделах Шапка' страницы и Меню доступна следующая настройка:

§Ширина— ширина текущего раздела Страницы (в пикселах). Значение Ширина в случае Вертикального Типа Меню по умолчанию оставляет 960 пикселов для Шапка' страницы и 120 пикселов для Меню, но эти значения можно изменить. Значение Ширина для горизонтальных меню, настроенных на Шапка' страницы также используется для Меню, Контент страницы и Подвал' страницы.

По умолчанию Ширина рассчитывается для оптимального отображения Сайта при разрешении экрана 1024 x 768 пикселов.

Следующие параметры подходят для разделов за исключением Фон страницы и Контент страницы:

§Высота— высота текущего раздела Страницы (в пикселах).

Следующие параметры только для раздела Контент страницы:

§Минимальная высота— задает минимальную высоту в пикселах, которую должна иметь область контента страницы, независимо от объема контента.

Кликните, чтобы развернуть/уменьшить Справка: Свойства области контента

Можно задать Свойства контента для некоторых разделов страницы.

Для разделов Фон страницы, Меню и Контент страницы доступны следующие опции:

§Поля— задайте размер верхнего и нижнего полей (в пикселах). Под полем здесь понимается пространство между внешним краем раздела и его содержимым.

Этот параметр можно использовать для разделов Фон страницы и Меню:

§Выравнивание— для Фон страницы, он определяет как будет выравниваться страница в окне браузера; для Меню он задает как выравниваются кнопки меню относительно страницы.

Действительная ширина Страниц Сайта определяется шириной раздела Контент страницы (в зависимости от ширины Шапка' страницы), за вычетом ширины левого и правого полей.

Верхний колонтитул шаблона можно дополнить текстом, изображениями, Flash-анимациями, слайд-шоу, полями «поиск» и ссылками. Соответствующие опции представлены в окне Редактировать шаблон , для открытия которого нужно нажать кнопку Далее.

Лучшая практика:

- | Как работать с шаблонами
- | Где можно найти новые шаблоны для программы WebSite X5


Редактировать шаблон

Этап 1 - Общие настройки >

Редактировать шаблон

 Return to chapter overview
Покажите/скройте невидемый текст

После выбора шаблона в окне Выбор шаблона или создания своего шаблона в окне Настроить шаблон можно перейти к разделу Редактировать шаблон. Можно настроить Шапка' страницы и Подвал' страницы шаблона, добавив Текст, Изображения, Flash-анимацию, Слайд-шоу, HTML-код, Поля Поиска и Ссылки.

Команды и параметры для Шапка' страницы и Подвал' страницы идентичны.

Flash-анимацию, используемую в качестве фона для Шапка' страницы и Подвал' страницы, нельзя настроить в окне Редактировать шаблон.
Кликните, чтобы развернуть/уменьшить Справка: Редактор шаблонов

В окне Редактировать шаблон находится графический редактор. Под панелью инструментов находится фоновое изображение для верхней и нижней частей выбранного вами шаблона (по умолчанию или настроенного). Изображение показывается в масштабе 1:1, и его можно прокрутить вверх или вниз. Любые изменения этого изображения отображаются в реальном режиме времени.

В строке состояния под изображением дается следующая информация:

§Положение — координаты X и Y верхнего правого угла выбранного Объекта.

§Размер — ширина и высота выбранного Объекта (в пикселах).
Кликните, чтобы развернуть/уменьшить Справка: Параметры панели инструментов

Можно использовать параметры панели инструментов для добавления новых объектов к шаблону Шапка' страницы / Подвал' страницы и задать для них некоторые настройки. Добавив Объект, его можно выбрать и модифицировать посредством опций, показываемых в разделе под графическим редактором.

Вырезать [CTRL+X] - Копировать [CTRL+C] - Вставить [CTRL+V]

Можно вырезать, скопировать или вставить выбранный Объект.

Отменить [CTRL+Z]

Можно отменить последнюю операцию.

Переместить вперёд - Переместить назад

Выбранный Объект можно вынести на передний план, чтобы он отображался поверх остальных Объектов, или убрать на задний план, расположив его позади остальных Объектов.

Вставить ссылку на этот объект

Создать гипертекстовую ссылку на выбранный текст, изображение или слайд-шоу. Ссылка задается в окне Ссылка.

Положение и размер

Чтобы открыть другое окно и задать координаты, которые определяют положение и размеры выбранного объхекта. Опция Сохранять Пропорции позволяет сохранять исходные пропорции Объекта при изменении его размера.

Вставить текст - Вставить изображение - Вставить Flash-анимацию - Вставить слайд-шоу - Вставить HTML-код - Вставить поле поиска

Можно вставить Текст, Изображение, Flash-анимацию, Cлайд-шоу, HTML-код или Поле «Поиск».

Слайд-шоу - это ряд изображений, которые автоматеически сменяют одно другое. Это полезный объект для создания баннеров (в частности для рекламы).

Можете использовать HTML-код для добавления контента любого рода, даже такого, у которого нет определенного объекта.

В программе WebSite X5 есть встроенная Поисковая Система, которую можно использовать для поиска текста, введенного в Поле «Поиск», по всему Сайту.

Любые объекты с Flash-анимацией или HTML-кодом, добавленные вами, будут отображаться только когда сайт будет открыт в браузере.
Кликните, чтобы развернуть/уменьшить Справка: Настройки для объекта Шапка' страницы / Подвал' страницы

Нажмите на фоновое изображение разделов Шапка' страницы и Подвал' страницы, чтобы выбрать их и применить следующие команды:

§Сохранить как JPG: при создании Сайта Объекты «Текст» и «Изображение», добавляемые в Шапка' страницы/Подвал' страницы, будут объединены с фоновым изображением и сохранены вместе с ним в новом файле формата PNG. Этот формат выбран из-за того, что в нем сохраняются и поддерживаются все настройки прозрачности. Если уровни прозрачности не используются, выберите опцию Сохранить как JPG, чтобы уменьшить размер файла фонового изображения.
Кликните, чтобы развернуть/уменьшить Справка: Настройки для объекта Текст

Можете выбрать объект Текст в Шапка' страницы / Подвал' страницы и использовать следующие параметры для работы над ним:

§Содержание— чтобы ввести или вставить скопированное текстовое содержание в это поле.

§Шрифт— чтобы задать тип, стиль и размер шрифта для текста.

§Цвет текста / Цвет Фона— чтобы задать цвет текста и фона.

§Сохранить как PNG— если этот параметр активен, текст не сливается с фоновым изображением Шапка' страницы/Подвал' страницы, а, вместо этого, будет сохранен как изображение в формате *.PNG с прозрачной подложкой. Исходный текст автоматически ассоциируется с изображением *.PNG в виде наполнения тега ALT.
Кликните, чтобы развернуть/уменьшить Справка: Настройки для объекта Изображение

Можете выбрать объект Изображение в Шапка' страницы/Подвал' страницы и использовать следующие параметры для работы над ним:

§Файл изображения— выберите файл, содержащий Изображение, которое нужно добавить. Можно использовать файлы следующих форматов: JPG, GIF, PNG, BMP, PSD, TIF, DIB, PCX, RLE, TGA, WMF.

§Файл изображения, отображаемого при наведении мыши— можно задать второй графический файл, который будет отображаться при наведении курсора мыши на Изображение. Эту опцию можно использовать для создания кнопок, вид которых изменяется при нажатии и отпускании.

§Разрешить прозрачность— если включить эту опцию, то Изображение станет прозрачным, так что данный цвет станет невидимым.

§Прозрачный цвет— чтобы задать какой из цветов изображения соответствует прозрачному, если выбран параметр Разрешить прозрачность. В этом случае пригодится инструмент «Пипетка», позволяющий взять пробу цвета прямо с Изображения.

§Допуск прозрачности— для прозрачности можно задать коэффициент допуска. Чем выше допуск, тем больше будет прозрачная область Изображения.
Кликните, чтобы развернуть/уменьшить Справка: Настройки для объекта Flash-анимация

При выборе объекта Flash-анимация, который вы добавили к разделу Шапка' страницы/Подвал' страницы, можно работать со следующими параметрами:

§Файл flash-анимации— выберите файл *.SWF, содержащий Flash-анимацию, которую вы хотите добавить.

§Прозрачный фон— этот параметр устанавливает для анимации прозрачный фон.
Кликните, чтобы развернуть/уменьшить Справка: Настройки для объекта Слайд-шоу

При выборе объекта Слайд-шоу, который вы добавили к разделу Шапка' страницы/Подвал' страницы доступны следующие параметры:

§Список Изображений здесь перечислены изображения для слайд-шоу и задано имя файла для каждого из изображений. Здесь также помечено, какие эффекты и/или ссыоки связаны с ними. Выберите файл из списка для предварительного просмотра слайд-шоу. Используйте CTRL + нажатие и SHIFT + нажатие для выбора нескольких объектов.

§Добавить... / Удалить— можно добавить новые изображения в Cлайд-шоу или удалить какие-то изображения из списка. Можно вырать одновременно несколько объектов из библиотеки изображений.

§Сдвинуть вверх / Сдвинуть вниз — изменить порядок показа изображений в Cлайд-шоу. Выберите изображение и сдвиньте его вверх или вниз в Списке Изображений.

§Эффекты...— эта команда открывает окно Название эффекта, где можно задать тип эффекта, масштабирование и положение для изображений в Cлайд-шоу, а также ссылки на другие Страницы, где показывается выбранное изображение.

§Автовоспроизведение— эта опция включена по умолчанию и означает, что показ Cлайд-шоу запускается автоматически.

§Случайный вид— эта опция позволяет показывать изображения в Cлайд-шоу в случайном порядке (а не в том порядке, в котором они идут в Списке Изображений).
Кликните, чтобы развернуть/уменьшить Справка: Настройки для объекта HTML-код

Выберите HTML-код добавляя к разделу Шапка' страницы/Подвал' страницы, чтобы использовать следующие объекты:

§HTML-код— наберите здесь или вставьте HTML-код объекта, который хотите создать. Панель инструментов предлагает следующие команды:

Вырезать [CTRL+X] - Копировать [CTRL+C] - Вставить [CTRL+V]

Эти команды вырезают, копируют и вставляют выделенный текст.

Отменить [CTRL+Z] - Восстановить [ALT+CAPS+BACKSPACE]

Эти команды отменяют или заново выполняют последнюю проведенную операцию.

Добавить виджеты

Эта опция вствляет код выбранного виджет: нажмите на стрелку рядом с кнопкой, чтобы развернуть полный список доступных виджетов в том виде, как он показывается в Объект HTML и виджеты. Нажмите на нужный виджет, чтобы открыть окно нас троек виджета, где можно задать необходимые параметры. После подтверждения виджет наполняется HTML-кодом и автоматически добавляется в редактор.

§Отображать полосы прокрутки— этот параметр отображает полосы прокрутки.

Замечания о совместимости с предыдущими версиями:

В предфдущей версии 9, этот HTML-код редактор позволял добавлять сниппеты (несколько строк кода) автоматически. В текущей, 10 версии, функциональность сниппетов была существенно улучшена, и теперь они добавились к списку виджетов.
Кликните, чтобы развернуть/уменьшить Справка: Настройки для объекта Поле поиска

При выборе объекта Поле поиска в разделе Шапка' страницы/Подвал' страницы, можно работать со следующими параметрами:

§Текст для кнопки— можно ввести текст для добавления на кнопку, запускающей поиск.

§Тип шрифта — в открывающемся окне можно настроить тип, стиль и размер шрифта.

§Цвет полей— можно выбрать цвета текста и фона полей строкового поиска.

§Цвет кнопок— можно выбрать цвета текста и фона кнопки поиска.

§При добавлении Поле поиска к шаблону Шапка' страницы/Подвал' страницы специальная страница автоматически добавляется к карте сайта под именем «Поиск»: можете выбрать ее и открыть окно Свойства страницы, чтобы задать свойства.

§Результаты поиска по Сайту отображаются на Страницах, автоматически генерируемых Программой. Графическое оформление этих Страниц настраивается в разделе Стили и модели (Этап 4 – Расширенные настройки).

Кликните, чтобы развернуть/уменьшить Справка: Параметры для Эффекты

При выборе объекта Текст, Изображение или Слайд-шоу в разделе Шапка' страницы/Подвал' страницы можно задать различные спецэффекты для этого объекта. Возможные объекты перечислены далее Тип эффекта.

Можно выбрать более одного эффекта для каждого объекта Текст, Изображение и Слайд-шоу. Вы должны указать настройки для каждого эффекта:

Эффект

Настройки

Отбрасывание Тени

§Диффузия — укажите концентрацию цвета, применяемую к тени Объекта.

§Цвет: задает цвет тени.

§Смещение X / Смещение Y — эти значения задают горизонтальное (вертикальное) положение тени по отношению к Объекту. Положительное значение означает смещение тени вправо и вниз, а отрицательное — влево и вверх.

Отражение

§Диффузия: указывает насколько сильным должно быть отражение объекта.

§Расстояние — расстояние отражения от Объекта.

Цветная кромка

§Толщина — задайте толщину кромки Объекта (в пикселах).

§Цвет: задает цвет границы.

Внешнее Свечение

§Диффузия — укажите концентрацию внешнего свечения.

§Цвет: задает цвет внешнего свечения.

Скос

§Глубина — задайте выраженность скоса.

§Диффузия — укажите концентрацию скоса.

§Угол — задайте угол скоса.

Поворот

§Угол — задайте угол поворота Объекта по часовой стрелке (в градусах).

Непрозрачность

§Непрозрачность — задайте степень прозрачности Объекта (от 0 до 255). Чем меньше (ближе к нулю) это значение, тем выше прозрачность Объекта.

Размытие

§Диффузия — задайте концентрацию размытия.

Волна

§Диффузия — задайте ширину волны.

§Частота — задайте близость соседних волн друг к другу.

Перспектива

§Горизонтальная — задайте точку схода для эффекта перспективы справа (положительные значения) или слева (отрицательные значения).

§Вертикальная — задайте точку схода для эффекта перспективы внизу (положительные значения) или вверху (отрицательные значения).

Наклон

§Горизонтальный — разместите точку на горизонтальной линии и задайте искажение в направлении этой точки, направо (положительные значения) или налево (отрицательные значения).

§Вертикальный — разместите точку на вертикальной линии и задайте искажение в направлении этой точки, вниз (положительные значения) или вверх (отрицательные значения).

Лучшая практика:

- | Как работать с шаблонами
- | Где можно найти новые шаблоны для программы WebSite X5

Родственные темы:

-

Как работает поисковый движок в программе WebSite X5


Создание карты сайта

Этап 2 - Создание карты сайта >

Создание карты сайта

 Return to chapter overview
Покажите/скройте невидемый текст

Сайт — это структурированный набор Страниц. При создании структуры Сайта важно иметь ясное представление о том, как именно Страницы Сайта должны быть связаны между собой, чтобы посетителям было удобно перемещаться по Сайту.

На хорошо структурированном сайте невозможно заблудиться; посетитель всегда знает, где находится, и может быстро найти нужную информацию. Плохо структурированный сайт сбивает с толку; в худшем случае, посетители будут навсегда уходить с такого сайта.

Структура Сайта создается при помощи окна Создание карты сайта. Сюда можно вставлять Страницы и организовывать их по уровням и подуровням. После определения структуры Карты Сайта с названиями Страниц можно перейти к этапу добавления содержимого на Страницы. Нажимайте несколько раз на кнопку Далее чтобы открывать страницы в том же порядке, как они были добавлены на карту сайта. Либо можно использовать карту сайта, чтобы открыть окно программы, где можно непосредственно работать с выбранной страницей: дважды щелкните на элементе карты или выберите элемент и щелкните на Далее.

Кликните, чтобы развернуть/уменьшить Справка: Карта сайта

Большую часть окна Создание карты сайта занимает дерево Карты Сайта — схематическое представление создаваемой Карты Сайта.

По умолчанию предлагается использовать базовую схему. Здесь находится папка меню, содержащая главную страницу и еще три других. Можно использовать доступные команды для добавления уровней, страниц и разделителей, чтобы создать такую карту сайта, какую вы хотите.

Если вы используете различные разделы на Этапе 4 - Расширенные настройки , чтобы добавить встроенную поисковую систему (см. Редактировать шаблон, Страница приветствия, блога, защищенной области (она вам понадобится только если есть защищенные страницы) или Корзина, то автоматически будет добавлена папка Особые Страницы , содержащая следующие элементы: поиск, страница приветствия, блог, регистрация и Корзина.

Помимо дерева Карты Сайта, при вставке Страниц отображается и другая полезная информация, такая как Расширенный Заголовок и Описание страницы. Эта информация берется из настроек, заданных в окне Свойства страницы.
Кликните, чтобы развернуть/уменьшить Справка: Команды панели инструментов

Панель инструментов над картой сайта предлагает следующие команды:

Вырезать [CTRL+X] - Копировать [CTRL+C] - Вставить [CTRL+V]

Можно вырезать, копировать и вставлять выбранные Страницы в текущем Проекте или в другом Проекте. Эти же команды представлены во всплывающем меню, появляющемся при нажатии правой кнопкой мыши на Карту Сайта.

Развернуть - Свернуть

Эти команды позволяют разворачивать и сворачивать выбранный уровень, чтобы показывать или скрывать в нем страницы.

Скрытая страница в меню

Эта опция позволяет не показывать данную Страницу или Уровень на Карте Сайта. Если уровень скрыт, то скрыты и все его Страницы. Скрытые Страницы можно использовать для добавления информации по какой-то теме или для создания ссылок на дополнительные сведения. Важно помнить о необходимости создания хотя бы одной ссылки на скрытую Страницу.

Защищенная страница

Эта команда открывает окно Защищенная страница, где можно Закрыть Страницу, выбрав опцию Защитить эту страницу. Затем следует задать Группы или отдельных Пользователей, имеющих право доступа к Закрытой Странице, нажимая на их имена в соответствующем списке. Предоставление доступа для Группы — это не то же самое, что предоставление доступа для всех Пользователей этой Группы. Если в дальнейшем в Группу будут добавляться новые пользователи, то они автоматически получат доступ к Закрытой Странице лишь в случае наличия доступа у этой Группы.

Кликните, чтобы развернуть/уменьшить
Защищенная страница

Для создания новых Групп или Пользователей откройте окно Управление доступом (Этап 4 - Расширенные настройки).

§На карте сайта можно скрыть даже главную страницу, но так делать можно лишь в том случае, если вы собираетесь дать ссылку на нее в других местах сайта, например, в заголовке.

§Если вы хотите создать свое навигационное меню, можно скрыть все страницы и уровни на карте сайта: вместо того, чтобы выбирать страницы по одной, можно выбрать папку меню и нажать на кнопку Скрытая страница в меню.

Кликните, чтобы развернуть/уменьшить Справка: Команды для формирования карты сайта

Вот команды для формирования карты сайта:

§Новый уровень [CTRL+L]: можно добавить новый Уровень меню. Общее число Уровней и подуровней практически неограниченно.

§Новая страница [CTRL+P]: можно добавить новую Страницу, которая будет автоматически вставлена на текущем Уровне.

§Разделитель: для визуальной организации Карты Сайта можно добавлять разделители. В качестве разделителя можно использовать пробел или заголовок. Разделители часто применяются при создании многостолбцовых Карт Сайта; см. Стиль раскрывающегося меню | Пункты меню (Этап 4 - Расширенные настройки).

§Удалить [DEL]: удалить выбранную страницу, уровень или разделитель.

§Переименовать [F2]: сменить название выбранной страницы, главной страницы, уровня или разделителя. Важно правильно называть Уровни или Страницы, поскольку эти названия будут отображаться в меню Сайта, а также в названиях Страниц. Кроме того, эти названия будут использоваться для именования HTML-файлов, автоматически создаваемых для каждой Страницы (если в окне Свойства страницы не указано иное).

§Сдвинуть Вверх [CTRL+U] / Сдвинуть Вниз [CTRL+D]: можно изменить порядок Страниц или Уровней на Карте Сайта, поместив выбранный элемент до предыдущего или после следующего.

Изменить порядок Страниц или Уровней можно и непосредственно на Карте Сайта, перетащив мышью элемент, который нужно сдвинуть, и отпустив его в нужном месте. Для выбора нескольких позиций используйте клавиши CTRL и SHIFT.

§Свойства...: задать свойства выбранной странице (в окне Свойства страницы), или уровню (в окне Свойства уровня).

Лучшая практика:

-

Как создать карту сайта и работать с ней


Окно Свойства уровня

Этап 2 - Создание карты сайта > Создание карты сайта >

Окно Свойства уровня

Return to chapter overview
Покажите/скройте невидемый текст

Окно Свойства уровня открывается при выборе уровня на карте сайта. Нажмите кнопку Свойства... для просмотра возможных параметров для задания свойств различных уровней карты сайта.

На уровнях WebSite X5 карты сайта не содержащих контента кроме страниц: это категории, применяемые для организации страниц в логические группы. Они дают ясное указание посетителям, где их искать на сайте.

Кликните, чтобы развернуть/уменьшить Справка: Свойства уровня

§Скрыть всплывающее меню на этом уровне: при выборе этого пункта развертывающееся меню для этого уровня не отображается при прохождении курсора мыши над названием уровня.

§Ссылка, исполняемая при нажатии на объект: при выборе этого пункта Ссылка открывается и можно создать ссылку на элемент уровня.

Можно включить опцию Скрыть Выпадающее Меню для этого Уровня и задать опцию Ссылка, срабатывающая при нажатии на элемент, например, для создания ссылки на внешний сайт в качестве элемента меню или для замены подменю, содержащего множество элементов, если Страница создается специально для обеспечения доступа к разным разделам сайта.

§Пиктограмма для пункта меню— можно указать изображение (формата JPG, GIF или PNG) для использования в качестве значка элемента Меню.


Окно Свойства страницы .

Этап 2 - Создание карты сайта > Создание карты сайта >

Окно Свойства страницы .

 Return to chapter overview
Покажите/скройте невидемый текст

Окно Свойства страницы открывается, когда вы выбираете страницу на карте сайта. Нажмите на Свойства..., чтобы увидеть параметры для задания свойств, необходимых для оптимизации, настройки графики и добавления кода на ваши веб-страницы.

Свойства страницы организованы в 3 раздела: Общие, Графика и Эксперт.

Кликните, чтобы развернуть/уменьшить Справка: Параметры раздела Общие

Используйте параметры этого раздела для задания ряда значений, необходимых для поисковой оптимизации (SEO):

§Расширенный Заголовок: задает странице название, отличающееся от названия, отображаемого на карте сайта.

Название, данное странице при создании карты сайта, используется в навигационном меню. Заданное в свойствах страницы Расширенный Заголовок — это полное название, отображаемое после размещения сайта в Интернете.

Если вы работаете над главной страницей, ее заголовок не отображается даже если вы зададите Расширенный Заголовок: исходный заголовок используется в меню и в метатеге <title> в коде HTML страницы, но если вы зададите Расширенный Заголовок то заголовок будет использоваться в метатеге <title>.

§Описание страницы: можно ввести описание страницы. Важно выражаться кратко, четко и по существу. Этот текст используется для заполнения метатега <description> в HTML-коде страницы и считывается поисковыми роботами для индексации сайта.

§Ключевые слова сайта: можно ввести ключевые слова для данной страницы (слова должны разделяться запятыми). Эти слова используются для заполнения метатега <keywords> в HTML-коде страницы и считываются поисковыми роботами для индексации сайта.

§Имя файла: можно задать имя HTML-файла данной страницы.

По умолчанию HTML-файлу дается имя, назначенное странице при создании карты сайта. Используйте короткие и осмысленные имена, чтобы адрес был простым и легко запоминался. Это также улучшит индексацию страницы поисковыми системами. Эту возможность нельзя использовать для главной страницы.
Кликните, чтобы развернуть/уменьшить Справка: Параметры раздела Графика

Параметры в этом разделе предназначены для задания некоторых важных аспектов графики страницы, над которой вы работаете.

Прежде всего, можно задать для страницы другой фон, отличный от прочих страниц сайта. Фон задается в выбранном шаблоне (см. Выбор шаблона). Учтите, что фон страницы - это область вокруг страницы в случае, когда браузер открыт с большим разрешением, чем это нужно для вашего сайта.

Варианты для Фон только для этой страницы следующие:

§Цвет фона: указывает цвет для заливки фона.

§Файл: указывает на файл изображения (в форматах .JPG, .GIF или .PNG), используемого в качестве фона.

§Положение: указывает, должно ли повторяться фоновое изображение. Изображение может повторяться по горизонтали, по вертикали или сразу в обоих направлениях, чтобы занять все отведенное пространство. Фоновое изображение должно быть специально откадрировано так, чтобы можно было заполнять им пространство.

§Выравнивание: можно указать метод выравнивания фонового изображения.

§Фиксированный фон: при выборе этой возможности, фоновое изображение страницы, остается на месте даже при прокрутке страницы.

Фон выбранной страницы может тоже отличаться от фона других страниц сайта. Это задается в шаблоне (см. Выбор шаблона). В этом случае вам нужно использовать параметры в Контент только для этой страницы, которые идентичны параметрам фона страницы.

Наконец, можно задать некоторый общий Параметры:

§Пиктограмма для пункта меню: можно указать изображение (в формате *.JPG, *.GIF или *.PNG), которое будет отображаться в навигационном меню рядом с заголовком страницы.

§Создать страницу без шаблона: при выборе этой возможности параметры шаблона (по умолчанию или с настройками пользователя - см. Выбор шаблона) не применяются к этой странице; это будет страница с контентом, но без графики и без меню.

§Ширина страницы: эта возможность доступна лишь при выбранном параметре Создать страницу без шаблона: он задает ширину страницы в пикселах.
Кликните, чтобы развернуть/уменьшить Справка: Параметры раздела Эксперт

Параметры в этом разделе предназначены редактирования вручную HTML-кода страницы, над которой вы работаете.

§Расширение генерируемых файлов: можно указать, в каком формате страница будет сохраняться в файле. По умолчанию используется расширение .HTML, но его можно изменить на .PHP, .ASP, .CFM или .JSP. Файл index.html главной страницы также можно сохранить в другом формате. Формат заблокированного файла изменить нельзя (см. Защищенная страница на карте сайта toolbar): эта часть должна остаться .PHP.

§Пользовательский код: указывает, где находится пользовательский код, который нужно добавить к HTML-коду страницы: Перед закрывающим тегом HTML, Перед закрывающим тегом HEAD, Атрибуты тега BODY (style, onload и т.д.) (т.е. в качестве части тэга <BODY>, например, так: <BODY onload="alert('Hello!')">), Перед закрывающим тегом BODY, После закрывающего тега BODY. Когда вы определитесь, куда нужно помещать ваш код, напечатайте его там или скопируйте часть кода в поле.

Параметр Пользовательский код можно использовать, например, чтобы связать с данной страницей определенные таблицы стилей (CSS), или чтобы при открытии страницы запускались определенные события. Для корректной работы некоторых скриптов JavaScript нужно добавить несколько строк кода в секции <HEAD> и <BODY> в файле HTML-страницы. Скрипты JavaScript добавляются при помощи Объект HTML и виджеты.

И, наконец, раздел Настройки карты сайта включает параметры для работы с картой сайта:

§Добавить эту страницу к карте сайта: выбрано по умолчанию, и добавляет текущую страницу на карту сайта.

§Приоритет контента: для страницы можно задать уровень приоритета, указывающий на ее важность по отношению к другим страницам сайта. Этот параметр включается в карту сайта.

§Частота обновления: определяет как часто должна обновляться страница. Этот параметр включается в карту сайта.

Замечания о совместимости с предыдущими версиями:

В отличие от предыдущей версии программы, в 10 версии можно открыть окно Свойства страницы со специальной страницы, которая автоматически появляется на карте сайта, когда на сайте используется собственная поисковая система (см. Редактировать шаблон), и когда Страница приветствия, блог, закрытые страницы или Корзина добавляются.

Родственные темы:

-

Веб-браузер и встроенный браузер WebSite X5


Создание Страниц

Этап 3 - Создание Страниц >

Создание Страниц

 Return to chapter overview
Покажите/скройте невидемый текст

Создав Карту Сайта для Проекта, можно приступить к созданию разных Страниц, из которых состоит Сайт. Окно Создание Страниц, где можно создавать свои страницы и добавлять на них контент.

Полный путь с именем и Название текущей Страницы показывается как Текущая Страница.

Кликните, чтобы развернуть/уменьшить Справка: Таблица макета страницы

WebSite X5 использует таблицу, чтобы легко создавать макет. По умолчанию эта таблица состоит из 2 строк и 2 столбцов, т. е. содержит 4 Ячейки. Для создания Страницы (и добавления в нее содержимого) нужно всего лишь перетаскивать в Ячейки Объекты, представленные в соответствующем списке. Каждая Ячейка может содержать не более одного Объекта.

Чтобы увеличить число Ячеек для размещения Объектов, в исходную таблицу можно добавить строки и столбцы. Кроме того, ширину любого столбца можно изменить. Как будет далее показано, возможность изменения Таблицы Макета Страницы и вставки Объектов, охватывающих более одной Ячейки (по горизонтали или по вертикали), обеспечивает гибкость настроек по компоновке страниц.

Примечание: Таблица Макета Страницы не показывается при отображении Сайта, опубликованного в Интернете, в Браузере. Эта таблица предназначена лишь для облегчения компоновки содержимого Страницы. Таблица Макета Страницы не «переводится» в таблицу в HTML-коде Страницы (исключая немногочисленные особые случаи при создании сложных компоновок).

Как было отмечено выше, Ячейка Таблицы Макета Страницы может содержать не более одного Объекта, однако Объект может занимать несколько смежных Ячеек (и даже иметь размеры, превышающие физические размеры Страницы).

Представление Ячеек Таблицы Макета Страницы зависит от их состояния:

§Если Ячейка содержит заполненный Объект, то в ней отображается значок Объекта на фоне, заштрихованном серыми диагональными линиями.

§Если Ячейка содержит незаполненный Объект, то в ней отображается значок Объекта на сплошном голубом фоне.

§Если Ячейка содержит выбранный Объект, то отображаются кромка и «ручки» выбора.

Кликните, чтобы развернуть/уменьшить Справка: Команды панели инструментов

Панель инструментов расположена над таблицей макета страницы и содержит следующие команды:

Изменить

Эта команда открывает окно, где можно создать объект, выбранный из таблицы раскладки страницы. Тип открывающегося окна зависит от типа выбранного объекта (текст, изображение, флэш-анимация и т.д.).

Стиль Ячейки

При выборе этой опции открывается окно Стиль ячейки, где можно задать графическое оформление текущей Ячейки.

Поставить привязку (якорь)

Эта команда создает привязку (якорь) и связывает ее с выбранным объектом. Если нажать на стрелку рядом с кнопкой, увидите меню со следующими пунктами: Вставить якорь..., Редактировать... и Удалить.

Добавить строку / Добавить столбец

Можно добавить новую строку или столбец к таблице раскладки страницы. Нажмите на стрелку рядом с кнопками, чтобы указать, перед или после выбранной ячейки нужно добавить строку или столбец. Максимальный размер таблицы раскладки страницы 64 строки на 12 столбцов.

Удалить строку / Удалить столбец

Эти команды удаляют выбранную строку или столбец из таблицы макета страницы. Минимальный размер таблицы раскладки страницы - 1 строка на один столбец (одна ячейка).

Якорь (привязка) - это ссылка, котрая помогает определить положение объекта на странице: используется для установки ссылок прямо на объект.

Замечания о совместимости с предыдущими версиями:

В предыдущих версиях программы параметры для задания полей и выравнивания содержимого ячейки находились в меню [image] и [image] на кнопках сверху раскладки таблицы. В 10 версии эти кнопки убрали, а параметры теперь можно задать в окне Стиль ячейки| Стиль.
Кликните, чтобы развернуть/уменьшить Справка: Список доступных объектов

Список доступных объектов находится рядом с таблицей раскладки страницы. Чтобы добавить на страницу объект, выберите его пиктограмму из списка и перетащите мышкой в нужную ячейку таблицы макета страницы.

Возможные типы объектов:

Текстовый объект | Изображение объекта | Объект таблица | Объект в галерее
Аудио-видео объект | Объект-форма обратной связи | Объект социальной сети | Объект гостевая книга
 | Объект Flash-анимации | Объект список товаров | Объект HTML и виджеты

После переноса объекта в ячейку нажмите на кнопку [image] (или дважды щелкните на объекте), чтобы открыть окно для непосредственного создания объектов.

Замечания о совместимости с предыдущими версиями:

Возможные типы объектов - Пункты Объект гостевая книга, Объект социальной сети и новые и появились только в 10 версии WebSite X5: в предыдущей 9 версии были доступны виджеты из Объект HTML и виджеты.

Лучшая практика:

-

Как создать страницу, используя шаблоны страниц


Текстовый объект

Этап 3 - Создание Страниц >

Текстовый объект

 Return to chapter overview
Покажите/скройте невидемый текст

Текст — очень важный элемент содержимого Сайта. Значительная часть содержимого сайтов состоит из Текста (помимо Изображений, Видеозаписей и Flash-анимаций).

Текст для Интернета пишется не совсем так, как для бумажного издания. Так, требуется поддержка отображения текста на разных устройствах (на мониторе компьютера или на мобильном устройстве), пользователи читают текст иначе (в отличие от внимательного чтения бумажного издания, на компьютере текст обычно быстро просматривают) и, конечно же, у пользователей есть огромный выбор других текстов (поскольку многие сайты могут уделять внимание одним и тем же темам).

Чтобы привлечь посетителей на Сайт и убедить их в том, что представленные материалы достойны их внимания, текст должен быть адаптирован для размещения в Интернете. Пишите увлекательно и по существу. Разбейте текст на короткие предложения и абзацы, чтобы его было легко читать и чтобы он выглядел менее объемистым. Особое внимание уделите форматированию; полужирный шрифт и курсив, заголовки и подзаголовки следует использовать аккуратно и единообразно.

Пользователей обычно привлекают продуманные сайты. Можно запросто отпугнуть посетителей, разместив на Сайте текст с большим количеством ошибок, использовав неудобную компоновку Сайта, затруднив чтение текста и т. п.

После этого краткого, но важного замечания о стиле написания в Интернет, WebSite X5 помогает набирать тексты с помощь. встроенного редактора и предоставляет все необъодимые команды для форматирования. Текст, созданный в других программах, можно вставить путем обычного Копирования и Вставки. Более того, WebSite X5 позволяет создавать текст, отображаемый на вкладках: практичный и удобный способ организации информации на небольшой площади, например, на странице сайта.

Кликните, чтобы развернуть/уменьшить Справка: Команды текстового редактора

Панель инструментов текстового редактора содержит следующие команды и возможности:

Вырезать [CTRL+X] - Копировать [CTRL+X] - Вставить [CTRL+V]

Эти команды вырезают, копируют и вставляют выбранный текст. Текст при вставке теряет все форматирование (жирный, наклонный и т.д.), примененное в исходном докумнте. Но эти же возможности есть во встроенном редакторе.

Специальная вставка

Используйте эту команду, если хотите вставить текст, который был скопирован или вырезан с помощью команд Вырезать и Копировать, в том случае, когда вы хотит сохранить исходное форматирование.

Можно использовать команды Вырезать, Копировать и Вставить для того, чтобы вырезать, копировать и вставлять фрагменты текста, созданные в других редакторах.

Отменить [CTRL+Z] - Восстановить [ALT+CAPS+BACKSPACE]

Эти команды отменяют или заново выполняют последнюю проведенную операцию.

Вставить ссылку [CTRL+L]

Эта команда формирует ссылку на выбранные слова. Ссылку можно задать в окне Ссылка, когда оно откроется.

Вставить изображение

тексту можно добавить изображение (формата JPG, GIF, PNG или BMP). Размер Изображения, вставляемого в Объект «Текст», автоматически изменяется под размер Ячейки Таблицы Макета Страницы. Если размер изображения нужно изменить, выделите его и используйте «ручки» выделения для изменения размера. Особую компоновку страницы можно задать, работая с Объектом «Изображение» в окне Изображение объекта.

Включить HTML-код

Эта опция позволяет добавлять текст в виде HTML-кода прямо в Страницу. При работе в режиме HTML символы < и > не интерпретируются как «меньше» и «больше», но текст между ними интерпретируется как HTML-тег.

Настройки реакции на мышь

К тексту можно применить эффект прокрутки. Настройки прокрутки задаются в окне Реакция на мышь.

Выровнять контент по ширине ячейки

Эта функция редактора моделирует представление текста в зависимости от размера ячейки таблицы макета страницы, в которой он находится.

Фон светлый/темный

Этот параметр задает темный или светлый цвет для фона редактора: это может быть полезно для работы с текстом, который написан на белом или другом бледном фоне.

Тип шрифта - размер шрифта

Можно выбрать тип шрифта (фонт) для текста и его размер.

В раскрывающемся меню перечислены все шрифты, доступные на вашем компьютере. Помните, что если выбрать шрифт, которого нет на компьютере посетителя сайта, шрифт будет автоматически заменен на другой, похожий на исходный.

Полужирный [CTRL+B] - Наклонный [CTRL+I] - Подчеркнутый [CTRL+U]

Эти параметры задают стиль выделенного текста: жирный, наклонный и подчеркнутый.

Цвет текста - Цвет фона для текста

Можно выбрать цвет выделенного текста или его фона.

Маркер списка

Можно добавить список маркеров.

Отступ / Отменить отступ

Для выделенного абзаца можно увеличить или уменьшить отступ.

Выровнять по левому краю - Выровнять по центру - Выровнять по правому краю - Выровнять по ширине

Выделенный текст можно выравнивать по левому краю, по правому, по центру или по ширине.

Выровнять текст по правому краю - По умолчанию - Выровнять текст по левому краю

Эти опции активны при вставке изображения в текст. Изображение можно вставить обычным образом, т. е. как слово (по умолчанию), или отобразить текст сбоку от изображения, а именно слева или справа от него.

Нажмите правую кнопку мыши, чтобы отобразить всплывающее меню с этими командами: Отменить, Вырезать, Копировать, Вставить, Специальная вставка и Выделить все.


Окно Реакция на мышь .

Этап 3 - Создание Страниц > Текстовый объект >

Окно Реакция на мышь .

 Return to chapter overview
Покажите/скройте невидемый текст

Это окно открывается при нажатии кнопки [image] в Текстовый объект или Объект таблица и содержит команды и параметры для настройки эффекта прокрутки текста.

Кликните, чтобы развернуть/уменьшить Справка: Настройки прокрутки

Прежде всего, нужно выбрать параметр Разрешить реакцию на мышь, после чего в разделе Режим можно выбрать визуализацию эффекта:

§Движение: можно выбрать стиль прокрутки. Это может быть:

Без движения - Показать полосу прокрутки: текст автоматически не прокручивается. Однако, поскольку задана фиксированная высота ячейки (см. параметр Высота), при необходимости (если весь текст не уместится) будет автоматически добавлена полоса прокрутки.

Одно движение: текст прокручивается в заданном направлении. По достижению конца текста, прокрутка останавливается.

Непрерывное движение: текст прокручивается в заданном направлении. По достижению конца текста, прокрутка начинается с начала.

Поочередное движение: текст прокручивается в заданном направлении. По достижению конца текста, начинается прокрутка в обратном направлении.

Движение блоков: текст разбивается на две части на высоте, заданной параметром Высота. Прокрутка начинается с первой части, затем следует пауза, после чего прокручивается вторая часть. Это продолжается до завершения прокрутки второой части, после чего снова показывается первая часть. Этот эффект лучше использовать в случае, если текст одинаково написан и форматирован, что позволяет разбить его на части равного значения Высота.

§Направление: можно выбрать направление прокрутки: вверх, вниз, налево или направо.

Окно Параметры содержит следующие параметры:

§Эффект: можно выбрать любой тип движения: Линейный, Рикошет или Колебания (за исключением Непрерывное движение.

§Высота: можно задать высоту ячейки, содержащей текст.

§Длина (сек): можно задать длительность эффекта (в секундах). Для параметров Одно движение, Непрерывное движение или Поочередное движение длительность эффекта — это время, затрачиваемое на его завершение, до возобновления эффекта с самого начала. Для параметра Движение блоков длительность эффекта — это время, затрачиваемое на показ одной части, до перехода к другой части.

§Остановить при наведении курсора мыши: прокрутка остановится, если подвигать курсор мыши на текстом.

Возможность Высота доступна лишь в случае вертикальной прокрутки (направление: вверх или вниз). Эффект горизонтальной прокрутки (налево или направо) лучше использовать, когда текстовый объект занимает всю строку в таблице макета страницы.


Изображение объекта

Этап 3 - Создание Страниц >

Изображение объекта

 Return to chapter overview
Покажите/скройте невидемый текст

Изображения — одни из наиболее часто используемых элементов на веб-страницах. Они позволяют изложить идею, рекламировать товар, показать сообщение или просто украсить страницу. В любом случае, изображения важны, поскольку помогают создавать более привлекательные и профессионально выглядящие сайты.

WebSite X5 позволяет импортировать изображения разных графических форматов, а также использовать Редактор изображений для внесения изменений в фотографии; с помощью этого редактора можно вырезать, поворачивать, вносить поправки, накладывать маски, фильтры и рамки. Кроме того, можно добавить удивительный панорамный обзор, а также показывать Изображения крупным планом.

WebSite X5 прекрасно осведомлены о проблеме незаконного копирования изображений в Интернете. Благодаря встроенной системе защиты посетители Сайта не смогут найти исходные файлы изображений; для защиты от копирования используемых на Сайте изображений, на них можно наносить водяные знаки и информацию об авторских правах.

Команды для создания объектов изображений организованы в резделы: Общие настройки, Отображение и Карта сайта.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Общие настройки

Можно использовать команды этого раздела для импортирования графических файлов и редактирования изображений.

WebSite X5 позволяет импортировать все основные графические форматы (JPG, GIF, PNG, BMP, PSD, TIF, DIB, PCX, RLE, TGA, WMF). Для этого нужно выбрать графический файл на локальном компьютере или в Интернете.

Изображение, выбранное для импорта, можно просмотреть в окошке Предпросмотр. При нажатии кнопки Редактировать... под окошком предварительного просмотра откроется встроенный Редактор изображений, где можно редактировать изображение.

Изображение может иметь несколько Параметры:

§Заголовок— название Изображения, вносимое в атрибут title тега <img> в HTML-коде Страницы.

§Альтернативный текст— введите текст, который будет отображаться в случае, если показать Изображение по какой-то причине невозможно. В HTML-коде Страницы текст-заменитель вносится в атрибут alt тега <img>.

Параметрам Заголовок и Альтернативный текст следует уделить особое внимание, поскольку они важны для поисковой оптимизации и удобства пользования сайтом.

§Ссылка— можно добавить гиперссылку на Изображение. Нажмите кнопку [image] и в окне Ссылка выберите действие и задайте соответствующие настройки.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Отображение

Можно использовать команды этого раздела для задания способа импорта отображаемых изображений: с помощью WebSite X5 можно получить широкоугольные изображения и применить эффект приближения.

Раздел Режим отображения:

Автоматически изменять размер изображений— эта опция включена по умолчанию; размер Изображения автоматически подгоняется по размеру Ячейки Таблицы Макета Страницы, куда оно вставлено.

Масштабировать и позиционировать изображение вручную— если включена эта опция, то Изображение можно увеличить, нажав на него. Увеличенное Изображение можно двигать, чтобы вынести определенный участок на передний план; для этого нужно нажать на Изображение и перетащить его мышью до отображения нужного участка.

Для получения этого эффекта Изображение сначала уменьшается до размера Ячейки Таблицы Макета Страницы, а зачем пересчитывается либо согласно коэффициенту Макс. Масштаб (если выбрано Свободное масштабирование в Режиме Перемещения), либо пропорционально заданной Высоте Высота (если выбран Горизонтальный панорамный вид или Вертикальный панорамный вид в Тип движения). Полученное Изображение больше области отображения, и его можно двигать внутри нее.

Автоматически масштабировать и позиционировать изображение— этот вариант аналогичен предыдущему, разве что для перемещения Изображения достаточно подвигать курсором мыши возле краев Изображения.

Если выбрать Автоматически изменять размер изображений в качестве Режим отображения, можете выбрать эти Настройки—

§Качество— это уровень качества, поддерживаемый при сохранении изображений в формате *.JPG. Все импортированные изображения автоматически преобразуются в формат *.JPG или *.PNG, если установлена прозрачность. При сохранении файла в формате *.JPG чем больше степень сжатия, тем хуже будет качество.

Лучше всего использовать графические файлы в форматах *.JPG, *.GIF и *.PNG. Если вы добавляете изображение в форматах отличных от *.JPG, *.GIF и *.PNG, оно будет автоматически преобразовано в формат *.JPG с указанной степенью сжатия. Файлы преобразуются в формат *.JPG (или *.PNG, если есть прозрачность) даже если изображение больше, чем размеры ячейки в таблице макета страницы и если они редактируются с помощью Редактор изображений.

Во всех других случаях изображение копируется как есть, для того, чтобы сохранить прозрачность файлов *.GIF.

§Метод пересчета— этот параметр указывает как нужно уменьшить размеры изображения (ширину и высоту). Есть следующие варианты:

-Билинейное (быстрое)— это самый быстрый способ изменения размеров, но дает самое низкое качество изображения среди других методов.

-Прореживание (среднее)— этот метод довольно быстрый и дает изображения хорошего качества.

-Бикубическое (лучшее, но медленное)— это самый медленный метод, но он дает самое высокое качество изображения.

Если выбрать Масштабировать и позиционировать изображение вручную или Автоматически масштабировать и позиционировать изображение для Режим отображения можно работать со следующими параметрами Настройки—

§Тип движения— можно задать направление (ручного или автоматического) перемещения Изображения. Это может быть:

-Свободное масштабирование— Изображение можно перемещать в любую сторону (по вертикали или по горизонтали). Задайте значение Максимальное увеличение Например, при масштабном коэффициенте 200% показываемое Изображение будет вдвое больше исходного размера.

Исходное изображение | Изображение с примененным эффектом

-Горизонтальный панорамный вид— Изображение можно перетаскивать в горизонтальном направлении. Этот эффект имеет смысл использовать для Изображений, ширина которых намного больше высоты. В поле Высота введите высоту Изображения (в пикселах).

Исходное изображение | Изображение с примененным эффектом

-Вертикальный панорамный вид— Изображение можно перетаскивать в вертикальном направлении. Этот эффект имеет смысл использовать для Изображений, высота которых намного больше ширины. В поле Высота задается высота (в пикселах), которая должна использоваться для Ячейки Таблицы Макета Страницы.

Исходное изображение | Изображение с примененным эффектом

§Максимальное увеличение— эта настройка доступна лишь при включенной опции Свободное масштабирование. Для Изображения можно задать такой масштабный коэффициент, что оно будет больше имеющейся области обзора. Если бы Изображение не было увеличено, его нельзя было бы перетаскивать.

§Высота— эта настройка доступна лишь при включенной опции Горизонтальный панорамный вид и Вертикальный панорамный вид. В первом случае можно задать высоту Изображения (в пикселах), а во втором — высоту Ячейки Таблицы Макета Страницы , куда вставлено Изображение.

§Разрешить увеличение картинки— эта опция включена по умолчанию. Изображение можно увеличить или уменьшить, нажав на него. При открытии Страницы показывается Изображение исходного размера, а значок в правом нижнем углу указывает на возможность масштабирования. Изображение можно увеличивать или уменьшать вращением колесика мыши, пока оно не примет размеры, заданные в Максимальное увеличение.

§Показать управление масштабом— эта настройка доступна лишь при включенной опции Разрешить увеличение картинки. В окне Изображения можно показывать панель масштабирования, где пользователь может двигать курсор мыши вперед и назад для настройки масштаба.

§Показать навигатор— если включить эту опцию, то внутри Изображения будет размещено небольшое окошко, содержащее миниатюру этого Изображения. Это так называемый «навигатор», который показывает целое Изображение и отмечает участок, в данный момент показываемый в окошке. Посетители могут перемещать блок навигации по изображению, чтобы разглядеть отдельные детали. Блок навигации исчезает при перемещении курсора мыши по изображению.

§Разрешить автоматическое постоянное перемещение— если включить эту опцию, то при просмотре Изображения оно будет непрерывно двигаться. Это указывает на то, что Изображение показано не целиком, а также и на то, что его можно увеличить. Автоматическое постоянное перемещение прерывается, когда посетитель двигает колесико мыши или курсор над панелью масштабирования.

Если вы задали Автоматически изменять размер изображений в качестве Режим отображения для изображения, над которым вы работаете, можно задать Эффекты при наведении курсора мыши—

§Эффекты при наведении курсора мыши— можно задать спецэффект для случая, когда мышка оказывается над изображением.

§Настройки— они могут быть разными, в зависимости от типа Эффекты при наведении курсора мыши выбрано: они задают параметры, определяющие эффект (например, цвет и толщину границ для эффекта «Цветные границы»).

Можно также использовать параметры Защита, чтобы постараться избежать неправомерного копирования ваших изображений:

§Изображение для защиты от копирования— защищает изображение от копирования командами Сохранить как этот пункт меню предоставляется различными браузерами.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Карта сайта

Можно использовать команды этого раздела, чтобы получить дальнейшую информацию о вашем изображении, использованном на сайте Карта сайта.

Сначала включите опцию Добавить изображение к карте сайта — информация об Изображения будет добавлена на Карту Сайта, автоматически созданную программой WebSite X5 (см. Автоматически создать карту сайта в разделе Общие настройки | Эксперт). Можно задать следующие настройки:

§Заголовок— (дополнительный параметр) здесь можно ввести название Изображения (необязательно).

§Заголовок— (дополнительный параметр) здесь можно ввести надпись, или краткое описание Изображения (необязательно).

§Местоположение (например, адрес, город и т.д.)— (дополнительный параметр) здесь можно указать такие сведения, как адрес, город и страну, идентифицирующие место съемки (необязательно).

§URL файла с лицензией— (дополнительный параметр) можно задать URL-адрес файла, содержащего лицензию на использование Изображения (необязательно).

Изображения, защищенные от незаконного копирования и использования, нельзя добавить на Карту Сайта (см. опцию Изображение для защиты от копирования в разделе Отображение).

Лучшая практика:

-

Как создать карту сайта и ссылку на нее


Объект таблица

Этап 3 - Создание Страниц >

Объект таблица

 Return to chapter overview
Покажите/скройте невидемый текст

Таблицы очень полезны для организации и представления данных.

Нередко информацию лучше отобразить в табличном виде, чем в виде объемистого и многословного текста. Например, если в таблице представить прейскурант гостиницы, показав цены на разные типы номеров в разные сезоны, то такая информация будет намного удобнее для восприятия, чем обычный текст.

Таблицы также могут содержать графические изображения, что делает страницу более приятной для глаза, а ее содержимое менее однообразным.

При использовании таблицы важно учесть следующее: информация должна быть не слишком сложной и представленной в удобном для восприятия виде, а таблица должна быть достойно оформлена.

WebSite X5 предлагает редактор для создания таблиц, очень похожий на редактор для Текстовый объект. По умолчанию Таблица состоит из трех строк и трех столбцов и занимает всю ширину своей Ячейки. При необходимости можно добавить или удалить строки и столбцы, изменить их размер, а также объединить или разделить ячейки.

Кликните, чтобы развернуть/уменьшить Справка: Команды табличного редактора

Можно использовать следующие команды:

Вырезать [CTRL+X] - Копировать [CTRL+X] - Вставить [CTRL+V]

Эти команды вырезают, копируют и вставляют выбранный текст. Текст при вставке теряет все форматирование (жирный, наклонный и т.д.), примененное в исходном докумнте. Но эти же возможности есть во встроенном редакторе.

Специальная вставка

Используйте эту команду, если хотите вставить текст, который был скопирован или вырезан с помощью команд Вырезать и Копировать, в том случае, когда вы хотит сохранить исходное форматирование.

Отменить [CTRL+Z] - Восстановить [ALT+CAPS+BACKSPACE]

Эти команды отменяют или заново выполняют последнюю проведенную операцию.

Вставить ссылку [CTRL+L]

Эта команда формирует ссылку на выбранные слова. Ссылку можно задать в окне Ссылка, когда оно откроется.

Вставить Изображение

В ячейку Таблицы можно вставить изображение (формата JPG, GIF, PNG или BMP). Если размер изображения нужно изменить, выделите его и используйте «ручки» выделения для изменения его размера.

Разрешить использование HTML-кода

Эта опция позволяет добавить текст в виде HTML-кода прямо в Таблицу. При работе в режиме HTML символы < и > не интерпретируются как «меньше» и «больше», но текст между ними интерпретируется как HTML-тег.

Настройки реакции на мышь

К тексту можно применить эффект прокрутки. Настройки прокрутки задаются в окне Реакция на мышь.

Фон светлый/темный

Этот параметр задает темный или светлый цвет для фона редактора: это может быть полезно для работы с текстом, который написан на белом или другом бледном фоне.

Вставить Строку / Удалить Строку / Вставить Столбец / Удалить Столбец

В месте расположения курсора мыши можно вставить или удалить строку или столбец.

Объединить Ячейки — Разделить Ячейки

Смежные ячейки можно объединить в одну ячейку; также можно разделить ячейку на 2 смежные ячейки, находящиеся в одной строке.

Тип шрифта - размер шрифта

Можно выбрать тип шрифта (фонт) для текста и его размер.

В раскрывающемся меню перечислены все шрифты, доступные на вашем компьютере. Помните, что если выбрать шрифт, которого нет на компьютере посетителя сайта, шрифт будет автоматически заменен на другой, похожий на исходный.

Полужирный [CTRL+B] - Наклонный [CTRL+I] - Подчеркнутый [CTRL+U]

Эти параметры задают стиль выделенного текста: жирный, наклонный и подчеркнутый.

Цвет текста - цвет фона ячейки

Эти параметры задают цвет для выделенного текста или для фона ячейки, содержащей выделенный текст.

Стиль Кромки Ячейки

К кромке текущей ячейки можно применить стиль. Можно задать цвет и ширину каждой из четырех кромок ячейки.

Маркер списка

Можно добавить список маркеров.

Выровнять по левому краю - Выровнять по центру - Выровнять по правому краю - Выровнять по ширине

Выделенный текст можно выравнивать по левому краю, по правому, по центру или по ширине.

По умолчанию — Текст Слева — Текст Справа

Эти опции активны при вставке изображения в ячейку с текстом. Изображение можно вставить обычным образом, т. е. как слово (по умолчанию), или отобразить текст сбоку от изображения, а именно слева или справа от него.

Выровнять по Верху — Выровнять по Середине — Выровнять по Низу

Выделенный текст можно вертикально выровнять по верху, по центру или по низу ячейки.

Нажмите правую кнопку мыши, чтобы вызвать всплывающее меню, где представлены команды Отмена, Вырезать, Копировать, Вставить, Особая вставка и Выбрать все и:

§Высота Строки

Можно задать высоту выбранных строк (в пикселах). Если ввести ноль, то строки будут иметь минимальную высоту, необходимую для отображения содержимого.

§Ширина Столбца

Можно задать ширину выбранных столбцов (в пикселах).

Размер строк, столбцов и отдельных ячеек можно изменять, перетаскивая мышью (удерживая левую кнопку мыши) их кромки. Можно изменить ширину отдельных ячеек, при этом изменения касаются лишь выбранной ячейки.


Объект в галерее

Этап 3 - Создание Страниц >

Объект в галерее

 Return to chapter overview
Покажите/скройте невидемый текст

В наше время цифровые камеры и специальные он-лайн сервисы значительно упростили опубликование целых фотоколлекций в Интернете. Например, в Интернете можно разместить семейные фотоальбомы и предоставить доступ к ним родственникам и друзьям. Также можно создать альбомы и каталоги, посвященные своим увлечениям, или использовать фотоальбомы для работы.

Программа WebSite X5 позволяет создавать удивительные Галереи, где можно демонстрировать не только фотографии, но и видеозаписи. В каждой галерее свои эффекты, сповобы навигации и внешний вид: например, это может быть панель управления или миниатюры самого разнообразного вида. Для создания динамических эффектов во всех галереях используются JavaScript, HTML5 и CSS3.

Замечания о совместимости с предыдущими версиями:

Галереи на базе HTML5 или Flash - Галереи HTML5 впервые были представлены в версии 9.1 WebSite X5, а в версии 10 они полностью заменили галереи Flash.

Галереи Flash были заменены на галереи HTML5 из-за того, что, хотя флэш-галереи предлагают множество видов эффектов, они требуют Flash-плеер для отображения галереи и не поддерживаются на планшетных и мобильных устройствах с ОС iOS (например, iPad® и iPhone®). С другой стороны, галереи на базе HTML5 быстрее загружаются, не требуют внешних модулей (плагинов) и правильно отображаются на всех видах устройств с любыми современными операционными системами.

Если вы пользуетесь версией браузера, которая не поддерживает HTML5 и CSS3, галереи HTML5 будут отображаться правильно, но некоторые из эффектов, примененных к изображениям, могут не отрабатывать. В таких случаях автоматически применяется эффект Fade (постепенное исчезновение).

Если в галерее присутствует видео, формат которого не поддерживается в HTML5, или браузер не поддерживает этот формат видео в окружении HTML5, оно автоматически отображается средствами Flash, чтобы обеспечить правильное отображение.

Некоторые из предоставляемых галерей предлагают миниатюры и окно ShowBox , где показываются увеличенные изображения миниатюр. Посетитель нужно лишь нажать на миниатюру, чтобы открыть изображение или видео в ShowBox, который отображается поверх страницы. Перемещение мыши по окну ShowBox приводит к появлению кнопок для отображения следующего или предыдущего изображения или видео в галерее. Возвращаться к миниатюрам при этом не нужно.

Внешний вид окна Электронной Витрины настраивается: в разделе Стили и модели | ShowBox ( Step 4 - Расширенные настройки).

Команды для создания Объект в галерее находятся в разделах Стиль, Список и Пиктограммы.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Стиль

Можно использовать команды этого раздела для выбора вида галереи, которую вы хотите создать, и для задания некоторых общих настроек этой галереи.

Выбор галерей включает:

Кликните, чтобы развернуть/уменьшить | Классическое слайд-шоу В галерее этого типа изображения и видео показываются последовательно, одно за другим: способ показа изображений зависит от установленного эффекта. Управлять очередностью показа можно через Панель Управления. Также можно показывать миниатюры на Панели Управления, чтобы пользователь мог мгновенно увеличить заинтересовавшее его Изображение (или Видеозапись).
Кликните, чтобы развернуть/уменьшить | Горизонтальная галерея В такой Галерее показывается горизонтальный ряд миниатюр, расположенных над или под Изображением, находящимся на переднем плане. При помещении мыши над миниатюрами, они перематываются вправо или влево. Нажатие на миниатюру открывает на переднем плане увеличенное изображение или видео. Увеличенные изображения появляются в соответствии с заданным для них эффектом.
Кликните, чтобы развернуть/уменьшить | Вертикальная галерея Такая Галерея аналогична предыдущей, разве что миниатюры размещаются вертикально, слева и ли справа от Изображения, находящегося на переднем плане.
Кликните, чтобы развернуть/уменьшить | Пиктограммы В такой Галерее показываются все миниатюры. Чтобы открыть Изображение или Видеозапись на переднем плане в Электронной Витрине, нужно нажать на соответствующую миниатюру.
Кликните, чтобы развернуть/уменьшить | Сколько пиктограмм на страницу Такая Галерея напоминает предыдущую, однако при большом числе Изображений в Галерее они распределяются по рамочкам с указанием числа отображаемых рядов с миниатюрами. Панель Управления позволяет пользователю двигаться от рамочки к рамочке, при этом оставаясь на той же Странице. Такой тип галереи очень пригодится, если вам нужно показать много изображений.
Кликните, чтобы развернуть/уменьшить | Горизонтальные пиктограммы В такой Галерее показывается один горизонтальный ряд миниатюр. Чтобы открыть Изображение или Видеозапись в Электронной Витрине, нужно нажать на соответствующую миниатюру.
Кликните, чтобы развернуть/уменьшить | Вертикальные пиктограммы Такая Галерея аналогична предыдущей, разве что миниатюры размещаются вертикально.

Различные типы галерей имеют свои Настройки и возможности для Команды навигации.

Настройки: | Классическое слайд-шоу | Горизонтальная галерея | Вертикальная галерея
§Максимальный размер: можно задать максимальную ширину и высоту Электронной Витрины. Оставьте Сохранять пропорции выбранным, если хотите сохранить соотношение высоты и ширины (форм-фактор). | P | P | P
§Видимые пиктограммы: задайте число миниатюр, показываемых возле основного Изображения. | - | P | P
§Положение пиктограмм: можно задать местоположение миниатюр по отношению к основному Изображению. | - | P | P
§Шрифт описания:задает шрифт, стиль и размер для текста. Эти настройки применяются к заголовкам, которые можно создать в поле Описание в разделе Список. | P | P | P
§Звук: можно задать звуковую дорожку, проигрываемую во время просмотра Галереи. | P | P | P
§Автовоспроизведение: слайд-шоу из изображений и видео начинается сразу после открытия галереи. | P | P | P
§Случайный вид: изображения и видео показываются в случайном порядке (а не в том, в каком они были добавлены). | P | P | P
Команды навигации:
§Вид кнопок: задает где и как показываются кнопки навигации рядом с главным изображением в галерее, как перейти к следующему или предыдущему изображению. Кнопки могут быть Всегда видимый, Невидимый (автозапуск) или Отображать при наведении курсора мыши. | P | - | -
§Стиль кнопок: можно выбрать стиль кнопок, которые показываются рядом с главным изображением галереи. | P | - | -
§Показать панель управления: эта опция включена по умолчанию. Панель Управления можно настроить так, чтобы она появлялась лишь при наведении курсора мыши. Пользователь может использовать Панель Управления для просмотра нужных Изображений и Видеозаписей в Галерее. На базовой Панели Управления есть следующие кнопки: Запустить Cлайд-шоу, [image] Предыдущее Изображение и [image] Следующее Изображение. | P | P | P
§Цвет: в окне Цвет можно задать цвет Панели Управления. | P | P | P
§Показывать пиктограммы на панели управления: активно по умолчанию: добавляет список миниатюр изображений на панель управления галереи, которая отображается при наведении мыши. Посетителю не требуется соблюдать заданную последовательность показа слайд-шоу, а можно выбрать то изображение или видео, которое он хочет посмотреть. | P | - | -

Настройки: | Пиктограммы | Сколько пиктограмм на страницу | Горизонтальные пиктограммы | Вертикальные пиктограммы
§Видимые пиктограммы: задайте число миниатюр, показываемых возле основного Изображения. | P | - | P | P
§Строк на странице: можно задать число рядов в рамочке. | - | P | - | -
§Показывать по нажатию увеличенное изображение в ShowBox: создает ссылку на миниатюру таким образом, что она соответствует отображаемым в ShowBox изображению или видео. | P | P | P | P
§Максимальный размер: этот вариант доступен только если активен параметр Показывать по нажатию увеличенное изображение в ShowBox он задает максимальную ширину и высоту окна ShowBox (в пикселах). Оставьте Сохранять пропорции выбранным, если хотите сохранить соотношение высоты и ширины (форм-фактор). | P | P | P | P
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Список

Эти команды можно использовать, чтобы задать список изображений или видео, которые нужно добавить в галерею.

Все файлы, добавленные в Галерею, отображаются в списке Image filename: для предварительного просмотра Изображения или Видеозаписи Выберите нужный файл.

В списке Image filename дается полный путь с именем каждого Изображения или Видеозаписи и вводный эффект; галочка в соответствующей позиции указывает на наличие ссылки и описания файла.

Для создания Объекта «Галерея» доступны следующие команды:

§Добавить... / Удалить: можно добавлять файлы в Галерею и удалять их оттуда. Можно импортировать графические файлы в форматах .JPG, .GIF, .PNG, .PSD, .BMP, .TIF, .DIB, .PCX, .RLE, .TGA и .WMF. Также можно добавлять видеофайлы формата FLV и MP4.

Нажмите на треугольник в Добавить... , чтобы открыть подменю со следующими пунктами: Добавить изображение..., Добавить видео... и Добавить видео с YouTube/Vimeo....

Кликните, чтобы развернуть/уменьшить

В окне, отображаемом командой Добавить видео с YouTube/Vimeo..., можно задать URL-адрес видеозаписи, уже выложенной на YouTube™ или Vimeo.

§Сдвинуть Вверх / Сдвинуть Вниз выбранный файл можно поместить до предыдущего или после следующего в списке Image filename .

§Редактировать...: открывает встроенный Редактор изображений где можно изменить изображение, выбранное из списка Image filename ..

Для каждого Изображения и Видеозаписи можно задать Параметры в зависимости от выбранного стиля Галереи

§Ссылка: создает ссылку на изображение или видео, выбранные из этого списка. Нажмите на [image] кнопку, чтобы открыть окно Ссылка , где можно выбрать действие и относящиеся к нему параметры. В JavaScript-галереях ссылка, заданная таким способом, заменяет ссылку на увеличенное Изображение (даже если включена опция Показывать по нажатию увеличенное изображение в ShowBox).

§Эффект: нажмите [image] кнопку Название эффекта для открытия окна, где можно задать вводные эффекты, а также эффекты движения и масштабирования для Изображений и Видеозаписей из Image filename.

Если вы пользуетесь версией браузера, которая не поддерживает HTML5 и CSS3, галереи HTML5 будут отображаться правильно, но некоторые из эффектов, примененных к изображениям, могут не отрабатывать. В таких случаях автоматически применяется эффект Fade (постепенное исчезновение).

§Описание: можно ввести описание Изображения (Видеозаписи), выбранной в списке Image filename. Это описание будет показываться внизу окна, в котором показывается увеличенное Изображение (Видеозапись).
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Пиктограммы

Можно использовать команды этого раздела, чтобы задать внешний вид миниатюр в галерее, если они там есть.

Миниатюра — это автоматически созданная Программой уменьшенная версия Изображения или Видеозаписи в Галерее. Миниатюры показываются внутри рамочек, делающих их похожими на слайды, негативы, напоминания и др.

Оформление миниатюры можно выбрать из этих вариантов:

§Картинка по умолчанию: рамочку для миниатюры можно выбрать из набора готовых вариантов.

§Пользовательское изображение: можно загрузить графический файл (формата JPG, GIF, PNG, BMP, PSD, TIF, DIB, PCX, RLE, TGA или WPG), содержащий нужную рамочку.

Если нужно создать новую рамочку, подготовьте изображение и сохраните его в файле (в одном из вышеуказанных форматов). Рамочки должны быть прямоугольными; если требуется поддержка прозрачности, файл следует сохранить в формате PNG.

Следующие параметры Параметры также применимы и к миниатюрам:

§Внешнее поле изображения (%): можно задать поле между Изображением-миниатюрой и его рамочкой.

§Включить цветовую насыщенность: установив эту опцию, в окне Цвет можно задать насыщение цвета рамочки миниатюры. к рамочке будет применен цветовой эффект для получения нужного цвета.

Насыщенность цвета не влияет на черные и белые рамочки.

В галереи можно переходить по ссылкам на страницах: см. Ссылка для получения дополнительной информации.


Аудио-видео объект

Этап 3 - Создание Страниц >

Аудио-видео объект

 Return to chapter overview
Покажите/скройте невидемый текст

Программа WebSite X5 позволяет добавлять на Сайт видео- и аудиозаписи.

Видеозаписи сейчас популярны как никогда — любой может снять видео, скопировать его на компьютер, отредактировать и выложить в Интернет.

Программа WebSite X5 значительно упрощает загрузку видеозаписей на Сайт и их показ посетителям. WebSite X5 принимает все основыне форматы и имеет встроенный плеер для файлов *.FLV и *.MP4. На Сайт можно импортировать файлы с локального компьютера или файлы, найденные в Интернете (включая такие порталы, как YouTube и Vimeo).

Команды для создания Аудио-видео объект разбиты на следующие разделы: Общие настройки и Карта сайта.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Общие настройки

Используя команды этого раздела можно импортировать файл для создания Аудио-видео объект и задать необходимые указания о том, как должно проходить воспроизведение.

Процедура вставки Объекта Аудио-видео объект зависит от места хранения импортируемого файла:

§Локальный файл на компьютере— если включена эта опция, сделайте двойной щелчок по кнопке [image] и выберите нужный файл на компьютере. Можно использовать файлы следующих форматов: MP4, FLV, AVI, WMV, MPG, MOV, MP3, WMA, WAV, MID, AIF, M4A.

§Файл в Интернет— если выбрана эта опция, введите URL-адрес нужного видео- или аудиофайла.

§Ссылка на видео с YouTube/Vimeo— если выбрана эта опция, введите URL-адрес нужного видео- или аудиофайла на сайте YouTube или Vimeo.

Если импортировать таким образом Видеозапись с сайта YouTube, то ее размер будет изменен согласно настройкам WebSite X5. Чтобы сохранить исходный размер, можно импортировать Видеозапись при помощи Объект HTML и виджеты (вместо Аудио-видео объект).

Можно запустить предварительный просмотр импортированного видео или аудио объекта, выбрав параметр Предпросмотр.

Для воспроизведения разных форматов видео- и аудиофайлов используются разные Проигрыватели. Если браузер поддерживает тэг видео в HTML5 и кодек файла, то для проигрывания файлов в форматах *.MP4, *.WEBM и *.OGG используется встроенный в WebSite X5 медиаплеер. Все другие форматы обрабатываются как указано в таблице:

Проигрыватель | Видеофайлы | Аудиофайлы
Adobe Flash Player® | .MP4 и .FLV | .MP3
Microsoft® Windows Media Player® | .AVI, .WMV и .MPG | .WAV и .WMA
QuickTime® Player | .MOV | .M4A и .AIF

Чтобы обеспечить максимальную производительность, лучше использовать *.MP4.

Для любого Проигрывателя можно задать следующие Параметры:

§Альтернативный текст— введите текст, который будет отображаться в случае, если воспроизведение видео- или аудиозаписи по какой-то причине невозможно.

§Размеры— введите ширину и высоту в пикселах управляющего блока видео или аудио. Максимальная ширина объекта показана в квадратных скобках, в соответствии с настройками для таблицы макета страницы. Максимальная высота аудиоплеера (35 пиксел) показана в квадратных скобках. Минимальная высота: 15 пиксел. Оставьте Сохранять пропорции выбранным, если хотите сохранить соотношение высоты и ширины (форм-фактор).

§Автовоспроизведение— при включении этой опции воспроизведение видео- или аудиозаписи запускается автоматически.

§Разрешить полноэкранный просмотр— в видеоплеере появляется кнопка для перехода в полноэкранный режим.

Можно задать способ отображения Панель управления :

§Показать панель управления— можно показывать Панель Управления со всеми командами, необходимыми для воспроизведения видео- или аудиозаписей.

Панель управления—

§Автоматически скрывать панель управления— Панель Управления Будет показываться лишь при наведении курсора мыши на окно, где воспроизводится видео- или аудиозапись.

§Цвет— задает цвет фона плеера.

WebSite X5 Media Player не работает с видеозаписями в форматах Microsoft® или QuickTime® , они могут вызывать всевозможные проблемы на плеере.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Карта сайта

Можно использовать команды этого раздела, чтобы получить дальнейшую информацию, полезную для построения карты сайта.

Сначала включите опцию Добавить видео к карте сайта — информация о Видеозаписи будет добавлена на Карту Сайта, автоматически созданную программой WebSite X5 (см. Автоматически создать карту сайта в разделе Общие настройки | Эксперт). Теперь можно задать следующие настройки:

§Заголовок— (обязательный параметр) видеозапись должна иметь название. Google задает максимальную длину названия: 100 символов.

§Заголовок— (обязательный параметр) для Видеозаписи нужно задать надпись (краткое описание). Google задает максимальную длину названия: 2048 символов. Более длинные надписи будут обрезаны.

§Категория— (дополнительный параметр) можно указать категорию, к которой относится Видеозапись. Google оговаривает, что Видеозапись может относиться лишь к одной категории, и задает максимальную длину названия: 256 символов.

§Ключевые слова сайта— (дополнительный параметр) можно ввести список тегов (кратких описаний ключевых тем, связанных с Видеозаписью). Google задает максимальное число тегов для Видеозаписи: 32 тега.

§Картинка для предпросмотра видео— (обязательный параметр) для Видеозаписи нужно задать Изображение-миниатюру. Google рекомендует использовать миниатюры размером 120 x 90 пикселов, формата JPG, PNG или GIF.

§Дата публикации— (дополнительный параметр) можно указать дату первой публикации Видеозаписи.

§Длительность (сек)— (дополнительный параметр) определяет длительность видео в секундах. Google настоятельно рекомендует указать эту информацию. Допустимое значение: 0 ... 28800 (8 часов).

§Контент, подходящий всем— (дополнительный параметр) Можно указать, подходит ли Видеозапись для несовершеннолетних посетителей. Google предупреждает, что видеозаписи, не помеченные как подходящие для несовершеннолетних посетителей, смогут найти через эту поисковую систему лишь пользователи с отключенным фильтром SafeSearch («Безопасный Поиск»). Функция SafeSearch поисковой системы Google удаляет из результатов поиска сайты с содержимым, имеющим выраженный сексуальный или порнографический характер.

Лучшая практика:

-

Как создать карту сайта и ссылку на нее


Объект-форма обратной связи

Этап 3 - Создание Страниц >

Объект-форма обратной связи

 Return to chapter overview
Покажите/скройте невидемый текст

При навигации в Интернет часто попадаются страницы, которые отображают формы, где у вас запрашивают личные сведения. Такие формы могут быть, например, предложениями зарегистрироваться на сайте или запросами логина и пароля для получения доступа к пользовательскому разделу; формы также могут использоваться для проведения маркетинговых исследований.

Программа WebSite X5 позволяет легко создать любую Форму электронного письма. Можно задать все необходимые поля, скомпоновать форму и настроить ее внешний вид, и, конечно же, определить, какие данные будут собираться и кто их получит.

Для создания объекта формы обратной связи доступны следующие команды: Список, Отправить и Стиль.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Список

Можно использовать команды этого раздела для задания списка полей, которые появятся в ваших формах обратной связи.

Здесь приводятся Имя поля, Тип поля, Ширина, указывается, Обязательное ли заполнять данное поле, и дается Описание. Эти значения можно ввести в окне Вставить поле при создании Полей.

В Списке Форм электронного письма можно не только просмотреть значения Полей, но и работать с Полями.

§Сделайте двойной щелчок на Поле ввода, чтобы открыть окно Вставить поле и изменить ранее указанные значения.

§Нажмите на выбранное поле во второй раз, чтобы сменить его название (это же можно сделать, открыв окно Вставить поле и сменив текст, введенный в качестве заголовка);

§Выберите Поле ввода и используйте команды на Панели Инструментов возле Списка, чтобы копировать это Поле, удалить его, переместить на другое место на Форме или изменить его настройки.

Можно посмотреть расположение Полей ввода в Списке. Пунктирная линия показывает, сколько строк содержит Форма. Если Поле находится в той же строке, что и другое, возле его ширины показывается значок [image] . Если суммарная ширина Полей в строке превышает длину строки, то показывается значок [image] , указывающий на ошибку. Если не изменить ширину Полей, то те из них, что не поместятся в строке, будут показаны в следующей строке.

Команды для создания списка полей для формы показаны рядом с таблицей:

§Добавить...— в окне Вставить поле на Форму можно добавить новое поле

§Сделать копию— можно создать копию выбранного Поля.

§Удалить— выбранное Поле можно удалить с Формы.

§Сдвинуть Вверх / Сдвинуть Вниз — выбранное Поле можно поместить до предыдущего или после следующего.

§Редактировать...— в окне Вставить поле можно изменить настройки выбранного Поля в списке.

Кнопки Отправить и Сброс (для отправки заполненной формы и для удаления всей информации, добавленной на форму) программа автоматически добавляет внизу формы.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Отправить

Можно использовать команды этого раздела для задания способа отправки данных из формы обратной связи.

На панели Отправка данных можно задать способ, которым администратор сайта будет получать данные. Имеются следующие параметры:

Отправить данные по e-mail: это параметр по умолчанию. С помощью PHP-скрипта данные, получаемые из формы, автоматически отправляются по электронной почте.

Отправить данные в базу данных— с помощью PHP-скрипта данные, отправляемые из формы, автоматически отправляются в заданную базу данных MySQL.

Отправить данные в виде файла— данные, введенные в Форму, обрабатываются специальным скриптом (PHP, ASP или др.). Этот вариант можно использовать при наличии собственного скрипта (например, в случае, если нужно отправлять данные на сервер, не поддерживающий PHP-скрипты, или для специальной обработки данных).

Нужно задать несколько параметров для каждой возможности отправки:

Отправить данные по e-mail—

§Адрес электронной почты отправителя— при выборе этой опции можно указать адрес, на который должны отправляться данные, введенные в Форму.

По умолчанию адрес отправителя совпадает с адресом назначения, который в данном случае принадлежит Администратору Сайта. Если указать электронный адрес Посетителя, то можно будет использовать опцию Ответить программы по работе с электронной почтой.

§Адрес электронной почты пользователя— можно указать адрес, на который должны отправляться собранные данные. Можно перечислить несколько адресов, отделяя их друг от друга точкой с запятой.

§Объект— можно указать тему электронного письма, содержащего данные, введенные в Форму электронного письма.

§Сообщение— можно ввести текст электронного письма, содержащего данные, введенные в Форму электронного письма.

§Включить собранные данные в формате CSV— при включении этой опции, в конец электронного письма также будут вставляться собранные данные в формате CSV. Данные в формате CSV отображаются как длинный список элементов, разделенных точками с запятой. Такой файл легко импортировать в программу для работы с электронными таблицами (например, Microsoft Excel).

Отправить данные в базу данных—

§Имя базы данных— выберите базу данных из списка тех, что связаны с проектом. Можно использовать команды в окне Управление данными для создания списка баз данных, связанных с проектом.

§Имя таблицы базы данных— введите название таблицы базы данных, куда должны вноситься введенные данные. Если такая таблица не существует, она будет автоматически создана.

§Отправить письмо на электронную почту, чтобы уведомить о получении данных— по мере поступления новых данных будут автоматически отправляться уведомления по электронной почте.

§Адрес электронной почты пользователя— Нужно задать несколько параметров для каждой возможности отправки:

введите адрес получаетеля электронной почты с уведомлением о получении данных.

Отправить данные в виде файла—

§Файл скрипта (например, PHP, ASP)— можно импортировать файлы скрипта для сбора и отправки данных, введенных в Форму электронного письма. Файл скрипта создается вручную.

Если вы не выбрали Отправить данные в виде файла в качестве Отправка данных метода в Письмо-подтверждение для пользователя, показываются следующие настройки:

§Отправить письмо-подтверждение пользователю по e-mail— если включить эту опцию, то после отправки заполненной Формы электронного письма пользователю будет автоматически отправлено электронное письмо подтверждения.

§Адрес электронной почты отправителя— используйте эту опцию, чтобы задать действительный рабочий адрес электронной почты для использования в качестве отправителя электронного письма подтверждения.

По умолчанию адрес отправителя электронного письма подтверждения совпадает с электронным адресом Администратора Сайта, указанным в поле Адрес электронной почты пользователя в разделе Отправка данных . Введите разные Адрес электронной почты отправителя если хотите, чтобы подтверждающие письма отправлялись с другого адреса, чем используется для приема отправленных формами данных. Этот вариант можно использовать для общения с посетителями, использующими общий (info@moya_firma.com или noreply@moya_firma.com), а не персональный (imya.familiya@moya_firma.com) электронный адрес.

§Адрес электронной почты пользователя— можно указать Поле Формы электронного письма, откуда будет браться электронный адрес для письма подтверждения.

§Объект— можно указать тему электронного письма подтверждения.

§Сообщение— можно ввести сообщение электронного письма подтверждения.

§Включить собранные данные— собранные данные можно вставлять в конец электронного письма подтверждения.

Наконец, можете выбрать следующее Параметры—

§Включить антиспам фильтр 'Captcha'— внизу Формы электронного письма можно добавить так называемую «капчу». Анти-спам фильтр CAPTCHA показывает в случайном порядке несколько искаженных букв; чтобы отправить данные через Форму электронного письма, посетитель должен правильно ввести эти буквы в отведенное для этого поле.

§Страница подтверждения после отправки данных— эта команда открывает Карту Сайта, где можно задать Страницу, показываемую Пользователю после отправки данных через Форму электронного письма и пересылки собранных данных по электронной почте. Для этой цели лучше использовать специальную страницу с благодарственным сообщением, а не Домашнюю Страницу. Эта страница должна быть Скрытая страница в меню(см. Этап 2 - Создание карты сайта.

Внешний вид Формы электронного письма можно настроить в окне Стили и модели | E-mail. Этап 4 - Расширенные настройки.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Стиль

Команды в этом разделе можо использовать для задания стиля электронных писем, создаваемых вами.

Сначала выберите нужный Элемент формы Это можно сделать при помощи Выпадающего Меню или нажав на нужный пункт в окошке предварительного просмотра.

Можно настроить следующие Элементы Формы:

Тэги— описательный текст Поля, который либо сообщает, какая требуется информация, либо содержит вопрос.

Поля— сюда посетитель вводит требуемую информацию.

Кнопки 'Отправить' и 'Сброс'— эти кнопки автоматически добавляются внизу Формы электронного письма. Они предназначены, соответственно, для отправки и удаления всех введенных данных.

Описание поля и проверка— эти сообщения отображаются в процессе заполнения Поля. Они предоставляют дополнительную информацию, указывают на неправильность введенных данных или предлагают посетителю заполнить обязательное поле.

Параметры, доступные для этих элементов, перечислены в разделе Стиль:

Тэги—

§Шрифт— задает шрифт, стиль и размер для текста.

§Цвет— задает цвет текста.

§Положение— можно указать, где должна отображаться Надпись Поля. Доступны три варианта: Отображать заголовки над полями, Отображать заголовки внутри полей и Отображать заголовки полей слева. Если Надпись нужно поместить слева от Поля, можно задать ее Ширина (%) в качестве процентного соотношения строки, в которой отображаются и Выравнивание надписей.

Поля—

§Цвет— укажите цвет текста (для нормального и выбранного состояний), фона (для нормального и выбранного состояний) и границы (для нормального состояния и для ошибки).

§Закругленные уголки— вы можете задать радиус закругления отдельно для каждого уголка.

§Тень— применяется к теням внутри полей, чтобы придать ощущение объемности.

Кнопки 'Отправить' и 'Сброс'—

§Шрифт— задает шрифт, стиль и размер для текста.

§Цвет— задает цвет текста, фона и границ кнопки.

§Закругленные уголки— вы можете задать радиус закругления отдельно для каждого уголка.

§Фоновое изображение— указывает на файл изображения (в форматах .JPG, .GIF или .PNG), используемого в качестве фона.

§Отображать кнопку 'Сброс'— эта опция включена по умолчанию. Кнопка «Сбросить» (используется для удаления содержимого полей) автоматически добавляется внизу Формы электронного письма, возле кнопки «Отправить».

Описание поля и проверка—

§Файл пиктограммы для описания— можно импортировать графический файл (формата JPG, GIF или PNG), который будет использоваться в качестве фонового изображения для кнопок.

§Отображать описание при выборе поля— если включить эту опцию, то при выборе Поля будет автоматически показываться дополнительная информация.

§Во время проверки данных произошла ошибка— можно выбрать вариант показа сообщения по умолчанию в случае ввода в Поле неверных данных или незаполнения Поля, которое должно быть обязательно заполнено. Доступны три варианта: Показывать диалоговое окно браузера, Показывать внутренние всплывающие окна и Показывать подсказку около неверно заполненного поля.

Когда вы находитесь в режиме предварительного просмотра сайта, это сообщение напоминает вам, что внесенные данные не будут отправлены по электронной почте. Форма отправки электронной почты работает в полном объеме только после публикации сайта на сервере.

Форма отправки электронно почты будет работать правильно, если сервер, на котором развернут сайт, поддерживает PHP и команду MAIL. Эту информацию можно получить при диагностике сервера в разделе Тест сайта на панели управления.

Если у вас есть проблемы с отправкой электронной почты, возможно, это ваш сервер не поддерживает стандартную конфигурацию. Попробуйте сменить настройки скриптов и метод отправки электронной почты, используя параметры в Расширенные настройки | Управление данными. Более подробную информацию можно получить у своего интернет-провайдера.


Окно Вставить поле .

Этап 3 - Создание Страниц > Объект-форма обратной связи >

Окно Вставить поле .

 Return to chapter overview
Покажите/скройте невидемый текст

Окно Вставить поле открывается при нажатии кнопок Добавить... и Редактировать... в окне Объект-форма обратной связи. Здесь можно создавать и определять поля для формы обратной связи.

Это окно имеет следующие разделы: Тип поля и Параметры.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Тип поля

Можно использовать команды этого раздела для создания списка полей, из которых состоит ваша почтовая форма обратной связи.

Доступны следующие настройки:

Текстовое поле— единичная строка текста отображается как пустой прямоугольник, куда посетитель вписывает свой текст.

Адрес электронной почты— сюда можно ввести адрес электронной почты (одну строку текста). Правильность указанного адреса проверяется автоматическим фильтром; такой адрес должен содержать символ @ и точку.

Текстовая область— сюда посетитель может ввести несколько строк текста (например, комментарии или вопросы).

Дата— текстовое поле, где посетитель может указать дату. Дату можно либо набрать, либо выбрать на календаре.

Раскрывающийся список— посетитель должен выбрать один из вариантов ответа, представленных в Выпадающем Списке.

Список— посетитель должен выбрать один из вариантов ответа, представленных в списке.

Множественный выбор— посетитель может выбрать один или несколько вариантов ответа, представленных в списке.

Одиночный выбор— посетитель может выбрать один из вариантов ответа, представленных в списке.

Пароль— символы, введенные в это текстовое поле, отображаются в виде точек или звездочек (в зависимости от операционной системы на компьютере посетителя). Это делается для того, чтобы посторонние лица не смогли прочитать пароль, введенный посетителем.

Приложенный файл— это текстовое поле предназначено для указания приложенного посетителем файла, который можно добавить при помощи кнопки [image] открывающей обзор доступных файлов.

По вопросам добавления и отправки приложенных файлов проконсультируйтесь со своим Хостинг-провайдером.

Контрольный вопрос— текстовое поле (одна строка), в которое посетитель вводит ответ на проверочный вопрос. Такие вопросы используются, чтобы отличить людей от программ, распространяющих спам.

Условия лицензионного соглашения— это текстовое поле содержит условия, с которыми посетитель должен согласиться для того, чтобы отправить данные через Форму электронного письма. Это поле можно использовать, например, для отображения правил по защите личных сведений.

Разделитель— это разделитель, а не поле. Он используется для отделения полей в разделы, чтобы длинные формы легче читались.

В зависимости от типа выбранного поля доступны различные параметры. Параметры, доступные для всех полей:

§Тэг— здесь можно ввести описание Поля. Этот текст будет отображаться сверху, рядом или внутри соответствующего Поля. В нем будет содержаться запрошенная информация или показываться вопрос, задаваемый посетителю.

§Ширина (%)— можно задать ширину Поля (от 5% до 100% всего имеющегося места).

§Отображать в той же строке, что и предыдущее поле— если включить эту опцию, то новое Поле будет размещено в той же строке, что и предыдущее. Два Поля могут отображаться в одной строке лишь в случае, если их суммарная ширина не превышает ширины строки.

§Установить как обязательное поле— при включении этой опции посетитель должен будет заполнить это поле, прежде чем ему будет позволено продолжить. Эта опция не используется для Полей типа Множественный выбор, а для Полей типа Контрольный вопрос включена по умолчанию.

Следующие настройки показываются в зависимости от типа Поля:

Текстовое поле—

§Максимальное количество символов: задайте максимальное количество символов, которое можно ввести в это поле. эта опция позволяет ограничить длину текста, который можно ввести в это поле. Например, для Текстового Поля, куда вводится номер кредитной карточки, можно установить лимит в 16 символов.

§Фильтр для вводимого текста— можно задать критерии проверки вводимых посетителем данных. Доступны следующие настройки фильтрации:

-Нет ограничений (буквы и цифры)— можно вводить любые алфавитно-цифровые символы.

-Только цифры— можно вводить только цифры.

-Телефон/факс (цифры и символы '-' и ' ')— в это Поле можно вводить цифры, дефис (-) и пробелы.

-Даты (цифры и символы '/' и '.')— в это поле можно вводить цифры и косую черту (/).

Адрес электронной почты—

§Запрашивать подтверждение адреса электронной почты— при включении этой опции автоматически добавляется еще одно поле, куда посетитель должен повторно ввести электронный адрес. Содержимое двух полей автоматически сверяется; в случае несовпадения посетителю выдается предупреждающее сообщение.

Текстовая область—

§Максимальное количество символов: задайте максимальное количество символов, которое можно ввести в это поле.

§Количество строк: задает высоту поля, определяя количество отображаемых строк (до 30).

Дата—

§Формат даты— можно указать формат ввода даты (с примерами наиболее распространенных государственных и международных форматов).

§Отображать значок календаря— эта опция включена по умолчанию, при этом возле Дата отображается значок Календаря. Нажатие на этот значок открывает календарь, где посетитель может выбрать нужную дату (вместо того, чтобы вводить ее вручную).

Список—

§Количество строк: задает высоту поля, определяя количество отображаемых строк (до 30).

Множественный выбор/Одиночный выбор—

§Количество столбцов— можно задать число столбцов, где отображаются доступные варианты.

Пароль—

§Требовать подтверждения пароля— при включении этой опции автоматически добавляется еще одно поле, куда посетитель должен повторно ввести пароль. Содержимое двух полей автоматически сверяется. В случае несовпадения посетителю выдается предупреждающее сообщение.

Контрольный вопрос—

§Правильный ответ— можно указать верный ответ, с которым будет сверяться ответ, данный посетителем.

Условия лицензионного соглашения—

§Текст соглашения— можно ввести текст условий, которые Покупатель должен принять до отправки заполненной Формы.

Чтобы создать список возможных ответов для Раскрывающийся список, Список, Множественный выбор и Одиночный выбор, можно использовать следующие опции:

§Добавить / Удалить— можно добавлять и удалять возможные ответы.

§Сдвинуть Вверх / Сдвинуть Вниз — можно изменить порядок ответов в списке, поместив выбранный ответ до предыдущего или после следующего ответа.

§Редактировать— выбранный ответ можно изменить. Если ответ уже выбран, нажмите еще раз, чтобы отредактировать его.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Параметры

Можно использовать параметры в этом разделе, чтобы настроить некоторые более специфичные свойства полей для форм обратной связи.

Можно выбрать один из этих вариантов:

§Описание поля— можно добавить сообщение, поясняющее посетителю, как заполнить данное Поле. Также можно задать значок, который будет отображаться возле Поля и указывать на наличие дополнительной информации. Эта информация будет показана во всплывающей подсказке, если посетитель наведет курсор мыши на значок.

§Атрибут <name>— можно задать значение, которое будет вставлено в атрибут <name> Поля при генерации HTML-кода страницы. Этим вариантом можно воспользоваться, например, если для Отправить данные в виде файла включена опция Отправка данных (см. Объект-форма обратной связи | Отправить).

§Поле с именем базы данных— можно задать имя Поля, чтобы собранные данные были правильно распознаны и сохранены в базе данных. Этим вариантом можно воспользоваться, например, если для Отправка данных включена опция Отправить данные в базу данных (см. Объект-форма обратной связи | Отправить).


Объект социальной сети

Этап 3 - Создание Страниц >

Объект социальной сети

 Return to chapter overview
Покажите/скройте невидемый текст

Каждый из нас, вполне возможно, является частью хотя бы одной социальной сети. Пока мы делимся сообщениями, фотографиями, видео или любым другим контентом, мы строим свой онлайн-профиль, создаем отношения и постоянно расширяем свой круг контактов.

Многие люди в наше время взаимодействуют через социальные сети, поэтому так важно устроить так, чтобы сайт правильно взаимодействовал с различными уже открытыми профилями в социальных сетях. WebSite X5 делает это через Объект социальной сети, который пользуется преимуществами плагинов, предоставляемых распространенными социальными сетями: Facebook, Google+, Twitter, Pinterest. как правило, результат зависит от выбранного плагина, но, вообще говоря, все они объединены единой целью: превратить посетителей сайта в новые контакты для социальных сетей, делиться интересным контентом.

Кликните, чтобы развернуть/уменьшить Справка: Социальные сети, которые доступны

Прежде всего, нужно выбрать элемент для добавления из списка Социальная сеть. Доступны следующие элементы:

§AddThis - кнопки 'Поделиться': этот вариант добавляет панель с кнопками и/или меню, где посетитель сможет выбрать социальную сеть, с контактами которой он хотел бы поделиться контентом.

Для получения более подробной информации о том, как работает плагин AddThis см. http://www.addthis.com/social-plugins

§Facebook - поле для комментариев: этот вариант добавляет раздел Facebook, где посетители могут остаивть свои комментарии.

§Facebook - поле 'Нравится': этот вариант предоставляет блок, где посетители могут посмотреть последние сообщения на «стене» Facebook и нажать кнопку «Мне нравится», чтобы следовать за ними.

§Facebook - кнопка 'Нравится': этот вариант выводит кнопку «Мне нравится». Посетитель может нажать ее и поделиться контентом, который ему понравился со своими друзьями на Facebook.

Для получения более подробной информации о том, как работает плагин Facebook см. https://developers.facebook.com/docs/plugins/

§Google Plus - кнопка '+1': этот вариант добавляет кнопку «Следовать». Посетители могут нажать ее, чтобы рекомендовать ваш контент, который им понравился, в сети Google+

§Google Plus - значок: этот вариант добавляет ярлычок, а посетители могут зайти и посмотреть профиль в Google+ и последовать за автором.

§Google Plus - пиктограмма: этот вариант добавляет кнопку, так что посетители могут зайти и посмотреть профиль в Google+ и последовать за автором.

Для получения более подробной информации о том, как работает плагин Google+ см. https://developers.google.com/+/plugins/

§Twitter - кнопка 'Твитнуть': эта возможность добавляет кнопку «Tweet». Нажав ее посетители смогут поделиться этим сайтом с теми, кто следует за ним на Твиттере.

§Twitter - поле учетной записи: эта возможность добавляет облать, где посетители могут почитать последние твиты с вашей учетной записи в Твиттере и присоединиться к обсуждению.

§Twitter - кнопка 'Читать': эта возможность добавляет кнопку «Следовать»: посетители могут нажать ее, чтобы следовать за вами на Твиттере.

Для получения более подробной информации о том, как работает плагин Twitter см. https://dev.twitter.com/docs/twitter-for-websites

§Pinterest - кнопка 'Читать': эта возможность добавляет кнопку «Следовать»: посетители могут нажать ее, чтобы следовать за вами в сети Pinterest.

§Pinterest - кнопка 'Pin It': эта возможность добавляет кнопку «Pin It»: посетители нажимают ее, чтобы поделиться контентом, который им нравится, в своей сти Pinterest.

Для получения дополнительной информации о плагине Pinterest см. http://pinterest.com/about/goodies/
Кликните, чтобы развернуть/уменьшить Справка: Доступные настройки

как правило, у каждого элемента, выбранного из списка Социальная сеть , есть ряд специфичных настроек Настройки, где можно задать способ работы каждого из них. Кроме параметров, относящихся к конкретной специфике, можно уделить внимание следующим параметрам:

AddThis - кнопки 'Поделиться'

§Имя пользователя: это имя пользователя, которое вы получаете при входе в свою учетную запись AddThis. Администраторы сайтов с учетной записью на AddThis должны задать свою роль, чтобы предоставлять статистику использования их сервиса посетителями сайта.

Facebook - поле для комментариев

§URL сайта: этот параметр задает URL-адрес сайта, который комментируют посетители. Обычно на страницу добавляется блок «Комментарии», где посетители оставляют свои комментарии: в данном случае URL должен указывать на ту часть страницы, которая содержит такой блок «Комментарии».

Facebook - поле 'Нравится'

§URL профиля: этот параметр задает URL страницы Facebook, на которую нужно ссылаться, для того, чтобы показать контент и попросить посетителя следовать за ним, нажав кнопку «Мне нравится».

Facebook - кнопка 'Нравится'

§URL сайта: этот параметр задает URL-адрес сайта, который посетители оценивают нажатиями кнопки «Мне нравится».

Google Plus - кнопка '+1'

§URL сайта: этот параметр задает URL-адрес сайта, который посетители могут рекомендовать своим контактам.

Google Plus - значок / Google Plus - пиктограмма

§URL профиля: этот параметр задает URL-адрес профиля Google+, чтобы посетители могли за ним следовать.

Twitter - кнопка 'Твитнуть'

§URL сайта: этот параметр задает URL-адрес сайта, который посетители могут опубликовать в своем Твиттере.

Twitter - поле учетной записи / Twitter - кнопка 'Читать'

§Имя пользователя: это имя пользователя в профиле Твиттера.

Pinterest - кнопка 'Читать'

§Имя пользователя: это имя пользователя в профиле Pinterest..

Pinterest - кнопка 'Pin It'

§URL сайта: этот параметр задает URL-адрес сайта, который посетители могут опубликовать на своей доске в Pinterest.

§URL изображения: этот параметр задает URL-адрес изображения, который посетители могут опубликовать на своей доске в Pinterest.

Замечания о совместимости с предыдущими версиями:

В 9 версии программы этот объект был доступен в качестве виджета в Объект HTML и виджеты.


Объект гостевая книга

Этап 3 - Создание Страниц >

Объект гостевая книга

 Return to chapter overview
Покажите/скройте невидемый текст

Гостевая книга позволяет посетителям оставлять свои записи или комментарии и/или голосовать. Она состоит из короткой формы, которую заполняют посетители и списка комментариев, сделанных другими посетителями.

WebSite X5 позволяет настроить гостевую книгу и управлять публикацией комментариев с помощью специальной панели управления онлайн.

Кликните, чтобы развернуть/уменьшить Справка: Настройки гостевой книги

Чтобы создать гостевую книгу, нужно задать Тип контента где посетители могут оставить на выбор:

Комментарии и голосование: посетители могут писать комментарии и голосовать на сайте.

Комментарий: посетители могут писать комментарии, но не могут голосовать на сайте.

Оценка: посетители могут голосовать, но не могут писать комментарии.

Можно выбрать параметры Параметры Комментариев, в зависимости от Тип контента вашего выбора:

§Режим просмотра: именно вы определяете, сразу ли будут публиковаться комментарии, которые оставляют посетители или сначала каждый комментарий будет проверяться. Режим задается этой командой на панели управления.

§Порядок просмотра: можно задать вывод публикуемых комментариев в хронологическом порядке или в обратном.

§Показать кнопку 'Нецензурное': выбирайте этот параметр в том случае, если хотите добавить кнопку «Пожаловаться», чтобы посетители могли сообщить о замеченных ими нарушениях.

§Включить антиспам фильтр 'Captcha': снизу в форму можно добавить антиспам-фильтр Captcha («капча»). Он показывает ряд искаженных знаков в случайном порядке, а посетитель должен набрать их правильно, только тогда комментарий отправится на сайт.

§Тип голосования: этот параметр определяет стиль элемента, с помощью которого посетители могут голосовать (например, 5 звездочек). Эта возможность доступна только если вы выбрали Оценка в качестве Тип контента.

Следующие параметры Параметры можно задать для каждого Тип контента:

§Высота: можно задать высоту в пикселах для Объект гостевая книга. Каждый раз, когда посетитель оставляет комментарий и он публикуется на сайте, комментарий добавляется к списку уже сделанных: можно задать высоту этого объекта, чтобы при достижении определенного количества комментариев список можно было прокручивать, чтобы увидеть остальные.
Кликните, чтобы развернуть/уменьшить Справка: Отправка данных гостевой книги

Можно указать как будут передаваться данные из формы комментирования, которые затем будет обрабатывать администратор сайта в разделе Метод сохранения данных :

§Подпапка на сервере для сохранения данных: задайте папку на сервере (с доступом на запись для PHP), в которую будут записываться принятые данные. Название главной папки сервера задается параметром Папка на сервере с правами на запись в окне Управление данными . Если вы не зададите подпапку, данные будут сохраняться прямо в корневую папку!

§Отправить по электронной почте уведомление о получении комментариев: по мере поступления новых данных будут автоматически отправляться уведомления по электронной почте.

§Адрес электронной почты пользователя: Нужно задать несколько параметров для каждой возможности отправки:

введите адрес получаетеля электронной почты с уведомлением о получении данных.

Провайдеры обычно предоставляют права доступа на запись ко всем папкам на сервере: если в вашем случае это так, вы не должны показывать путь к папке общего доступа. В любом случае, по поводу папки общего доступа лучше обратиться к провайдеру.

Можно запустить тест в разделе Тест Сайта онлайн панели управления в любом случае, если у вас есть доступ на запись к папке и всем папкам внутри нее, у вас будет к ним доступ (куда можно сохранять данные).

Страницу, содержащую Объект гостевая книга нужно сохранять в формате *.PHP, чтобы гостевая книга сохранялась корректно.

Используйте пункт Расширение генерируемых файлов в окне Свойства страницы | Эксперт, чтобы задать формат страниц.

Замечания о совместимости с предыдущими версиями:

В 9 версии программы этот объект был доступен в качестве виджета в Объект HTML и виджеты.

Лучшая практика:

-

Как управлять комментариями в блоге и гостевой книге с помощью панели управления

Родственные темы:

-

Панель управления онлайн


Этап 3 - Создание Страниц >

 Return to chapter overview
Покажите/скройте невидемый текст

На коммерческих сайтах обычно есть страница контактов. По большей части она включает интерактивную карту, которая показывает, где расположена компания географически. Такие карты полезны, поскольку сообщают потенциальным покупателям адрес и указывают как туда добраться.

WebSite X5 позволяет добавить карту на свой сайт, используя сервис Google Maps™ через .

Кликните, чтобы развернуть/уменьшить Справка: Настройки для интерактивной карты

Вот параметры Настройки, которые вам нужно задать для создания интерактивной карты:

§Адрес: это адрес, который нужно показать на карте.

§Стиль: эта настройка задает в каком виде показывается карта: карта, спутник, земля.

§Язык: эта настройка определяет язык, используемый на карте.

§Размеры: эта настройка определяет размер карты. Оставьте Сохранять пропорции выбранным, если хотите сохранить соотношение высоты и ширины (форм-фактор).

Замечания о совместимости с предыдущими версиями:

В 9 версии программы этот объект был доступен в качестве виджета в Объект HTML и виджеты.


Объект Flash-анимации

Этап 3 - Создание Страниц >

Объект Flash-анимации

 Return to chapter overview
Покажите/скройте невидемый текст

WebSite X5 позволяет добавить на страницы вашего сайта различные виды анимаций и спецэффектов. Может быть, они станут более привлекательными и интересными.

Можно выполнить импорт всех видов Flash-анимации (в формате *.SWF) от простых баннеров с текстом и изображениями до более сложных и интерактивных видеоклипов. Их можно импортировать либо со своего компьютера, либо взять из Интернет. Можно использовать дополнительные возможности для прикрепления любых файлов, необходимых для правильной работы анимации.

Команды для создания Объект Flash-анимации организованы в разделы Основной и Эксперт.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Основной

Можно использовать команды этого раздела для импортирования файлов, нужных для создания Объект Flash-анимации.

Файл Flash-анимации может находиться либо на локальном компьютере, либо в Интернете. Если файл находится на локальном компьютере, выберите опцию Локальный файл на компьютере и нажмите кнопку [image] для выбора нужного SWF-файла. Если файл находится в Интернете, выберите опцию Файл в Интернет и введите URL-адрес файла.

Выберите параметр Предпросмотр чтобы предварительно просмотреть импортированную анимацию в окне предпросмотра.

Для воспроизведения (а также предварительного просмотра) Flash-анимации на компьютере должен быть установлен проигрыватель Macromedia Flash Player. Это можно сделать в http://get.adobe.com/it/flashplayer/otherversions/ (выберите параметр «Другие браузеры»).

Для добавленной Анимации можно задать следующие Свойства:

§Альтернативный текст— введите текст, который будет отображаться в случае, если воспроизведение Flash-анимации по какой-то причине невозможно.

§Размеры: эта настройка задает ширину и высоту Flash-анимации в пикселах. В квадратных скобках показывается максимально возможное значение, зависящее от настроек Таблицы Макета Страницы. Оставьте Сохранять пропорции выбранным, если хотите сохранить соотношение высоты и ширины (форм-фактор).

§Версия Flash-плеера: укажите версию программы Flash Player, необходимую для воспроизведения Flash-анимации. Если у пользователя отсутствует эта версия, то ему будет предложено обновить программу.

§Прозрачный фон: выберите эту опцию, чтобы задать прозрачный фон для Flash-анимации.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Эксперт

Можно использовать команды этого раздела для импортирования любых файлов, нужных для создания Flash-анимации.

Все файлы, связанные с Flash-анимацией, перечисляются в таблице, где также представлены имя файла и Относительный путь к серверу.

Для связанных файлов можно использовать следующие опции:

§Добавить...: новый файл можно добавить в список посредством окна Выгрузить связанный файл.

§Редактировать...: новый файл можно добавить в список посредством окна Выгрузить связанный файл.

§Удалить: выбранный файл можно удалить из таблицы связанных файлов.

Также доступна эта настройка:

§Путь для выгрузки Flash-файла: можно задать полный путь папки, куда должен быть загружен SWF-файл Flash-анимации.


Объект список товаров

Этап 3 - Создание Страниц >

Объект список товаров

 Return to chapter overview
Покажите/скройте невидемый текст

Одна из наиболее интересных функций в программе WebSite X5 — это создание интернет-магазинов, благодаря чему можно показывать свои товары в виртуальной витрине и продавать их покупателям со всего мира.

Программа WebSite X5позволяет добавлять Товары, управлять он-лайн «корзинами для покупок» и создавать он-лайн каталоги при помощи Объекта «Список Товаров» Список Товаров — это основа интернет-магазина, поскольку именно этот список дает возможность покупателям просматривать предлагаемые товары, читать их описание на Карточках Товаров и покупать нужные товары.

Команды для создания списка товаров расположены в разделах Список и Настройки.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Список

Можно использовать команды этого раздела для указания, какие товары появятся в списке товаров.

Колонка в левой части окна отображает Список категорий и товаров внесенный при создании Корзина на этапе 4 — Расширенные настройки.

Нужные Категории и Товары можно отметить галочкой, чтобы добавить их в создаваемый Объект «Список Товаров». Все выбранные товары показаны в колонке справа.

Отметить какую-то Категорию и отметить все Товары в какой-то Категории — это не одно и то же; только в первом случае, если в эту Категорию впоследствии будут добавляться новые Товары, они будут автоматически вноситься в Объект «Список Товаров», с которым связана данная Категория.

Можно задать, в каком порядке выводить товары в правой колонке: нажмите нажмите на кнопку Порядок сортировки и выберите Свои настройки, Имя, Категория, Цена, По возрастанию или По убыванию.

Если выбрано Свои настройки можно использовать кнопки Сдвинуть вверх / Сдвинуть вниз для расстановки товаров в списке в желаемом порядке.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Настройки

Можно использовать команды этого раздела, чтобы задать вид карточки товара, которая дает информацию о товаре из списка.

Сначала нужно выбрать Режим отображения для Блоков с Товаром:

Только текст

При выборе этого варианта показывается следующее: название Товара, описание, выпадающее меню с разновидностями Товара (если они есть), цена, поле «количество» и кнопка «Купить» (возле поля «количество»).

Изображение и текст

При выборе этого варианта слева показывается фотография Товара, а справа — сведения о товаре.

Текст и изображение

Этот вариант аналогичен предыдущему, разве что сведения о Товаре показываются слева, а фотография Товара — справа.

Только картинки

В этом случае все сведения о Товаре показываются под фотографией. Полное описание не приводится.

Чередовать картинки и текст

В этом случае в Блоке с Товаром попеременно показываются то Фотография и Текст справа, то Фотография и Текст слева.

Можно использовать следующие параметры в Настройки рамок чтобы задать:

§Количество кадров в строке— можно задать число Карточек Товара в одной строке.

§Высота кадра— можно задать высоту Карточки Товара (в пикселах). Размер фотографии каждого Товара автоматически изменяется в зависимости от этого значения. Если описания слишком длинные и не помещаются в отведенном месте, то отображается полоса прокрутки.

§Ширина изображения (%)— если выбран вариант, когда показывается фотография рядом с текстом, то можно указать, сколько места должно отводиться под фотографию, а сколько под текст. Например, если фотография занимает 30% имеющегося места на Карточке Товара, то оставшиеся 70% будут заняты текстом.

§Внутреннее поле— под полем здесь понимается пространство между кромкой Карточки Товара и ее содержимым. Здесь можно задать ширину этого пространства..

Можно использовать параметр Графика чтобы задать:

§Цвет текста/Цвет фона— цвета текста и фона для карточки товара.

§Шрифт— задает шрифт, стиль и размер для текста.

Можно использовать параметр Параметры чтобы задать:

§Толщина рамки: толщина границ (для каждой границы можно задать свою толщину).

§Цвет рамки: цвет границ (и снова, для каждой границы можно задать свой цвет).

§Сглаживание углов: насколько закругленными будут уголки (каждый уголок может иметь свою степень закругленности).

§Тень: тень, определяется цветом, расположением, рассеянием и размером.

Можно использовать эти параметры Параметры, чтобы задать следующие настройки:

§Показать цену— здесь, на карточке товара, отображается цена товара, с учетом или без учета НДС.

§Отобразить поле количества— если включить эту опцию, то в Карточке Товара будет показываться Поле «Количество». Этим полем могут воспользоваться покупатели, желающие приобрести несколько единиц одного и того же товара.

§Разрешить переход по ссылке при нажатии на изображение— если включить эту опцию, то ко всем фотографиям в Карточке Товара будет добавлена ссылка на их увеличенные версии. Увеличенные фотографии показываются в окне Электронная Витрина.

Можно настроить стиль Showbox: используя параметры раздела Стили и модели | E-mail на этапе 4 — Расширенные настройки, вы можете задать цвета, тени, прозрачность, динамические эффекты и т.д.

Чтобы список товаров работал правильно, у вас уже должны быть товары в Корзине, используйте команды раздела Корзина на этапе 4 — Расширенные настройки.


Объект HTML и виджеты

Этап 3 - Создание Страниц >

Объект HTML и виджеты

 Return to chapter overview
Покажите/скройте невидемый текст

В программе WebSite X5 используется определенный Объект для каждого типа содержимого: текста, изображений, анимации, форм электронных писем и др. А с помощью объекта Объект HTML и виджеты возможности практически неограниченные. Этот тип Объекта позволяет вставлять HTML-код непосредственно в Страницы, чтобы добавить определенные функции, которые иначе было бы невозможно реализовать.

Особенно полезны Виджеты — небольшие программы, устанавливаемые и исполняемые из Веб-страницы. Хороший пример виджета - Google News™: вам потребуется только настроить несколько параметров, чтобы добавить блок со всеми последними новостями, который обновляется в реальном времени.

Команды для создания Объект HTML и виджеты организованы в разделы HTML-код и Эксперт.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе HTML-код

В этом разделе есть редактор для включения HTML-кода, добавляемого на вашу страницу. Можно либо вписать код, либо дважды щелкнуть на одном из доступных виджетов.

Редактор в разделе HTML-код поддерживает следующие команды:

Вырезать [CTRL+X] - Копировать [CTRL+C] - Вставить [CTRL+V]

Эти три команды предназначены для вырезания, копирования и вставки выбранного кода.

Отменить [CTRL+Z] - Восстановить [ALT+CAPS+BACKSPACE]

Отмена или повтор последней операции.

Подсветка синтаксиса, добавленная в разделе «HTML-код», упрощает чтение кода и нахождение ошибок; текст в разных частях кода окрашивается в разные цвета, при этом сам код не изменяется. При таком способе код легче читается и мы делаем меньше ошибок.

Все доступные Виджеты отображаются в Список виджетов. Если сделать двойной щелчок на Виджете, который нужно добавить, то откроется другое окно, где можно задать разные настройки. После подтверждения HTML-кода будет создан Виджет, который будет автоматически добавлен в редактор.

Замечания о совместимости с предыдущими версиями:

Возможные типы объектов - В 9 версии были добавлены в качестве виджетов гостевая книга, кнопки социальных сетей и карта сайта. В 10 версии теперь они стали объектами (см. Этап 3 - Создание Страниц).

Доступны следующие параметры: Параметры:

§Ширина: задает ширину Объект HTML и виджеты; настраивается автоматически в соответствии со свободным пространством в таблице макета страницы.

§Высота: этот параметр задает высоту для Объект HTML и виджеты.

§Отображать полосы прокрутки: этот параметр включен по умолчанию: полоса прокрутки добавляется автоматически, если Объект HTML и виджеты больше значения, заданного параметром Высота.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Эксперт

Можно использовать команды этого раздела для создания таблиц стиля (*.CSS) и/или списка файлов для добавления к Объект HTML и виджеты в ходе работы.

Для ввода кода Таблицы Стилей можно использовать редактор в разделе CSS-код (этот же редактор используется в разделе HTML-код). Таблицы Стилей (CSS) предназначены для настройки внешнего вида связанных с ними HTML-страниц.

Все связанные файлы показываются в таблице Файлы, связанные с HTML-кодом. В этой таблице отображаются имя файла и Относительный путь к серверу.

Для составления списка связанных файлов можно использовать следующие команды:

§Добавить...— новый файл можно добавить в список посредством окна Выгрузить связанный файл.

§Редактировать...— настройки выбранного файла в списке можно изменить в окне Выгрузить связанный файл.

§Удалить— выбранный файл можно удалить из списка.


Редактор изображений

Этап 3 - Создание Страниц > Общие характеристики >

Редактор изображений

 Return to chapter overview
Покажите/скройте невидемый текст

Помимо функции оптимизации импортируемых изображений, в программе WebSite X5 есть встроенный графический редактор для профессиональной подготовки изображений к размещению на сайте.

Редактор Редактор изображений можно открыть, нажав кнопку Редактировать..., которая обычно находится в окне, где импортируются графические файлы, например, Изображение объекта, Объект в галерее и Корзина.

В редакторе Редактор изображений есть следующие разделы: Кадрирование и поворот, Фильтры, Водяной знак, Маска, Рамка, Эффекты и Библиотека.

В редакторе Редактор изображений также есть следующие кнопки:

§Ok— эта команда закрывает Редактор изображений и снова открывает главное окно, сохраняя изображение со всеми изменениями.

§Отмена— эта команда закрывает Редактор изображений и снова открывает главное окно, не сохраняя изображение.

§Сохранить как...— эта команда сохраняет копию исходного изображения в формате PNG.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Кадрирование и поворот

Можно использовать команды этого раздела, чтобы указать часть изображения, которую вы хотите показывать, и удалить остальное.

Можно пометить область, которую вы хотите сохранить (рамка кадрирования) на экране предварительного просмотра изображения и использовать указатели, чтобы изменить размеры этой области. Этот прямоугольник также можно переместить, чтобы в него попала нужная часть картинки. Для этого нужно нажать на него, зажать левую кнопку мыши и перетащить его на новое место.

Подтверждать операцию обрезки не требуется; просто затемненная часть изображения за пределами прямоугольника выделения будет скрыта. Для отмены обрезки достаточно щелкнуть мышью вне прямоугольника выделения (при этом он исчезнет).

Возле Изображения в этом окне представлены следующие опции:

§Вырезать— этот параметр показывает значения (в пикселах) Координата X и Координата Y, которые соответствуют верхнему левому углу выбранной области. Также доступны Ширина и Высота этой области. Размеры прямоугольника выделения можно изменить, внеся изменения в соответствующие значения (как вариант, можно использовать «ручки» на прямоугольнике).

§Зеркало— можно получить зеркальное отражение (по горизонтали или по вертикали).

§Поворот— можно задать угол поворота Изображения (по часовой стрелке): 0°, 90°, 180° или 270°.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Фильтры

Можно использовать параметры в этом разделе для цветокоррекции и применения графических фильтров к импортированному изображению.

Если вы хотите применить фильтр, выберите его из списка, активируйте и задайте настройки. Изменения, вносимые фильтрами применяются немедленно и сразу отображаются при предварительном просмотре изображения.

§Фильтры— этот параметр перечисляет все доступные фильтры. здесь перечисляются имеющиеся фильтры: Яркость/Контраст, RGB, HSL, Резкость, Размытие, Черно-белое, Сепия, Мозаика, Портрет, Рамка, Масляные краски, Холст, Шум, Мрамор. Для применения фильтра нажмите на него; при этом будет поставлена галочка.

§Настройки— для выбранного фильтра можно задать настройки.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Водяной знак

Можно использовать команды этого раздела для создания водяных знаков на импортированных изображениях для защиты от неправомерного копирования. При нанесении водяного знака Изображение изменяется определенным образом (иногда водяной знак содержит информацию об авторских правах), что препятствует его бесконтрольному копированию или использованию.

§Водяной знак— в этом разделе перечисляются разные водяные знаки, которые можно нанести на Изображение. При желании можно добавить свой собственный водяной знак; для этого нужно выбрать второй вариант предварительного просмотра ( (Настроить...) в списке и импортировать нужный графический файл.

§Настройки— водяной знак, добавленный к Изображению, можно повернуть на 90°, 180° или 270° , а также получить его отражение (по горизонтали или по вертикали).

В качестве водяного знака можно использовать графический файл формата GIF, PNG, PSD или WMF с поддержкой прозрачности. Водяной знак накладывается на исходное Изображение так, что остаются видны лишь те участки Изображения, которые соответствуют прозрачным участкам водяного знака.

Формат GIF поддерживает лишь один уровень прозрачности, тогда как форматы PNG и PSD — до 256 уровней, поэтому водяные знаки рекомендуется сохранять в одном из этих двух форматов.

+

=

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Маска

Можно использовать команды этого раздела для применения маско к импортированным изображениям для того, чтобы разнообразить их вид.

§Маска— в этом представлены разные маски, которые можно нанести на Изображение. При желании можно использовать свою собственную маску; для этого нужно выбрать второй вариант предварительного просмотра ( Настроить...) в списке и импортировать нужный графический файл.

§Настройки— маску, нанесенную на Изображение, можно повернуть на 90°, 180° или 270° , а также получить ее отражение (по горизонтали или по вертикали).

Маска — это 256-цветное изображение в градациях серого, которое наносится на исходное Изображение так, что участки Изображения, закрытые черными участками маски, скрываются, а участки, закрытые белыми участками маски, остаются видимыми.

+

=

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Рамка

Можно использовать команды этого раздела для применения рамки к импортированным изображениям.

§Рамка— в этом разделе перечислены разные рамки, которые можно добавить к Изображению. При желании можно добавить свою собственную рамку; для этого нужно выбрать второй вариант предварительного просмотра (Настроить...) в списке и импортировать графический файл, содержащий нужную рамку.

§Настройки— рамку, добавленную к Изображению, можно повернуть на 90°, 180° или 270° , а также получить ее отражение (по горизонтали или по вертикали).

В качестве рамки можно использовать графический файл формата GIF, PNG, PSD или WMF с поддержкой прозрачности. Рамка накладывается на исходное Изображение так, что остаются видны лишь те участки Изображения, которые соответствуют прозрачным участкам рамки.

Формат GIF поддерживает лишь один уровень прозрачности, тогда как форматы PNG и PSD — до 256 уровней, поэтому рамки рекомендуется сохранять в одном из этих двух форматов.

+

=

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Эффекты

Можно использовать команды этого раздела для применения графических спецэффектов к импортированным изображениям.

§Эффекты— в этом разделе перечислены разные эффекты, которые можно применить к Изображению. Вот они: Тень, Отражение, Внешнее свечение, Цветная рамка, Градиент, Фаска, Рельеф, Размытая, Поворот, Перспектива, Наклон и Непрозрачность. Для применения эффекта нажмите на него (при этом будет поставлена галочка).

§Настройки— для выбранного эффекта можно задать настройки.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Библиотека

Можно использовать команды этого раздела для применения таблицы стилей к текущему изображению. Либо можно сохранить для этого изображения новую таблицу стилей, которую впоследствии можно будет применять к другим изображениям.

§Применить— к Изображению можно применить выбранную Таблицу Стилей.

§Добавить— настройки, определенные в Редактор изображений для текущего Изображения, можно сохранить и создать на их основе новую Таблицу Стилей. Она будет добавлена в список Свои настройки Таблиц Стилей.

§Удалить— Таблицу Стилей можно удалить из списка Свои настройки. Нельзя удалить Заводские настройки удалить нельзя.


Стиль ячейки

Этап 3 - Создание Страниц > Общие характеристики >

Стиль ячейки

 Return to chapter overview
Покажите/скройте невидемый текст

WebSite X5 значительно облегчает создание страниц сайта, разбивая страницу на ячейки, из которых состоит таблица макета страницы. Количество ячеек зависит от количества строк и столбцов в таблице макета страницы. Для создания страницы и наполнения ее содержимым нужно всего лишь перетаскивать объекты в соответствующие ячейки (в одну ячейку помещается не более одного объекта).

Таким образом, ячейка — это элементарная область страницы. У каждой ячейки есть свое содержимое и может быть свое графическое оформление. Параметры полей, фона и кромок ячейки можно задать так, чтобы содержимое страницы было представлено в удобном для восприятия виде.

Чтобы задать стиль ячейки, выберите его и нажмите на [image] кнопку, чтобы открыть окно Стиль ячейки. Эти настройки разбиты на следующие разделы: Стиль, Текст и Библиотека.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Стиль

Можно использовать команды этого раздела, чтобы задать внешний вид текущей ячейки в таблице макета страницы.

Сначала нужно выбрать фон Фон ячейки из следующих вариантов:

Цветной фон ячейки: фон заполнен сплошным цветом.

Градиентный фон: фон заполнен цветовым переходом. Можно задать начальный и конечный цвета, а также направление градиента.

Фоновое изображение: в качестве фона ячейки используется изображение.

Подогнать к Фону Ячейки: фоновое изображение обрезается и подгоняется точно по размеру ячейки (см. Как работать над стилем ячейки).

Для каждого стиля фона можно задать Настройки.

 | Цветной фон ячейки | Градиентный фон | Фоновое изображение | Подогнать к Фону Ячейки
§Цвет фона: задает цвет для использования в качестве фонового. | P | - | P | P
§Начальный цвет градиента / Конечный цвет градиента: задается начальный и конечный цвет для цветового перехода. | - | P | - | -
§Диффузия: указывает начальный или конечный цвет более важен, задает на каком участке (в пикселах) должен происходить градиентный переход цвета. Например, вертикальный переход от серого к белому при диффузии 250 означает, что при переходе сверху вниз на протяжении первых 250 пикселов серый свет постепенно переходит в белый, а вся область ниже этого — полностью белая. | - | P | - | -
§Направление: можно выбрать направление цветового перехода: сверху, снизу, слева или справа. | - | P | - | -
§Файл изображения: указывает на файл изображения (в форматах .JPG, .GIF или .PNG), используемого в качестве фона. | - | - | P | P
§Положение: указывает, должно ли повторяться фоновое изображение. Изображение может повторяться по горизонтали, по вертикали или сразу в обоих направлениях, чтобы занять все отведенное пространство. Фоновое изображение должно быть специально откадрировано так, чтобы можно было заполнять им пространство. | - | - | P | -
§Выравнивание: можно задать выравнивание фонового изображения внутри ячейки. | - | - | P | -
§Насыщенность цвета: можно поменять цвет фонового изображения: эффект «раскрашивания» применяется ко всему изображению, так что можно окрасить его в нужные вам цвета. | - | - | P | -
§Ширина блока / Высота блока: можно задать размер блоков фонового изображения. Можно указать, какая часть изображения останется неизменной, а какая будет повторяться (см. Как работать над стилем ячейки). | - | - | - | P
§Непрозрачность: для фонового изображения можно задать степень прозрачности или градиент. Чем меньше (ближе к нулю) заданное значение, тем выше прозрачность (и тем лучше виден фон страницы). | P | P | P | P

Используйте параметры в разделе Рамка чтобы задать:

§Толщина рамки: толщина границ (для каждой границы можно задать свою толщину).

§Цвет рамки: цвет границ (и снова, для каждой границы можно задать свой цвет).

§Сглаживание углов: насколько закругленными будут уголки (каждый уголок может иметь свою степень закругленности).

§Тень: тень, определяется цветом, расположением, рассеянием и размером.

И, наконец, можно использовать параметры Выравнивание и поля ,чтобы задать следующее:

§Выравнивание: этот параметр задает выравнивание объекта по верху/по центру/по низу и по левому краю/по центру/по правому краю текущей ячейки.

§Внешние поля / Внутреннее поле: эти параметры задают значение в пикселах для внешнего и внутреннего отступа с текущей ячейке (см. Блочная модель WebSite X5).

Замечания о совместимости с предыдущими версиями:

В предыдущих версиях программы параметры для задания полей и выравнивания содержимого ячейки находились в меню [image] и [image] на кнопках сверху раскладки таблицы. В 10 версии эти кнопки убрали, а параметры теперь можно задать в окне Стиль ячейки| Стиль.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Текст

Можно использовать команды этого раздела, чтобы задать стиль текста, дополняющего оформление текущей ячейки в таблице макета страницы.

Сначала нужно определить, что будет добавлено, текст или изображение. Есть следующие варианты:

Заголовок: текст, который будет отображаться в качестве названия текущей ячейки.

Изображение для 'шапки' страницы: в заголовок текущей ячейки можно добавить изображение, которое будет показываться возле Заголовок.

Текст описания: текст, который будет показываться под текущей ячейкой.

После добавления необходимых элементов можно задать для них разные настройки. Выберите нужный элемент для задания настроек либо в раскрывающемся меню, либо нажав на этот элемент в окошке просмотра.

Есть несколько параметров в разделе Настройки , в зависимости от типа выбранного элемента:

Доступны следующие параметры для Заголовок и Текст описания:

§Контент: введите текст названия или описания ячейки.

§Цвет фона / Цвет текста: можно задать цвет букв и фон для текста, над которым вы работаете.

§Шрифт: задает шрифт, стиль и размер для текста.

§Выравнивание: можно указать, будет ли текст в ячейке выровнен слева, по центру или справа.

§Внешние поля / Внутреннее поле: можно задать размер полей для текста (в пикселах). При этом текст будет расположен на заданном расстоянии от границы ячейки.

Доступны следующие параметры для Изображение для 'шапки' страницы:

§Файл изображения: указывает на файл изображения (в форматах .JPG, .GIF или .PNG), используемого в качестве фона.

§Выравнивание: можно задать, будет ли изображение в ячейке выровнено слева, по центру или справа.

§Поля: можно задать размер полей для текста (в пикселах). При этом текст будет расположен на заданном расстоянии от границы ячейки, и, соответственно, отделится от Заголовок.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Библиотека

В этом разделе можно выбрать существующие настройки, сохраненные в качестве стиля, и применить их к текущей ячейке. Либо можно сохранить настройки, заданные для текущей ячейки, в качестве нового стиля (для последующего применения к другим ячейкам).

В окне «Библиотека» отображается список Заводские настройки и Пользовательский Таким образом создаются стили . Можно использовать следующие команды:

§Применить: настройки выбранного стиля можно применить к текущей ячейке.

§Добавить: можно сохранить настройки графики, определенные в разделах Стиль и Текст для текущей ячейки, можно сохранить в новом стиле. Этот стиль можно добавить в список стилей: Пользовательский .

§Удалить: выбранный стиль можно удалить из списка Пользовательский стилей. Нельзя удалить Заводские настройки стили.

При создании нового стиля сохраняются все настройки текущей ячейки, но не ее содержимое, которое может меняться от одной ячейки к другой. Например, в новом стиле сохраняются Цвет текста или Шрифт но не Контент заданные для таких элементов, как Заголовок или Текст описания исходной ячейки.

Лучшая практика:

-

Как работать с Стиль ячейки

Родственные темы:

-

Блочная модель WebSite X5


Окно Ссылка

Этап 3 - Создание Страниц > Общие характеристики >

Окно Ссылка

 Return to chapter overview
Покажите/скройте невидемый текст

Помимо статических меню, автоматически создаваемых на основе Карты Сайта, для перемещения по Сайту посетители могут воспользоваться ссылками, которые программа WebSite X5 умеет добавлять к Тексту и Изображениям. Эти ссылки позволяют загружать внутренние или внешние страницы, открывать файлы, показывать изображения, добавлять товары в Корзину и др.

При создании ссылки следует определить ее действие. Для ссылки также можно задать и настроить всплывающую подсказку; при нажатии на ссылку в этой всплывающей подсказке показывается краткая информация.

Параметры для построения ссылки доступны в разделах Действие и Описание.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Действие

Можно использовать команды этого раздела, чтобы указать, какое действие связано со ссылкой:

Страница сайта

Можно создать ссылку на Страницу Сайта. Нажатие кнопки [image] открывает Карту Сайта, где можно выбрать Страница сайта, на которую нужно создать ссылку. Если нужно, можно также задать адрес Внутренняя ссылка страницы ,куда ведет ссылка, выбрать из списка якорей на странице. Ссылку можно настроить так, что она откроется в том же окне, в новом окне Браузера или во Временном окне. В последнем случае откроется новое окно Браузера, для которого можно задать Ширина подсказки и Высота.

Якоря должны получить связи с объектами еще до того, как они появятся в списке Внутренняя ссылка страницы.

Проект можно сохранить, нажав кнопку, [image] перейдя на Этап 3 - Создание Страниц.

Файл или URL

Можно создать ссылку на внешнюю Веб-страницу на локальном компьютере или ссылку на Веб-страницу, уже размещенную в Интернете. Чтобы задать страницу на локальном компьютере, выберите Локальный файл на компьютере и нажмите кнопку [image] для указания пути к файлу. Чтобы задать страницу, уже размещенную в Интернете, выберите Файл в Интернет и введите URL-адрес в соответствующее поле.

зависимости от настроек ссылки, страница откроется в том же окне, в новом окне или во Временном окне. Для Временного окна можно задать Ширина подсказки и Высота.

Файл или URL ShowBox

Можно создать ссылку для отображения любого файла, имеющегося на компьютере или уже размещенного в Интернете, на так называемой Электронной Витрине. В отличие от внешнего Временного окна, при открытии такой ссылки файл отображается на переднем плане текущей Страницы, которая автоматически делается полупрозрачной и светлеет (темнеет).

Чтобы задать файл, на который создается ссылка, либо выберите Локальный файл на компьютере и нажмите кнопку [image] для указания файла, либо выберите Файл в Интернет и введите URL-адрес (уникальный идентификатор в Интернете). В разделе Свойства Электронной Витрины можно задать Ширина подсказки и Высота Электронной Витрины, а также Заголовок и будет показан снизу.

Ссылка на окно Электронной Витрины в первую очередь предназначена для показа изображений, но ее также можно использовать для показа других материалов, таких как документы формата PDF.

Галерея ShowBox

Можно создать ссылку для показа Галереи изображений на Электронной Витрине. Чтобы создать список изображений, используйте команды Добавить..., Удалить, Sposta Sopra и Sposta Sotto. Также можно задать Ширина и Высота окна Электронной Витрины.

Можно настроить стиль Showbox: используя параметры раздела Стили и модели | E-mail на этапе 4 — Расширенные настройки, вы можете задать цвета, тени, прозрачность, динамические эффекты и т.д.

Адрес электронной почты

Можно создать ссылку, запускающую используемую по умолчанию программу для работы с электронной почтой, чтобы отправить электронное письмо. Для создания ссылки такого типа достаточно ввести электронный адрес, тему письма и (по желанию) текст сообщения.

Если установить опцию Подключить защиту адреса электронной почты, то указанный адрес электронной почты будет зашифрован в HTML-коде Страницы. Это сделает его недоступным для шпионских программ, собирающих электронные адреса для последующей рассылки спама.

Интернет-звонок

Можно создать ссылку, запускающую программу для звонков через Интернет, такую как Skype. Также можно задать Тип действия: на выбор из Звонок, Добавить контакт, Чат, Показать профиль, Голосовая почта Skype VoiceMail и Отправить файл.

Звук

Можно создать ссылку на звуковой файл. Чтобы задать аудиофайл, на который указывает ссылка, либо выберите Локальный файл на компьютере и нажмите кнопку [image] для указания файла, либо выберите Файл в Интернет и введите URL-адрес (уникальный идентификатор в Интернете), чтобы указать Страницу, на которой создается ссылка на аудиофайл. Можно использовать файлы формата MP3.

Когда посетитель нажимает на ссылку, отображается Всплывающая Подсказка с кнопкой «Воспроизведение / Пауза», позволяющей начать (остановить) воспроизведение звукового файла. Если убрать курсор мыши с Всплывающей Подсказки, то она скрывается и воспроизведение звукового файла прекращается.

Всплывающая Подсказка для ссылки на звуковой файл автоматически создается Программой. Внешний вид Всплывающей Подсказки задается в окне Стили и модели | Тексты (Этап 4 - Расширенные настройки).

Распечатать страницу

Можно создать ссылку, позволяющую напечатать текущую страницу.

Окно сообщения

Можно создать небольшое Всплывающее окно сообщения, чтобы показывать посетителю предупреждающее сообщение. Для создания такой ссылки достаточно ввести Текст сообщения. Включите опцию Отображать как всплывающее окно, чтобы сообщение показывалось так, как это делается в ОС Windows.

Лента RSS

Можно показывать RSS-ленту Сайта. Ссылка будет работоспособной в случае, если RSS-лента создана посредством соответствующего окна в Этап 4 - Расширенные настройки.

При тестировании вашего сайта это сообщение появляется для того, чтобы напомнить вам, что RSS-поток отображается только на сайте, который опубликован в Интернет.

Блог

Можно создать ссылку для открытия Блога, связанного с Сайтом. Для работоспособности этой ссылки нужно предварительно создать Блог переходя на Этап 4 - Расширенные настройки.

зависимости от настроек, Блог откроется в том же окне или в новом окне Браузера.

Карта сайта

Можно создать ссылку, позволяющую показать на определенной странице полную Карту Сайта. Элементы Карты Сайта генерируются автоматически и содержат рабочие ссылки на разные Страницы. Карта Сайта позволяет посетителю перемещаться по Сайту. Отображением элементов на карте можно управлять при помощи команд Развернуть все и Свернуть все.

Показать Корзину

Можно создать ссылку, открывающую страницу Корзины со списком уже заказанных товаров.

Добавить в Корзину

Можно создать ссылку на Корзину, при помощи которой Посетитель может сделать заказ или добавить Товар в Корзину.

В первом случае следует использовать опцию Показать список товаров выбранной категории и выбрать нужную Категорию в каталоге Товаров.

Во втором случае следует использовать опцию Добавить выбранный товар прямо в Корзину и выбрать в списке нужный Товар. Также можно указать Категория и Количество Товара, добавляемого в Корзину.

Для работоспособности ссылок Показать Корзину и Добавить в Корзину нужно предварительно создать Корзину в разделе Корзина (Этап 4 - Расширенные настройки).
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Описание

Можно использовать параметры в этом разделе, чтобы добавить к ссылке описание. Это описание используется как пояснительный текст под названием «всплывающая подсказка» (или просто «подсказка»). Всплывающие Подсказки отображаются возле курсора мыши при его наведении на Ссылку и поясняют, что произойдет при нажатии на Ссылку (открытие другой Страницы, открытие другого Сайта, показ изображения, скачивание файла и др.).

Вот команды для написания подсказок:

§Текст— в это поле вводится пояснительный текст для Ссылки.

§Файл изображения— можно добавить изображение, которое будет показано рядом с текстом Всплывающей Подсказки или вместо этого текста.

§Ширина подсказки— задайте ширину Всплывающей Подсказки (в пикселах).

§Ширина изображения (%)— задает ширину изображения как процент от ширины всплывающей подсказки.

§Расположение изображения— задает способ выравнивания изображения относительно текста всплывающей подсказки.

Текст, Файл изображения и Ширина подсказки для разных Ссылок могут быть разными, поэтому их нужно задавать для каждой ссылки. Внешний вид Всплывающей Подсказки настраивается для всего Проекта и определяется в окне Стили и модели | Тексты ( Этап 4 - Расширенные настройки).


Окно Название эффекта

Этап 3 - Создание Страниц > Общие характеристики >

Окно Название эффекта

 Return to chapter overview
Покажите/скройте невидемый текст

В этом окне можно задать вводные эффекты для Изображений в Объекте «Слайд-шоу», вставленном посредством окна Редактировать шаблон, а также для изображений, выбранных в Объект в галерее и изображений в каталоге товаров слайд-шоу (см. Объект список товаров).

Доступные настройки разбиты на следующие разделы: Тип эффекта, Масштаб и положение и Страница.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Тип эффекта

В этом разделе можно выбрать вводный эффект и применить его к текущим Изображениям:

§Список эффектов— список доступных эффектов. Если выбрать пункт "1 - Случайный", то выбранный эффект будет в случайном порядке применяться к изображениям в Слайд-шоу. После выбора эффекта для Слайд-шоу он показывается в окошке предварительного просмотра.

§Время отображения— для каждого изображения можно задать длительность показа (в секундах).
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Масштаб и положение

В этом разделе для текущего Изображения можно задать масштабирование и перемещение.

§Начальное положение— введите масштаб (в процентах) и координаты X и Y начального положения Изображения (до начала перемещения).

§Конечное положение— введите масштаб (в процентах) и координаты X и Y конечного положения Изображения (после окончания перемещения).

В обоих случаях для задания начального и конечного положений Изображения можно не вводить соответствующие числовые координаты, а просто перетащить Изображение внутри рамки с начальной позиции на конечную.

К одному и тому же Изображению можно применить и вводный эффект, и эффект масштабирования и перемещения. Сначала применяется вводный эффект — Изображение показывается согласно координатам начального положения. Затем Изображение перемещается (если задано, с изменением размеров) до достижения координат и размеров, указанных для конечного положения.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Страница

Этот раздел доступен только для изображений из слайд-шоу, которые добавлены к верхней или нижней части страницы (см. Редактировать шаблон).

Карта сайта открыта: добавьте к желаемым страницам изображения. С помощью этой возможности можно отображать различные части слайд-шоу для «шапки» или «подвала» различных страниц вашего сайта.

Возможность задания страницы для показа определенного изображения в Слайд-шоу можно использовать, например, для вставки рекламных сообщений. В Слайд-шоу можно настроить все баннеры для использования на Сайте; это позволяет показывать только нужные сообщения на определенных страницах или в определенных разделах Сайта.


Окно Выгрузить связанный файл

Этап 3 - Создание Страниц > Общие характеристики >

Окно Выгрузить связанный файл

Return to chapter overview

Это окно открывается по нажатию кнопки Добавить... на списке файлов, связанных с Flash-анимацией (см. Объект Flash-анимации | Эксперт) или с HTML-кодом (см. Объект HTML и виджеты | Эксперт).

Доступны следующие команды:

§Связанный файл для выгрузки на сервер: можно выбрать файл для импорта, поскольку он связан с объектом, над которым вы работаете.

§Относительный путь к серверу: введите полный путь папки, куда должен импортироваться файл (связанный с объектом).

§Связать файл со страницей (только для файлов .js и .ccs): если импортированный файл представляет собой JavaScript (формат JS) или Таблицу Стилей (формат CSS), для обеспечения его работоспособности он должен быть связан с соответствующей Страницей. Если включить эту опцию, то в раздел <HEAD> HTML-кода Страницы будет автоматически добавлен необходимый код.


Расширенные настройки

Этап 4 - Расширенные настройки >

Расширенные настройки

 Return to chapter overview

Создав Карту Сайта на Этапе 2 и разные Страницы с их содержимым на Этапе 3, вы сможете перейти на Этап 4, где займетесь выбором более сложного функционала, чтобы доработать свой сайт до совершенства. При создании Сайта можно придерживаться определенного стиля, оформив соответствующим образом Меню и текст. Также можно воспользоваться множеством полезных функций, таких как Корзина, Блог и Пользовательский Раздел.

Можно использовать следующие продвинутые функции:

Главное меню

В этом разделе можно разработать стиль Главного Меню, которое отображается сверху (если при определении Общих Настроек на Этапе 1 было выбрано Горизонтальное Меню) или сбоку (если было выбрано Вертикальное Меню) каждой страницы Сайта и позволяет посетителям перемещаться по Сайту.

Раскрывающееся меню

Здесь можно настроить вид Выпадающего Меню. Такие меню показываются при наведении курсора мыши на элементы Главного Меню.

Меню страницы

Если были добавлены Меню Страницы, то здесь можно настроить их вид. Меню Страницы показывает список Страниц на текущем Уровне Меню.

Стили и модели

Здесь можно задать стиль, применяемый к разным элементам текста на Страницах, к связанной с Объект в галерее Электронной Витрине, к Всплывающим Подсказкам, которые могут быть связаны со Ссылка , а также к электронным письмам (если используется Объект-форма обратной связи или Корзина.

Страница приветствия

Здесь можно настроить Страницу Приветствия, предназначенную для представления Сайта. Она может содержать звуковую дорожку, а также ссылки на версии Сайта на других языках.

Рекламное сообщение

Здесь можно создать и настроить рекламное сообщение, которое будет показываться в указанном месте либо только на Домашней Странице, либо на всех Страницах Сайта.

Блог

Здесь можно создать и настроить Блог — Интернет-дневник, где можно публиковать новостные сообщения, к которым посетители могут оставлять комментарии.

Лента RSS

Этот раздел предназначен для создания RSS-ленты, позволяющей регулярно распространять новости, и управления ей.

Управление данными

Здесь вы указываете, как должна происходить передача данных в различных частях сайта, где посетители могут отправлять данные: электронная почта, блог, гостевая книга, Корзина электронного магазина.

Управление доступом

Здесь можно создать Профили пользователей, имеющих доступ к Закрытым Страницам Сайта, а также организовать пользователей в Группы. Закрытые Страницы (определенные как таковые на Этапе 2 при настройке Создание карты сайта— это Страницы Сайта, из которых состоит Пользовательский Раздел; для доступа к ним требуется логин и пароль. Наличие доступа к определенным Закрытым Страницам Пользовательского Раздела зависит от уровня полномочий пользователя.

Корзина

Этот раздел предназначен для создания интернет-магазина и управления им. Здесь составляется Список Товаров, указываются способы доставки и оплаты, задается компоновка формы заказа и др.

Для получения дополнительной информации о создании Карты Сайта, элементах первого и второго уровня, Выпадающих Меню и Меню Страницы см. раздел Создание карты сайта.


Стиль главного меню

Этап 4 - Расширенные настройки >

Стиль главного меню

 Return to chapter overview
Покажите/скройте невидемый текст

В этом окне можно настроить стиль Кнопок Главного Меню.

Меню создаются и обновляются программой автоматически по мере рзработки карты сайта на этапе 2 — Создание карты сайта. Главное меню отображает первый уровень элементов карты сайта, которые используются для навигационного меню. Если вы выбрали горизонтальное меню, главное меню появляется на каждой странице вплотную к заголовку сайта - выше или ниже его. Если вы выбрали вертикальное меню, главное меню показывается внизу страниц либо слева или справа от содержимого страницы.

Доступные команды для настройки кнопок меню организованы в следующие разделы: Общие настройки, Пункты меню и 3D-стиль.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Общие настройки

Можно использовать эти команды для задания некотрых общих настроек главного меню.

Опции в разделе Стиль:

§Ширина— можно задать в пикселах ширину кнопок для пунктов меню.

§Поля— можно задать отступы по горизонтали и по вертикали в пикселах (промежутки между границей кнопки и текстом внутри нее).

§Расстояние между кнопками— можно задать расстояние между соседними Кнопками.

§Разрешить автопрокрутку— выбирайте эту возможность, если хотите, чтобы навигационное меню перемещалось при прокрутке страницы, чтобы оставаться всегда на виду.

При задании ширины кнопок учтите общее пространство, необходимое меню: этот параметр можно изменить, если вы не используете шаблон по умолчанию (см. Настроить шаблон).

Опции в разделе Текст:

§Шрифт— задает шрифт, стиль и размер для текста.

§Выравнивание— можно задать выравнивание текста на поверхности кнопки: по левому краю, по центру или по правому краю.

§Использование сглаживания при отображении текста— выберите эту опцию, чтобы сглаживать края символов.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Пункты меню

Можно использовать команды этого раздела, чтобы задать цвета, фоновые изображения и стили текстов для различных состояний кнопок главного меню.

Сначала выберите нужный Пункт меню с которым вы хотите работать: можно задать стиль [image] Пункт меню и [image] Элемент при наведении мыши/текущая страница. Можно выбрать элемент меню из раскрывающегося меню или можно работать непосредственно с предварительным просмотром, который постоянно обновляется при внесении вами изменений.

Параметры в разделе Стиль доступны для всех элементов меню:

§Цвет фона / Цвет текста / Цвет рамки— можно задать цвет фона, текста и границы кнопки.

§Фоновое изображение— можно задать изображение для использования в качестве фона кнопки. Нажмите на [image] чтобы просмотреть подходящие файлы (в формате .JPG, .GIF или .PNG) и выбрать изображение. Или нажмите на стрелку рядом с полем, чтобы открыть библиотеку кнопок и выбрать понравившееся вам изображение оттуда.

§Стиль шрифта— для Пункт меню можно задать стиль текста на Кнопке: Нет, Углубленный, Приподнятый или Отбрасывание тени. Элемент Элемент при наведении мыши/текущая страница автоматически принимает настройку, заданную для элемента Пункт меню : можно добавить один или несколько стилей: Обычный, Полужирный, Курсив и Полужирный Курсив.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе 3D-стиль

Можно использовать команды этого раздела для создания эффекта объемности (3D) у кнопок.

Здесь доступны следующие возможности в разделе Фигура:

§Фигура: выбирает одну из возможных форм кнопок.

§Радиус закругления: задает насколько сильно должны выделяться уголки кнопок (для закругленных уголков).

§Слияние форм кнопок: объединяет кнопки вместе. В этом случае выбранная форма применяется ко всем этим кнопкам.

Здесь доступны следующие возможности в разделе 3D-формат:

§Пропорции: можно задать внешний вид кнопки из списка плоская, плоская вдавленная, выступающаяи т.д.

§Направление света: можно задать, под каким углом падает свет на кнопку.

§Коэффициент градиента: можно задать интенсивность тени для кнопок.

§Непрозрачность изображения: можно задать степень прозрачности изображений, накладываемых на кнопки, в разделе Пункты меню.

Раздел 3D-рамки со следующими параметрами:

§Стиль рамки: можно задать вид границ кнопки из списка обычные, выпуклые или вогнутые.

§Внешняя ширина / Внутренняя ширина: можно задать внешнюю и внутреннюю толщину границы кнопки.

§Только внешняя рамка: при выборе этой возможности ваши предпочтения по виду границ кнопок будут применяться не к одной кнопке, а ко всем.


Стиль раскрывающегося меню

Этап 4 - Расширенные настройки >

Стиль раскрывающегося меню

 Return to chapter overview
Покажите/скройте невидемый текст

В этом окне можно настроить некоторые продвинутые графические функции Выпадающего Меню.

Меню создаются и обновляются программой автоматически по мере рзработки карты сайта на этапе 2 — Создание карты сайта. Разветывающиеся меню показываются, когда курсор мыши проходит над элементом главного меню.

Команды организованы в следующие разделы: Общие настройки, Пункты меню и 3D-стиль.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Общие настройки

Можно использовать команды этого раздела для задания некоторых общих настроек для раскрывающихся меню.

Сначала выберите Тип меню который вам нужен, это может быть:

Расположить в один столбец— элементы Выпадающего Меню показываются в одной колонке, один за другим.

Расположить в несколько столбцов— элементы Выпадающего Меню показываются в в нескольких смежных колонках. Новая колонка автоматически добавляется, если:

§число элементов меню превышает Максимальное количество объектов в столбце;

§непрерывность списка Страницы прервана Разделителем (см. Создание карты сайта).

Если выбрано Вертикальное Меню в окне Выбор шаблона или Настроить шаблон, то можно также выбрать эту опцию:

Вертикальный 'аккордеон'— все элементы Выпадающего Меню размещаются в одной колонке. При нажатии на элемент все нижерасположенные элементы сдвигаются вниз, чтобы дать место для отображения нового списка элементов (ранее скрытых), относящихся к выбранному элементу.

После определения Тип меню можно задать настройки в окне Стиль:

§Ширина— можно задать в пикселах ширину кнопок для пунктов меню.

§Поля— можно задать отступы по горизонтали и по вертикали в пикселах (промежутки между границей кнопки и текстом внутри нее).

§Максимальное количество объектов в столбце— эта настройка доступна лишь для Типа Меню Расположить в несколько столбцов. Можно задать максимальное количество элементов, отображаемых в каждой колонке Выпадающего Меню.

Опции в разделе Текст:

§Шрифт— задает шрифт, стиль и размер для текста.

§Выравнивание— можно задать выравнивание текста на поверхности кнопки: по левому краю, по центру или по правому краю.

И, наконец, раздел Параметры предоставляет следующий выбор:

§Эффект— для Выпадающего Меню можно задать эффект отображения: Нет, Угасание, Отбрасывать Вверх, Отбрасывать Влево или Отбрасывать Вверх и Влево.

§Автоматический выбор текущей страницы— эти параметры можно использовать только для Вертикальный 'аккордеон' типа меню. Развертывающееся меню автоматически разворачивается и вы можете выбрать в нем нужную страницу.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Пункты меню

Можно использовать команды этого раздела, чтобы задать цвета, фоновые изображения и стили текстов для различных состояний кнопок развертывающихся меню.

Сначала выберите нужный Пункт меню. Можно настроить внешний вид [image] Пункт меню, [image] Элемент при наведении курсора мыши и [image] Разделитель. Можно выбрать элемент меню из раскрывающегося меню или можно работать непосредственно с предварительным просмотром, который постоянно обновляется при внесении вами изменений.

Параметры в разделе Стиль доступны для всех элементов меню:

§Цвет фона / Цвет текста / Цвет рамки— можно задать цвет фона, текста и границы кнопки. Из элементов только Разделитель имеет параметр Цвет текста .

§Стиль шрифта— можно задать стиль текста для элементов Элемент при наведении курсора мыши и Разделитель, например: Обычный, Полужирный, Курсив и Полужирный Курсив.

§Фоновое изображение— эти параметры можно использовать только для элементов Пункт меню и Элемент при наведении курсора мыши и можно задать изображение для использования в качестве фона кнопки. Нажмите на [image] чтобы просмотреть подходящие файлы (в формате .JPG, .GIF или .PNG) и выбрать изображение. Или нажмите на стрелку рядом с полем, чтобы открыть библиотеку кнопок и выбрать понравившееся вам изображение оттуда.

§Иконка Буллета— можно задать изображение для использования в качестве маркеров для списков кнопок и для разделителей. Нажмите кнопку [image] и выберите нужное изображение (формата JPG, GIF или PNG).
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе 3D-стиль

Можно использовать команды этого раздела для создания эффекта объемности (3D) у кнопок.

Здесь доступны следующие возможности в разделе Фигура:

§Фигура: выбирает одну из возможных форм кнопок.

§Радиус закругления: задает насколько сильно должны выделяться уголки кнопок (для закругленных уголков).

§Слияние форм кнопок: объединяет кнопки вместе. В этом случае выбранная форма применяется ко всем этим кнопкам.

Здесь доступны следующие возможности в разделе 3D-формат:

§Пропорции: можно задать внешний вид кнопки из списка плоская, плоская вдавленная, выступающаяи т.д.

§Направление света: можно задать, под каким углом падает свет на кнопку.

§Коэффициент градиента: можно задать интенсивность тени для кнопок.

§Непрозрачность изображения: можно задать степень прозрачности изображений, накладываемых на кнопки, в разделе Пункты меню.

Раздел 3D-рамки со следующими параметрами:

§Стиль рамки: можно задать вид границ кнопки из списка обычные, выпуклые или вогнутые.

§Внешняя ширина / Внутренняя ширина: можно задать внешнюю и внутреннюю толщину границы кнопки.

§Только внешняя рамка: при выборе этой возможности ваши предпочтения по виду границ кнопок будут применяться не к одной кнопке, а ко всем.


Стиль меню страницы

Этап 4 - Расширенные настройки >

Стиль меню страницы

 Return to chapter overview
Покажите/скройте невидемый текст

В этом окне можно настроить некоторые продвинутые настройки Кнопок меню Страницы.

Меню создаются и обновляются программой автоматически по мере рзработки карты сайта на этапе 2 — Создание карты сайта. Меню Страницы (использовать их необязательно) показывают список Страниц, доступных на текущем Уровне Главного Меню. Если посетитель откроет Страницу, которая относится к этому Уровню, содержащему и другие Страницы, то в Меню Страницы будут перечислены все Страницы этого Уровня. Меню Страницы всегда вертикальное и показывается справа или слева от содержимого Страницы.

Доступные команды для настройки кнопок меню организованы в следующие разделы: Общие настройки и Пункты меню.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Общие настройки

Можно использовать команды этого раздела для задания некоторых общих настроек для меню страницы.

Для отображения Меню Страницы, где показываются Страницы текущего Уровня, сначала нужно включить опцию Показать меню страницы.

После этого можно задать настройки в окне Стиль:

§Положение меню— выберите расположение Меню Страницы (слева или справа).

§Ширина— можно задать в пикселах ширину кнопок для пунктов меню.

§Поля— можно задать отступы по горизонтали и по вертикали в пикселах (промежутки между границей кнопки и текстом внутри нее).

§Расстояние между кнопками— можно установить размер внешнего отступа в пикселах (расстояние от одной кнопки до другой).

В разделе Текст :

§Шрифт— задает шрифт, стиль и размер для текста.

§Выравнивание— можно задать выравнивание текста на поверхности кнопки: по левому краю, по центру или по правому краю.

И, наконец, раздел Рамка , можно создать границу вокруг меню страницы (а не отдельных кнопок) и работать со следующими параметрами:

§Толщина рамки: толщина границ (для каждой границы можно задать свою толщину).

§Цвет рамки: цвет границ (и снова, для каждой границы можно задать свой цвет).

§Сглаживание углов: насколько закругленными будут уголки (каждый уголок может иметь свою степень закругленности).

§Тень: тень, определяется цветом, расположением, рассеянием и размером.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Пункты меню

Можно использовать команды этого раздела, чтобы задать стиль элементов меню страницы.

Сначала выберите нужный Пункт меню. Можно настроить внешний вид [image] Пункт меню, [image] Элемент при наведении мыши/текущая страница, [image] Разделитель и [image] Линия-разделитель. Можно выбрать элемент меню из раскрывающегося меню или можно работать непосредственно с предварительным просмотром, который постоянно обновляется при внесении вами изменений.

§Цвет фона / Цвет текста / Цвет линии— можно задать цвет фона и текста Пункт меню, Элемент при наведении мыши/текущая страница и Разделитель, и цвет границы для Линия-разделитель.

§Иконка Буллета— для Пункт меню, Элемент при наведении мыши/текущая страница и Разделитель можно импортировать изображение (формата JPG, GIF или PNG), которое будет отображаться слева от кнопок Элементов Меню Страницы, так что это меню будет оформлено как маркированный список.

§Стиль шрифта— этот параметр для Элемент при наведении мыши/текущая страница и Разделитель и можно определить текст как Обычный, Жирный, Наклонный или Жирный наклонный.

§Стиль линии— эта настройку можно использовать лишь для Линия-разделитель. Доступны следующие варианты: Сплошная, Штриховая, Пунктирная, Углубленная или Приподнятая.


Стили и модели

Этап 4 - Расширенные настройки >

Стили и модели

 Return to chapter overview
Покажите/скройте невидемый текст

В этом окне можно задать стиль, применяемый к разным элементам текста на Страницах, к Электронной Витрине, связанной с Объект в галерее и Объект список товаров, к Всплывающим Подсказкам, которые могут быть связаны со Ссылка, а также к электронным письмам (если используется Объект-форма обратной связи или Корзина.

Под Стилем здесь понимается ряд параметров форматирования текста и графики, применяемых к элементу для изменения его внешнего вида. Используя Стили и Модели, можно за одну операцию применить несколько разных форматов.

Эти опции разбиты на следующие разделы: Тексты, ShowBox, Подсказка и E-mail.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Тексты

Команды в этом разделе можо использовать для задания стиля различных текстов, появляющихся на сайте.

Выберите Элемент страницы, для которого нужно задать Стиль. Либо в Выпадающем Меню, либо путем нажатия на этот элемент в окошке предварительного просмотра.

Различные элементы Страницы, для которых можно задать Стили:

Заголовок страницы: этот параметр задает название каждой Страницы Сайта. Текст берет начало из названия, данного странице при создании карты сайта в окне Создание карты сайта, или, наоборот - заданном Расширенный Заголовок в окне Свойства страницы.

Путь к странице: этот текст появляется непосредственно под Названием Страницы и показывает путь, пройденный для достижения этой Страницы Сайта (breadcrumbs, букв. «хлебные крошки»). Этот путь автоматически генерируется Программой.

Текст страницы: этот текст отдельных абзацев, вставленный при помощи Текстовый объект. По умолчанию заданный здесь стиль применяется к тексту, введенному при помощи редактора Текстовый объект Стиль, используемый по умолчанию, можно изменить в редакторе. Стиль Текста Страницы, используемый по умолчанию, также применяется к тексту, автоматически добавляемому Программой (например, на Страницах в Пользовательском Разделе, Блоге и Поисковой Системе, а также на Карте Сайта).

Активная ссылка / Ссылка, реагирующая на курсор мыши / Посещенная ссылка— эти параметры относятся к гипертекстовым ссылкам, созданным при помощи Текстовый объект. Внешний вид ссылки может изменяться в зависимости от ее состояния: активная, при наведении курсора мыши, посещенная. Изменение внешнего вида ссылки в зависимости от ее текущего состояния помогает посетителю перемещаться по Сайту, напоминая о том, где он уже побывал.

Поле / Кнопка— это поля ввода и кнопки, созданные с помощью Объект-форма обратной связи или Корзины, а также являющиеся элементами полей поиска (см. Редактировать шаблон | Вставить поле поиска), поля для ввода реквизитов доступа для пользовательского раздела и т.д. При создании новой формы Объект-форма обратной связи поля формы принимают стиль, заданный по умолчанию. Можно последовательно настроить стиль в новой форме обратной связи, используя параметры раздела Объект-форма обратной связи | Стиль.

Меню в 'подвале' страницы— в этом меню, отображаемом внизу каждой Страницы, повторяются элементы Главного Меню.

Для задания Стиля выбранных Элемент страницы, можно задать настройки в разделе Стиль чтобы сменить стиль:

§Видимость— можно задать видимость выбранного Элемента Страницы. Эту опцию нельзя использовать для Текст страницы или различные состояния ссылок, полей и кнопок, которые могут быть не видны. Даже если сделать Элемент невидимым, он всё равно останется в коде Страницы. Здесь видимость — чисто условное понятие, означающее, что данный элемент не будет отображаться при размещении страницы в Интернете. Например, можно сделать невидимым Заголовок страницы для того, чтобы использовать вместо текста изображение. Однако тег <title> как был, так и останется в HTML-коде.

§Цвет фона / Цвет текста— можно задать цвета фона и текста для выбранного элемента страницы. Для Текст страницы цвет фона задать нельзя, поскольку он определяется выбранным шаблоном (см. Выбор шаблона или Настроить шаблон) или Стиль ячейки , откуда вставлен Текстовый объект.

§Шрифт— задает шрифт, стиль и размер для текста.

§Выравнивание— можно указать, будет ли Элемент Страницы выровнен Слева, по Центру или Справа. Этот параметр нельзя использовать для полей, кнопок или ссылок, потому что выравнивание гиперссылок задается при создании Текстовый объект независимо от стиля.

§Стиль текста— этот параметр можно использовать только для ссылок в различных состояниях (посещенные и т.д.) и он может принимать значения Обычная или Подчеркнутая.

§Курсор— эта опция доступна лишь для Активная ссылка и автоматически наследуется двумя другими Ссылками. Можно задать внешний вид курсора мыши при наведении на ссылку. Нажмите кнопку [image] для выбора файла формата CUR или ICO.

§Цвет рамки— можно задать цвета различных границ элемента, которые Заголовок страницы, Путь к странице, Поле, Кнопка и Меню в 'подвале' страницы могут иметь.

§Закругленные уголки— можно указать, насколько закруглены уголки у Поле и Кнопка, можно задать значение отдельно для каждого уголка.

§Тень— можно применить тень внутри Поле, тень определяется цветом, расположением, рассеянием и размером.

§Горизонтальное поле— можно задать горизонтальный отступ для Заголовок страницы, Путь к странице и Меню в 'подвале' страницы.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе ShowBox

Можно использовать команды этого раздела, чтобы задать внешний вид ShowBox, который используется в галереях (см. Объект в галерее), в Галерея ShowBox (см. Ссылка | Действие) и в Объект список товаров. Во всех случаях открывается Электронная Витрина, где показывается увеличенное Изображение, Видеозапись или Cлайд-шоу. Когда посетитель нажимает на ссылку, окно Браузера тускнеет, чтобы стала более заметной Электронная витрина, появляющаяся в Браузере в соответствии с заданным вводным эффектом.

Параметры в разделе Стиль:

§Эффект перехода— можно указать, как именно Электронная Витрина должна появляться в окне Браузера. Доступные эффекты: Нет, Исчезновение, Наехать сверху, Масштабирование, Увеличить и скрыть стартовую картинку. Эффекты Масштабирование и Увеличить и скрыть стартовую картинку очень похожи: разница между ними лишь в том, что при увеличении изображения в одном случае исходное изображение видно, а в другом - нет. Эффект Увеличить и скрыть стартовую картинку , таким образом, в частности, подходит для отображения ShowBox, а не текста.

§Внешний цвет / Внутренний цвет— можно задать цвет фона в оласти внутри и снаружи от ShowBox. Цвет внешнего фона является полупрозрачным (степень прозрачности определяется параметром Непрозрачность фона), отчего окно Браузера тускнеет.

§Непрозрачность фона— можно задать прозрачность внешнего фона. Чем выше значения, тем меньше видно окно браузера.

Настройки для Текст:

§Цвет текста— можно задать цвет текста в окне ShowBox.

§Шрифт— задает шрифт, стиль и размер для текста.

§Выравнивание— можно указать, как выравнивается текст в окне ShowBox: по левому краю, по центруили по правому краю.

Здесь доступны следующие возможности для Рамка—

§Толщина рамки: толщина границ (для каждой границы можно задать свою толщину).

§Цвет рамки: цвет границ (и снова, для каждой границы можно задать свой цвет).

§Сглаживание углов: насколько закругленными будут уголки (каждый уголок может иметь свою степень закругленности).

§Тень: тень, определяется цветом, расположением, рассеянием и размером.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Подсказка

Команды в этом разделе используются для того, чтобы задать стиль всплывающих подсказок, связанных со ссылками, добавленными к тексту и изображениям, с помощью команды Вставить ссылку Ссылка . Всплывающая Подсказка — это небольшой текст, показываемый внутри «пузырька», появляющегося при наведении курсора мыши на Ссылку. Этот текст поясняет, что произойдет при нажатии на Ссылку.

Можно начать настройку всплывающей подсказки с параметров в разделе Стиль:

§Положение подсказки— можно указать, где должна показываться Всплывающая Подсказка, а именно Слева, Справа, Сверху или Снизу от Ссылки.

§Эффект перехода— можно задать эффект, применяемый при появлении Всплывающей Подсказки: Нет, Исчезновение или Жалюзи.

§Цвет фона— можно задать цвет фона всплывающей подсказки.

§Непрозрачность фона— можно задать прозрачность внешнего фона. Чем выше значения, тем меньше видно окно браузера.

§Замостить— к «пузырьку» Всплывающей Подсказки можно добавить стрелку, указывающую на Ссылку, к которой относится эта подсказка.

Настройки для Текст :

§Цвет текста— можно задать цвет текста всплывающей подсказки.

§Шрифт— задает шрифт, стиль и размер для текста.

§Выравнивание— можно указать, будет ли текст в Всплывающей Подсказке выровнен Слева, по Центру, или Справа.

Настройки для Рамка :

§Толщина рамки: толщина границ (для каждой границы можно задать свою толщину).

§Цвет рамки: цвет границ (и снова, для каждой границы можно задать свой цвет).

§Сглаживание углов: насколько закругленными будут уголки (каждый уголок может иметь свою степень закругленности).

§Тень: тень, определяется цветом, расположением, рассеянием и размером.

Настройки Стиля применяются ко всему Проекту, поэтому все Всплывающие Подсказки будут выглядеть одинаково. Содержимое Всплывающей Подсказки (текст и изображение) задается в разделе Ссылка | Описание .
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе E-mail

Команды в этом разделе можо использовать для задания стиля электронных писем, созданных в Объект-форма обратной связи или Корзина.

Выберите Элемент E-mail , для которого нужно задать Стиль, либо в Выпадающем Меню, либо путем нажатия на этот элемент в окошке предварительного просмотра.

Элементы Электронного письма, для которых можно задать Стили:

Макет E-mail— все электронные письма, создаваемые Программой, имеют одинаковую компоновку. Электронное письмо состоит из двух частей: центральной, где содержится сообщение, и окружающей его фоновой части. Можно добавить кромку вокруг внутренней части, чтобы визуально отделить сообщение от внешней области.

Изображение логотипа компании— в верхний колонтитул электронного письма можно добавить Изображение. Это может быть логотип фирмы, баннер и др.

Содержание сообщения— это центральная часть электронного письма, содержащая собственно сообщение

Текст 'подвала' страницы письма— это текст, завершающий электронное письмо. Обычно это стандартное сообщение, внешне отличающееся от основного сообщения тем, что для него используется меньший размер (а иногда также другой цвет) шрифта.

Настройки для каждого Элемент E-mail представлены в разделе Стиль:

Макет E-mail

§Цвет фона— можно задать цвет фона для электронного письма.

§Цвет рамки / Толщина рамки— можно задать цвет и толщину кромки (если она используется), отделяющей область сообщения от внешней области.

Изображение логотипа компании

§Файл изображения— можно выбрать Изображение для вставки в верхний колонтитул электронного письма. Нажмите кнопку [image] и выберите нужное изображение (формата JPG, GIF или PNG).

§Выравнивание— можно указать, будет ли Изображение выровнено Слева, по Центру или Справа.

§Положение— можно указать, будет ли Изображение вставлено Внутри рамки или Снаружи рамки центральной области сообщения электронного письма.

§Ширина— автоматически показывается ширина исходного Изображения; при необходимости ее можно изменить. Максимальная ширина Изображения составляет 700 пикселов. Ширина зависит от компоновки электронного письма.

Содержание сообщения

§Цвет фона— можно задать цвет фона для текста письма.

§Цвет текста— можно задать цвет текста для письма..

§Шрифт— задает шрифт, стиль и размер для текста.

Текст 'подвала' страницы письма

§Цвет фона— можно задать цвет фона для текста в нижнем колонтитуле.

§Цвет текста— можно задать цвет текста в нижнем колонтитуле.

§Шрифт— задает шрифт, стиль и размер для текста.

§Выравнивание— укажите, будет ли нижний колонтитул выровнен Слева, по Центру или Справаэлектронного письма.

§Положение— укажите, будет ли нижний колонтитул вставлен Внутри рамки или Снаружи рамки центральной области сообщения электронного письма.

§Текст— можете ввести текст нижнего колонтитула. По умолчанию используется предупреждение о конфиденциальности сообщения.


Страница приветствия

Этап 4 - Расширенные настройки >

Страница приветствия

 Return to chapter overview
Покажите/скройте невидемый текст

В этом окне можно создать Страницу Приветствия Сайта и настроить ее так, чтобы посетители могли выбрать версию Сайта на подходящем языке.

Как можно понять из названия, посетители обычно сначала попадают на Страницу Приветствия. На этой Странице может быть размещено Изображение, Flash-анимация или Видеозапись, и она обычно показывается в течение определенного промежутка времени, после чего открывается Домашняя Страница. Посетитель обычно может нажать на соответствующую кнопку (например, «Пропустить введение»), чтобы сразу перейти к Домашней Странице. Если есть несколько версий Сайта на разных языках, на Странице Приветствия можно выбрать нужный язык.

Кликните, чтобы развернуть/уменьшить Справка: Команды для настройки страницы приветствия

Не каждый сайт имеет Страницу Приветствия. Чтобы добавить Страницу Приветствия, включите опцию Показывать страницу приветствия. Помните, что если у вас есть страница приветствия, то она всегда отображается первой.

Для Страницы Приветствия можно задать Фон и Содержимое, а также добавить Звуковую дорожку.

Настройки в разделе Контент страницы:

§Тип контента— можно задать тип содержимого, которое будет добавлено на Страницу Приветствия. Доступные варианты: Изображение, Flash-анимация, Видеозапись и HTML-код.

§Файл— если в качестве Типа содержимого выбрать Изображение, Flash-анимация или Видеозапись для Тип контента, тогда можно импортировать графический файл (формата JPG, GIF или PNG), файл Flash-анимации (формата SWF) или видеофайл (формата FLV или MP4).

§HTML-код— если в качестве Типа содержимого выбрать HTML-код для Тип контента, код вводится здесь. Панель инструментов содержит следующие инструменты:

Вырезать [CTRL+X] - Копировать [CTRL+C] - Вставить [CTRL+V]

Эти команды вырезают, копируют и вставляют выделенный текст.

Отменить [CTRL+Z] - Восстановить [ALT+CAPS+BACKSPACE]

Эти команды отменяют или заново выполняют последнюю проведенную операцию.

Добавить виджеты

Эта опция вствляет код выбранного виджет: нажмите на стрелку рядом с кнопкой, чтобы развернуть полный список доступных виджетов в том виде, как он показывается в Объект HTML и виджеты. Нажмите на нужный виджет, чтобы открыть окно нас троек виджета, где можно задать необходимые параметры. После подтверждения виджет наполняется HTML-кодом и автоматически добавляется в редактор.

§Размеры— можно задать ширину и высоту добавленного Изображения, Flash-анимации, Видеозаписи или HTML-кода (в пикселах). Оставьте Сохранять пропорции выбранным, если хотите сохранить соотношение высоты и ширины (форм-фактор).

Доступны следующие параметры для Фон страницы—

§Цвет фона— можно задать цвет фона приветственной страницы.

§Файл изображения— указывает на файл изображения (в форматах .JPG, .GIF или .PNG), используемого в качестве фона.

§Положение изображения— указывает, должно ли повторяться фоновое изображение. Изображение может повторяться по горизонтали, по вертикали или сразу в обоих направлениях, чтобы занять все отведенное пространство. Фоновое изображение должно быть специально откадрировано так, чтобы можно было заполнять им пространство.

§Выравнивание— можно задать выравнивание Изображения в окне Браузера.

Эти возможности Параметры также можно использовать:

§Звук в качестве приветствия— можно указать аудиофайл (формата MP3) для воспроизведения во время показа Страницы Приветствия.

§Переход на главную страницу через [сек]— если включить эту опцию, то спустя указанное время показа Страницы Приветствия произойдет автоматический переход к Домашней Странице.
Кликните, чтобы развернуть/уменьшить Справка: Команды для выбора языка

Если есть несколько версий Сайта на разных языках и посетителю нужно дать возможность выбрать нужный язык при помощи Кнопок на Странице Приветствия, сначала нужно включить опцию Показывать ссылки на другие языки.

В разделе Список языков нужно составить список языков, на которых представлен Сайт. По умолчанию в этот Список включены пять языков, которые можно изменить при помощи следующих команд:

§Добавить... / Удалить— можно добавить в список новый язык (в окне Языковые настройки) или удалить оттуда существующий язык.

§Сдвинуть Вверх / Сдвинуть Вниз — можно изменить порядок языков в Списке, поместив выбранный язык до предыдущего или после следующего.

§По умолчанию— один из языков в Список языков можно сделать языком, используемым по умолчанию. Язык по умолчанию — это тот язык, на котором первоначально отображается Сайт (до того, как посетитель выберет нужный язык). Страница приветствия появляется на сайте только на языке по умолчанию (для получения дополнительной информации см. Как создать многоязычный сайт).

§Редактировать...— в окне Языковые настройки можно изменить настройки выбранного языка в Список языков.

Этот параметр тоже доступен:

§Esegui collegamento in una nuova finestra— при выборе этого варианта, сайт открывается в новом окне браузера, а не в том же, где показана страница приветствия.

Хотя мы уже обсудили в основном выбор языка на странице приветствия, есть и другой функционал, который можно сюда включить. Можно, например, предложить выбор версии HTML или Flash, или доступен ли контент всем или только для взрослых.

Если вы создаете страницу приветствия, то особая страница «Страница приветствия» автоматически добавляется и на карту сайта. Выберите ее и откройте окно Свойства страницы, чтобы задать главные параметры.

Лучшая практика:

- | Как автоматически переводить текст
- | Как создать многоязычный сайт


Окно Языковые настройки

Языковые настройки

Этап 4 - Расширенные настройки > Страница приветствия >

Языковые настройки

 Return to chapter overview

Это окно открывается по нажатию кнопок Добавить... или Редактировать... в окне Страница приветствия. Можно задать различные параметры языков, доступных на вашем сайте.

Можно выбрать один из этих вариантов:

§Отображение названия языка: можно ввести название языка, котрый вы хотите предоставить на сайте. Нажмите на стрелку рядом с полем, чтобы открыть всплывающее меню со списком языков и выбрать тот, что вы хотите добавить. Можно просто набрать название языка в этом поле.

§Изображение для этого языка (напр. флаг): можно задать имя графического файла, из которого будет создана кнопка для данного языка. Нажмите на [image] и выберите нужное изображение (формата JPG, GIF или PNG) для создания кнопки с изображением, например, флага, представляющего язык.

Если вы не укажете никакого изображения для кнопки, автоматически будет создана текстовая ссылка с Отображение названия языка в качестве текста.

§Ссылка для данного языка (например, показать сайт на этом языке): можно создать ссылку на изображение, ипортированное с помощью пункта Изображение для этого языка (напр. флаг). Нажмите на [image] кнопку, чтобы открыть окно Ссылка , где можно выбрать действие и относящиеся к нему параметры.

Если, например, сайт на обозначенном флагом языке уже опубликован в Интернет, можно выбрать пункт Файл или URL и ввести URL-адрес (адрес сайта) со ссылкой на него (например, http://www.mywebsite.ru/en/index.html). Если вы работаете над языком по умолчанию, то этот параметр использовать нельзя, поскольку он автоматически строит ссылку на главную страницу.

Замечания о совместимости с предыдущими версиями:

Окно Языковые настройки в 10 версии изменилось следующим образом:

§Путь к серверу или URL сайта для данного языка - пункт теперь перенесен на пункт Ссылка для данного языка (например, показать сайт на этом языке). Ссылку по-прежнему можно настроить на файл иои URL, но теперь нужно также задать и другие указатели.

§Пункт «Показать этот язык, но сообщить, что он пока недоступен» был перенесен, поскольку теперь можно создать свое сообщение, настроив более подходящую ссылку на кнопку с флагом.

Лучшая практика:

- | Как автоматически переводить текст
- | Как создать многоязычный сайт


Рекламное сообщение

Этап 4 - Расширенные настройки >

Рекламное сообщение

 Return to chapter overview
Покажите/скройте невидемый текст

В этом окне можно добавить Рекламное Сообщение на Домашнюю Страницу или на все страницы Сайта.

Рекламное Сообщение может быть Изображением или Flash-анимацией, показываемой в определенном месте Страницы и снабженной ссылкой на Целевую Страницу. Целевая Страница — это обычная страница Сайта. От других страниц она отличается тем, что содержит определенное сообщение для пользователя, побуждающее его заполнить какую-то форму, совершить покупку и др.

Кликните, чтобы развернуть/уменьшить Справка: Команды для подключения рекламы

Чтобы добавить Рекламное Сообщение, сначала включите опцию Отображать рекламное сообщение.

Для выбора Тип сообщения можно использовать следующие опции:

Отображать рекламу в правом верхнем углу: если навести курсор мыши на правый верхний угол Страницы, то этот угол отогнется, приоткрывая Рекламу, находящуюся за Страницей.

Отображать рекламу в рамке: Реклама будет показываться в окошке, расположенном в центре окна Браузера, поверх содержимого Страницы.

Отображать рекламу в горизонтальной полосе: Реклама будет показываться в горизонтальном баннере в окне Браузера. Этот баннер может располагаться либо в верхней части окна, выше собственно содержимого Страницы, либо в нижней части окна, поверх содержимого Страницы.

Раздел Настройки позволяет задать следующие опции для каждого Тип сообщения:

§Файл изображения: можно указать графический файл (формата JPG, GIF или PNG) или файл Flash-анимации (формата SWF), содержащий нужную Рекламу.

Если включить опцию Отображать рекламу в правом верхнем углу то можно задать следующие настройки:

§Стиль: можно выбрать классический эффект «Загнутый Уголок» для верхнего правого угла страницы или какие-то другие эффекты. Остальные эффекты действуют точно так же: при наведении курсора мыши показывается Реклама.

§Ширина/высота: можно задать ширину и высоту области, занятой Рекламой (в пикселах).

Если включить опцию Отображать рекламу в рамке в окошке, то можно задать следующие настройки:

§Положение: можно указать, где в окне Браузера должна располагаться Реклама. Возможны следующие варианты: В Центре, Слева Вверху, Справа Вверху, Слева Внизу и Справа Внизу..

§Эффект: эта опция задает эффект, применяемый при появлении Рекламы. Возможны следующие варианты: Исчезновение, Стереть снизу, Стереть сверху, Стереть справа или Стереть слева.

§Показать это сообщение только один раз: при выборе этой опции реклама показывается только один раз при открытии страницы (а в следующий раз при посещении сайта рекламу покажут еще раз).

Если включить опцию Отображать рекламу в горизонтальной полосе то можно задать следующие настройки:

§Положение: можно указать место показа Рекламной полосы, а именно: верхняя часть окна Браузера, выше собственно содержимого Страницы, либо нижняя часть окна, поверх содержимого Страницы.

§Цвет фона: в открывшемся окне Цвет можно задать цвет фона Рекламной полосы.

§Показать это сообщение только один раз: при выборе этой опции реклама показывается только один раз при открытии страницы (а в следующий раз при посещении сайта рекламу покажут еще раз).

Эти Параметры для всех типов рекламы:

§Ссылка: можно задать Целевую Страницу, связанную ссылкой с Рекламой. Нажмите на [image] кнопку, чтобы открыть окно Ссылка , где можно выбрать действие и относящиеся к нему параметры.

§Звук в качестве приветствия: можно указать аудиофайл (формата MP3) для воспроизведения во время показа Рекламы.

Что такое целевая Страница?

Целевая Страница — это веб-страница, на которую посетитель попадает после нажатия на ссылку или рекламу. Такая страница позволяет посетителю сразу найти нужную информацию, без необходимости искать ее на Сайте.

Приведем следующий пример. Допустим, Вы решили где-то разместить баннер, рекламирующий какой-то товар. Информация на этом баннере служит затравкой, призванной заинтересовать посетителя. Давать ссылку на Домашнюю Страницу Сайта нежелательно, поскольку эта страница обычно содержит сведения общего характера, из-за чего посетителю придется бродить по Сайту в поисках информации о заинтересовавшем его товаре. Так Вы рискуете упустить потенциального покупателя! Поэтому лучше всего создать новую Страницу, простую для восприятия, и разместить на ней все необходимые сведения о том товаре, включая условия покупки.

Для каждого случая, как правило, потребуется создать отдельную Целевую Страницу. Однако усилия, вложенные в создание таких страниц, окупаются сторицей, поскольку Целевые Страницы позволяют посетителю достичь цели (в данном случае — совершить покупку).

В Режим отображения доступны следующие настройки:

§Отображать только на главной странице / Отображать на всех страницах: можно задать показ Рекламы только на Домашней Странице или на всех Страницах Сайта.


Блог

Этап 4 - Расширенные настройки >

Блог

 Return to chapter overview
Покажите/скройте невидемый текст

Здесь представлены все инструменты и параметры для добавления на сайт полноценного блога, где посетители смогут оставлять комментарии к опубликованных сообщениям.

Блог похож на интернет-дневник. Автор блога время от времени пишет сообщения на любые темы и публикует их.

Сразу после публикации блог, созданный в программе WebSite X5, становится отдельной сущностью, связанной с основным сайтом. Он автоматически добавляется в раздел карты сайта «особые страницы» (см. Создание карты сайта). Чтобы добавить пункт «Блог» в меню перемещения по сайту, нужно создать псевдоним для особой страницы, выделив ее и перетащив в папку меню.

Блог имеет такое же оформление и пользовательский интерфейс, как сайт, частью которого он является. Все настройки, заданные в графическом шаблоне сайта, автоматически применяются и к блогу.

Блог публикуется по адресу http://www.mywebsite.ru/blog (где http://www.mywebsite.ru — URL-адрес сайта, с которым связан блог (вашего сайта).

На главной странице блога перечислены все опубликованные сообщения в хронологическом порядке. Для каждого сообщения показывается название, автор, категория, дата и время публикации, анонс и ссылка «читать всё». Если нажать ссылку «Читать всё», то соответствующее сообщение откроется полностью. Под ним показываются все комментарии и есть возможность добавить новые.

Помимо содержания сообщений все страницы блога имеют одинаковую структуру: в правой части страницы есть колонка, где размещаются ссылки на последние сообщения, на архив по месяцам и архив по категориям и облако тегов. Эту колонку можно настроить, определив, какие ссылки будут показываться посетителям и в каком порядке они будут размещены.

Возможность получать комментарии, оставляемые посетителями к сообщениям — это отличный способ вести обсуждения между читателями и авторами. Чтобы в блоге не публиковали оскорбительные, посторонние или неуместные по иным причинам комментарии, программа WebSite X5 предоставляет он-лайн Панель управления, которая помогает перехватывать нежелательные комментарии.

Чтобы создать блог, нужно всего лишь задать несколько общих параметров и создать список новостей для опубликования.

После заведения блога нужно поддерживать интерес посетителей к нему, регулярно публикуя новые сообщения. Чтобы сэкономить время при загрузке проекта в Интернет, можно публиковать только обновления к блогу, выбрав параметр Экспорт только блога и ленты RSS в окне Экспорт сайта в Интернет.

Команды создания блога и сообщений организованы в три раздела: Записи, Макет и Комментарии.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Записи

Можно использовать команды этого раздела для задания общих параметров и для создания списка сообщений для публикации в блоге.

В разделе Общие настройки есть следующие параметры:

§Заголовок: введите в это поле название своего блога. Заголовок отображается в строке заголовка браузера и, обычно является важным элементом, поскольку помогает посетителям и поисковым системам идентифицировать блог.

Если название блога не задано, то по умолчанию будет использовано название сайта (как указано в окне Общие настройки | Основной.

§Описание: введите в это поле краткое описание блога. Выразите мысль кратко и по существу. Введенный текст используется для заполнения мета-тега <description> в HTML-коде, так что поисковые системы смогут искать по нему ваш блог.

Если не ввести описание блога, то по умолчанию будет использовано описание сайта (как указано в окне Общие настройки | Основной.

§Создать ленту RSS, включающую содержимое блога: эта возмжность включена по умолчанию, т.е. RSS-лента со всеми сообщениями блога создается автоматически. Путь для RSS-ленты блога http://www.mywebsite.ru/blog/x5feed.xml, где http://www.mywebsite.ru это URL-адрес сайта, с которым связан блог (вашего сайта).

В разделе Список записей приводится таблица, где отображаются Заголовок, Автор, Категория и Дата публикации всех добавленных сообщений, а также опции составления списка сообщений:

§Добавить...: эта команда открывает окно Настройки записи, где можно добавить новое сообщение.

§Удалить: выбранное сообщение можно удалить из Список записей.

§Редактировать...: эта команда открывает окно Настройки записи, где можно редактировать сообщение, выбранное в Список записей.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Макет

Команды этого раздела определяют внешний вид вашего блога.

В разделе Общие есть следующие параметры:

§Режим просмотра сообщений: можно выбрать способ отображения ваших записей на первой странице блога. Можно показать запись полностью, а следом разместить анонсы других записей, либо можно просто разместить анонсы всех записей. Во всех анонсах есть связанная с ними ссылка «читать далее».

§Показать кнопку 'Добавить', чтобы рассказать о вашем сайте в социальных сетях.: Если выбрать эту возможность, внизу каждого сообщения в блоге будет автоматически показываться кнопка AddThis. Нажав эту кнопку, посетитель может выбрать в раскрывающемся меню свою социальную сеть и добавить на свою страницу ссылку на данное сообщение.

§Тип кнопки: можно выбрать оформление кнопки AddThis из вариантов, представленных в меню.

§Учетная запись сайта AddThis: если используется учетная запись AddThis, то можно ввести название своей учетной записи для получения статистики популярности своего блога у пользователей сервиса AddThis.

Для получения дополнительной информации о сервисе AddThis и о создании учетной записи AddThis нажмите кнопку [image] , чтобы перейти на официальный сайт www.addthis.com.

. Раздел Количество боковых блоков текста содержит таблицу, где указаны Заголовок, тип и Ширина каждого блока в колонке. Для работы с этими блоками можно использовать следующие команды:

§Добавить...: эта команда открывает окно Заголовок бокового блока текста, где можно добавить новый блок.

§Сделать копию: можно скопировать выбранный блок.

§Удалить: выбранный блок можно удалить из списка Раздел Количество боковых блоков текста.

§Сдвинуть вверх / Сдвинуть вниз: в списке Количество боковых блоков текста можно выбрать блок и сдвинуть его вверх или вниз.

§Редактировать...: эта команда открывает окно Заголовок бокового блока текста для редактирования блока, выбранного из списка Количество боковых блоков текста.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Комментарии

Можно использовать команды этого раздела для управления комментариями, оставляемыми посетителями к вашим сообщениям в блоге.

Прежде всего, нужно выбрать параметр Разрешить посетителям вашего блога оставлять комментарии, если хотите позволить посетителям добавлять комментарии к сообщениям, публикуемым в блоге.

Затем можно задать Тип контента, на выбор:

Комментарии и голосование: посетители могут писать комментарии и голосовать на сайте.

Комментарий: посетители могут писать комментарии, но не могут голосовать на сайте.

Оценка: посетители могут голосовать, но не могут писать комментарии.

Возможности в Настройки комментариев следующие:

§Режим просмотра: именно вы определяете, сразу ли будут публиковаться комментарии, которые оставляют посетители или сначала каждый комментарий будет проверяться. Режим задается этой командой на панели управления.

§Порядок просмотра: можно задать вывод публикуемых комментариев в хронологическом порядке или в обратном.

§Показать кнопку 'Нецензурное': выбирайте этот параметр в том случае, если хотите добавить кнопку «Пожаловаться», чтобы посетители могли сообщить о замеченных ими нарушениях.

§Включить антиспам фильтр 'Captcha': снизу в форму можно добавить антиспам-фильтр Captcha («капча»). Он показывает ряд искаженных знаков в случайном порядке, а посетитель должен набрать их правильно, только тогда комментарий отправится на сайт.

§Тип голосования: этот параметр определяет стиль элемента, с помощью которого посетители могут голосовать (например, 5 звездочек). Эта возможность доступна только если вы выбрали Оценка в качестве Тип контента.

Можно указать как будут передаваться данные из формы комментирования, которые затем будет обрабатывать администратор сайта в разделе Метод сохранения данных :

§Подпапка на сервере для сохранения данных: задайте папку на сервере (с доступом на запись для PHP), в которую будут записываться принятые данные. Название главной папки сервера задается параметром Папка на сервере с правами на запись в окне Управление данными . Если вы не зададите подпапку, данные будут сохраняться прямо в корневую папку!

§Отправить по электронной почте уведомление о получении комментариев: по мере поступления новых данных будут автоматически отправляться уведомления по электронной почте.

§Адрес электронной почты пользователя: Нужно задать несколько параметров для каждой возможности отправки:

введите адрес получаетеля электронной почты с уведомлением о получении данных.

Провайдеры обычно предоставляют права доступа на запись ко всем папкам на сервере: если в вашем случае это так, вы не должны показывать путь к папке общего доступа. В любом случае, по поводу папки общего доступа лучше обратиться к провайдеру.

Можно запустить тест в разделе Тест Сайта онлайн панели управления в любом случае, если у вас есть доступ на запись к папке и всем папкам внутри нее, у вас будет к ним доступ (куда можно сохранять данные).

Когда вы создаете блог, автоматически появляется новая страница на карте сайта и так и называется «Блог»: выберите ее и откройте окно Свойства страницы , чтобы задать главные параметры.

Лучшая практика:

-

Как с помощью панели управления сайтом онлайн настроить блог и гостевую книгу

Родственные темы:

-

Панель управления онлайн


Окно Настройки записи

Блог | Настройки записи

Этап 4 - Расширенные настройки > Блог >

Блог | Настройки записи

 Return to chapter overview
Покажите/скройте невидемый текст

Окно Настройки записи , открывающееся при выборе команды Добавить... или Редактировать... команды в окнах Блог | Записи предназначены для создания и редактирования сообщений в блоге.

Это окно разделено на два раздела: Основной и Эксперт.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Основной

Вот команды этого раздела:

§Заголовок: здесь можно задать название сообщения.

§Дата публикации: можно выбрать дату публикации сообщения, пользуясь календарем.

§Автор: введите фамилию и имя автора Сообщения. Их можно либо ввести в соответствующее поле, либо, если автор уже публиковался в этом Блоге, выбрать нужного автора в выпадающем списке.

§Категория: можно указать Категорию, к которой относится новое Сообщение. Как и в случае с Автор, можно либо ввести новую Категорию, либо выбрать существующую.

§Тэги: можно ввести список тегов (кратких описаний ключевых тем, связанных с Сообщением). С каждым Сообщением можно связать несколько тегов, записывая их один за другим и разделяя запятой (например, «тег1, тег2, тег3., ...»).

§Контент: можно писать свои сообщения в том же редакторе, что и один из Текстовый объект.

§Заголовок: можно добавить краткое описание, связанное с Сообщением.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Эксперт

Вот команды этого раздела:

§Ссылка на видео/аудио: можно указать аудиофайл (формата MP3, WMA, WAV, MID, AIF или M4A) или видеофайл (формата MP4, FLV, AVI, WMV, MPG или MOV), который будет связан с Сообщением. Внизу каждого Сообщения автоматически добавляется ссылка на соответствующий аудио- или видеофайл.

Чтобы в Сообщении сразу воспроизводилась видеозапись, при написании Сообщения нужно вручную добавить в текстовом редакторе соответствующий HTML-код.

Например, можно скопировать видеозапись с YouTube и вставить в Сообщение.

§Источники для записи— можно составить список источников, использованных для написания Сообщения, при помощи следующих команд:

-Добавить... / Убрать— — можно либо добавить новый источник, либо удалить существующий.

-Сдвинуть Вверх / Сдвинуть Вниз — в списке источников можно выбрать какой-то источник и переместить его на другое место.

-Редактировать— выбранный источник можно изменить. Либо можно дважды щелкнуть на источнике, чтобы отредактировать его. Для указания источника введите название сайта, а после него — URL-адрес, заключенный в символы < и > (например, WebSite X5<http://www.websitex5.com>). Название будет показано как источник, а URL-адрес будет использован для создания ссылки на источник.

§Не разрешать посетителям оставлять комментарии— — если выбрать эту опцию, посетители не смогут комментировать данное Сообщение.

Лучшая практика:

-

Как с помощью панели управления сайтом онлайн настроить блог и гостевую книгу

Родственные темы:

-

Панель управления сайтом онлайн


Окно Заголовок бокового блока текста

Блог | Заголовок бокового блока текста

Этап 4 - Расширенные настройки > Блог >

Блог | Заголовок бокового блока текста

 Return to chapter overview
Покажите/скройте невидемый текст

Окно Заголовок бокового блока текста открывается из команд Добавить и Редактировать в окне Блог | Макет. Здесь можно задать блоки в правой части любой страницы блога, которые содержат полезные для посетителей инструменты.

Это окно имеет следующие разделы: Общие настройки и Стиль.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Общие настройки

Можно использовать команды этого раздела для создания списка блоков, наполняющих страницу вашего блога.

Есть несколько типов таких блоков на выбор:

Недавние записи: Этот блок отображает все последние сообщения, опубликованные в блоге. Посетитель нажимает на заголовок, чтобы перейти к сообщению.

Категории: Этот блок содержит список категорий, с помощью которых организованы ваши сообщения. Посетитель нажимает на категорию, чтобы перейти к соответствующему списку сообщений.

Записи за месяц: Этот блок содержит список сообщений, опубликованных за каждый месяц.

Облака: Этот блок содержит список категорий или тэгов, связанных с опубликованными сообщениями. Наименования категорий и тэгов написаны шрифтами различных размеров в зависимости от того, сколько сообщений с ними связано: чем крупнее шрифт, тем больше таких сообщений. Посетитель нажимает на категорию или тэг, чтобы увидеть связанный с ними список сообщений.

Друзья: Этот блок отображает список сайтов или блогов, которые, по вашему мнению, могут быть интересны вашим посетителям.

Facebook: В этом блоке используется модуль «Мне нравится» из Facebook. Посетители могут:

§увидеть, скольким людям и/или их друзьям понравилась предлагаемая страница Facebook;

§прочитать сообщения, недавно опубликованные на предлагаемой странице Facebook;

§сообщить, что им нравится предлагаемая страница Facebook, не заходя на нее.

Реклама Google AdSense: Этот блок служит для отображения рекламы в рамках сотрудничества с сервисом AdSense™.

HTML-код: Этот блок сводобен, и вы можете настроить его так, как вам нравится. Можно добавить любую функциональность, которую программа не добавляет автоматически.

Доступные возможности зависят от типа блока. Следующие параметры доступны для всех типов:

§Заголовок: можно задать заголовок блока.

§Ширина: можно задать ширину блока в пикселах.

Следующие параметры специфичные для данного типа блока:

Недавние записи / Категории /

Записи за месяц:

§Максимальное количество элементов:: можно задать максимальное количество элементов, отображаемых в блоке.

Облака:

§Показывать категории в виде облака / Показывать тэги в виде облака: можно задать, будет ли блок Облака показывать категории или тэги для уже опубликованных сообщений.

Друзья:

§Список друзей: с помощью этих команд можно собрать список сайтов близкой тематики:

-Добавить / Убрать: можно либо добавить новый сайт близкой тематики, либо удалить выбранный.

-Сдвинуть Вверх / Сдвинуть Вниз: можно изменять порядок вывода списка, перемещая выбранный элемент вверх или вниз в различные положения.

-Редактировать: выбранный элемент можно изменить. Либо можно дважды щелкнуть на элементе, чтобы отредактировать его.

To enter a friendly website correctly, write the name of the website followed by its URL between the < > characters (for example "WebSite X5 <http://www.websitex5.com>"): the text will be displayed as the friendly website source and the URL will be used to create a link to it.

Facebook:

§Ссылка на Facebook: можно задать URL-адрес продвигаемой страницы Facebook.

§Цвет фона: можно задать для блока темный или светлый фон.

§Высота: можно задать высоту блока в пикселах.

§Показать фото друзей: выбирайте этот вариант, если хотите, чтобы отображались фото из профиля друзей (из их страничек на Facebook).

§Показать последние записи: выбирайте эту возможность для отображения в блоке последних сообщений, опубликованных на стене указанной страницы Facebook.

§Показать визитку из FaceBook: выбирайте эту возможность, если хотите отобразить в блоке заголовок Facebook.

Реклама Google AdSense:

§HTML-код Google AdSense: скопируйте HTML-код из Google AdSense™ для отображения рекламы в этом блоке.

HTML-код:

§HTML-код: напишите или скопируйте HTML-код, чтобы создать свой собственный контент в этом блоке.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Стиль

Можно использовать команды этого раздела, чтобы задать внешний вид блоков на странице вашего блога.

Настройки для Текст:

§Шрифт: задает шрифт, стиль и размер для текста.

§Цвет текста: задает цвет текста.

§Поля:: задает ширину поля в пикселах (промежуток между границей блока и текстом).

Настройки для Фон следующие:

§Цвет фона: указывает цвет для заливки фона.

§Файл изображения: указывает на файл изображения (в форматах .JPG, .GIF или .PNG), используемого в качестве фона.

§Положение: указывает, должно ли повторяться фоновое изображение. Изображение может повторяться по горизонтали, по вертикали или сразу в обоих направлениях, чтобы занять все отведенное пространство. Фоновое изображение должно быть специально откадрировано так, чтобы можно было заполнять им пространство.

§Выравнивание: задает способ выравнивания изображения в блоке.

Настройки для рамки:

§Толщина рамки: толщина границ (для каждой границы можно задать свою толщину).

§Цвет рамки: цвет границ (и снова, для каждой границы можно задать свой цвет).

§Сглаживание углов: насколько закругленными будут уголки (каждый уголок может иметь свою степень закругленности).

§Тень: тень, определяется цветом, расположением, рассеянием и размером.

Лучшая практика:

-

Как с помощью панели управления сайтом онлайн настроить блог и гостевую книгу

Родственные темы:

-

Панель управления сайтом онлайн


Лента RSS

Этап 4 - Расширенные настройки >

Лента RSS

 Return to chapter overview
Покажите/скройте невидемый текст

В этом окне можно создать RSS-ленту — один из самых популярных вещательных форматов в Интернете.

RSS-лента представляет собой очень гибкий инструмент для распространения новостей, изображений и видеозаписей. RSS-ленту можно использовать для регулярной передачи новостей, а также для уведомления о событиях, обновлениях на сайте и новых сообщениях или комментариях в Блоге.

Посетители, подписавшиеся на RSS-ленту сайта, регулярно получают обновления и новости через свой RSS-клиент (пользовательскую программу для чтения RSS-ленты).

Кликните, чтобы развернуть/уменьшить Справка: Команды для создания RSS-ленты

Чтобы создать RSS-ленту, нужно задать несколько общих параметров и создать список новостных статей, о выходе которых будут уведомляться пользователи сайта.

В Список записей в табличном виде представлены все добавленные новостные статьи с Заголовок и Дата опубликования. Для работы со Списком Сообщений можно использовать следующие команды:

§Добавить...: эта команда открывает окно Настройки записи, где можно добавить новую статью.

§Удалить: выбранную статью можно удалить из Список записей.

§Редактировать...: эта команда открывает окно Настройки записи , где можно изменить пункт, выбранный в Список записей.

Помимо создания Списка Сообщений, нужно также задать следующие Общие настройки:

§Заголовок ленты: (обязательный параметр) нужно указать название RSS-ленты, связанной с Сайтом.

§Изображение для ленты: можно указать графический файл (формата JPG, GIF или PNG), связанный с RSS-лентой. Это Изображение (как правило, логотип фирмы или Сайта) будет показываться посетителю в его RSS-клиенте.

§Описание ленты: (обязательный параметр) здесь нужно ввести описание RSS-ленты, связанной с Сайтом.

При тестировании вашего сайта это сообщение появляется для того, чтобы напомнить вам, что RSS-поток отображается только на сайте, который опубликован в Интернет.


Окно Настройки записи

Лента RSS | Настройки записи

Этап 4 - Расширенные настройки > Лента RSS >

Лента RSS | Настройки записи

 Return to chapter overview

Окно Настройки записи открывается командами Добавить... и Редактировать... в окне Лента RSS, где можно создать или отредактировать RSS-ленту сообщений.

§Заголовок: здесь можно задать название сообщения.

§Дата публикации: можно выбрать дату публикации сообщения, пользуясь календарем.

§Контент: можно писать свои сообщения в том же редакторе, что и один из Текстовый объект.

§Связанная страница: можно задать на карте сайта страницу, связанную с сообщением.


Управление данными

Этап 4 - Расширенные настройки >

Управление данными

 Return to chapter overview
Покажите/скройте невидемый текст

В этом окне можно задать способ передачи данных. Данные можно получать из почтовых форм обратной связи, из вашего блога, гостевой книги.

Можно использовать команды в разделе База данных для создания ссылок на базы данных вашего проекта, чтобы упростить управление данными. Все включенные вами базы данных показаны в таблице, где можно задать Описание, Имя базы данных, Имя хоста и Имя пользователя.

Кликните, чтобы развернуть/уменьшить Справка: Команды для создания списка баз данных

Команды для создания списка баз данных, связанных с текущим проектом:

§Добавить...: эта команда открывает окно Настройки базы данных, где можно добавить новую базу данных.

§Удалить: можно удалить выбранную базу данных из списка.

§Редактировать...: эта команда открывает окно Настройки базы данных, где можно редактировать данные в выбранной базе данных. Либо можно дважды щелкнуть на имени базы данных, чтобы отредактировать ее.

Список баз данных, связанных с проектом нужно создать до того, как вы начнете хранить в базах данные, полученные из таких источников: Объект-форма обратной связи.
Кликните, чтобы развернуть/уменьшить Справка: Возможности отправки электронной почты и сохранения данных на сервере

Можно использовать параметры в разделе Отправка почтового сообщения для указания, как именно должны отправляться сообщения электронной почты:

§Скрипт для отправки e-mail: можно задать скрипт для отправки электронной почты через WebSite X5, например, при использовании Объекта «Форма электронного письма» или создании Корзины. По умолчанию используется Стандартный Скрипт; если этот скрипт не работает из-за неподходящих настроек Сервера, попробуйте заменить его и включить опцию Низкоуровневый Скрипт или Скрипт для Низкокачественного Сервера.

§Тип отправки e-mail: можно настроить отправку данных для Объекта «Форма электронного письма». По умолчанию используется метод POST. Поскольку некоторые Серверы не поддерживают этот метод, также можно использовать метод GET.

Протокол HTTP — наиболее широко используемый метод обмена информацией в Интернете. Этот протокол основан на механизме запроса и ответа: Клиент производит запрос, а Сервер возвращает ответ. Как правило, Клиент — это Браузер, а Сервер — это Сайт.

Для составления сообщений запроса и ответа в протоколе HTTP используется специальный синтаксис. Для сообщения запроса должен быть указан метод; чаще всего используются методы GET и POST.

Метод GET используется для получения содержимого ресурса, указанного в качестве объекта запроса (например, веб-страницы, которую нужно отобразить).

Метод POST обычно используется для отправки информации (например, введенных в форму данных) на Сервер.

Для формы электронного письма правильно использовать метод POST, но если Сервер не поддерживает этот метод, то программа WebSite X5 позволяет использовать вместо него метод GET.

Также можно указать Папка с доступом на запись:

§Папка на сервере с правами на запись: введите путь на сервере для папки с правами на запись (для PHP-скриптов).

Провайдеры обычно предоставляют права доступа на запись ко всем папкам на сервере: если в вашем случае это так, вы не должны показывать путь к папке общего доступа. В любом случае, по поводу папки общего доступа лучше обратиться к провайдеру.

Можно запустить тест в разделе Тест Сайта онлайн панели управления в любом случае, если у вас есть доступ на запись к папке и всем папкам внутри нее, у вас будет к ним доступ (куда можно сохранять данные).


Окно Настройки базы данных

Настройки базы данных

Этап 4 - Расширенные настройки > Управление данными >

Настройки базы данных

 Return to chapter overview

Это окно открывается из команды Добавить... в окне Управление данными можно задать настройки для новой базы данных, чтобы свзать ее с текущим проектом.

Структура сайта создается при помощи окна Настройки базы данных где нужно задать:

§Описание: задайте имя базе данных, чтобы потом легче было сориентироваться

§Имя хоста: введите URL-адрес сервера SQL, на котором хранится база данных. Обычно база данных хранится на том же сервере, что и сайт, с которым она связана. Для такого случая используем адрес «localhost». Уточните у своего провайдера - находится ли ваша база данных на том же сервере.

§Имя базы данных: введите имя база данных, с которой вы хотите работать: можно получить его у провайдера).

§Имя пользователя: введите имя пользователя (которое вам сообщил провайдер), необходимое для получения доступа к базе данных.

§Пароль: введите пароль (который вам сообщил провайдер), он необходим для получения доступа к базе данных.


Управление доступом

Этап 4 - Расширенные настройки >

Управление доступом

 Return to chapter overview
Покажите/скройте невидемый текст

В этом окне содержатся команды для создания и управления профилями пользователей, имеющих доступ к Пользовательским Разделам Сайта. Пользовательские Разделы задаются как Закрытые страницы при создании Создание карты сайта.

Кликните, чтобы развернуть/уменьшить Справка: Команды для создания профилей пользователей

С помощью Группы и пользователи, которые могут заходить на закрытые страницы , вы увидите Таблицу, где перечислены Группы/Пользователи, для которых уже был создан профиль. В этой таблице также можно найти логины и заметки для каждого пользователя.

Возле этой Таблицы представлены команды для создания списка Групп и Пользователей, имеющих доступ к Закрытым Страницам:

§Новая группа: можно добавить новую Группу. Если организовать похожих Пользователей в Группы, то ими будет легче управлять. Группы не имеют особых настроек и добавляются непосредственно в Таблицу. Для переименования уже добавленной Группы сделайте двойной щелчок по ее названию.

Иногда имеет смысл организовать Пользователей в Подгруппы. Общее число Групп и Подгрупп практически неограниченно.

По умолчанию есть две Группы: Администраторы и Пользователи. Члены Группы Администраторы — это администраторы Сайта, имеющие доступ ко всем Закрытым Страницам Сайта.

Каждый член Группы Администраторы может использовать свой Логин и Пароль для получения доступа к Панели Управления (http://www.mywebsite.ru/admin, где http://www.mywebsite.ru URL-адрес Сайта) Отсюда они могут управлять комментариями к сообщениям в Блоге, сообщениями в Гостевой Книге, а также просматривать информацию по диагностике Сайта.

§Новый пользователь: в окне Настройки пользователя можно создать нового Пользователя и задать для него Логин и Пароль. Созданный пользователь будет добавлен в выбранную Группу.

§Создать псевдоним: для выбранного Пользователя можно создать Псевдоним. Это бывает полезно в случае, если один и тот же Пользователь состоит более чем в одной Группе, а потому имеет доступ к разным Закрытым Страницам. Псевдонимы для членов Группы Администраторы создать нельзя, поскольку по умолчанию они имеют доступ ко всем Закрытым Страницам. Псевдоним остается связанным с Пользователем, и любые изменения в настройках одного Псевдонима автоматически применяются к остальным Псевдонимам этого Пользователя. Есть более простой способ создания Псевдонима: можно выбрать Пользователя в одной Группе и перетащить его в другую Группу, нажав клавишу CTRL непосредственно перед внесением его в новую Группу.

§Удалить: выбранную Группу или Пользователя можно удалить из списка. Существующую по умолчанию Группу Администраторы и Пользователя Admin в ней удалить нельзя.

§Редактировать...: в окне Настройки пользователя где можно редактировать параметры, заданные для выбранного Пользователя.

После создания Пользователей, задания их Логинов и Паролей, а также организации их в Группы можно вернуться к Этапу 2 — Создание карты сайта. Здесь можно задать Закрытые Страницы и определить, к какой из них какие Пользователи/Группы имеют доступ.
Кликните, чтобы развернуть/уменьшить Справка: Возможности по управлению доступом

В разделе Страница настройки логина и пароля можно задать следующие настройки:

§Приветственное сообщение: можно ввести сообщение, показываемое Пользователю при попытке получить доступ к Закрытой Странице без входа в систему. Пользователь будет перенаправлен на созданную Программой другую Страницу, имеющие следующие элементы:

-- вышеупомянутое приветственное сообщение;

-- поля ввода Логина и Пароля;

-кнопка Регистрация, если на Сайте используется Страница регистрации (см. следующую опцию).

§Страница регистрации: можно открыть Карту Сайта и задать Страницу, показываемую Пользователю после нажатия кнопки Регистрация, где он может ввести свои Логин и Пароль для доступа к Закрытым Страницам.

Когда вы указываете, что хотя бы одна страница будет закрытой , (что означает, что она является частью сайта, доступной только зарегистрированным пользователям), автоматически создается специальная страницв под названием «Вход в систему» на карте сайта, после чего можно выбрать эту страницу и настроить ее в окне Свойства страницы, чтобы задать главные параметры.

При тестировании вашего сайта в режиме оффлайн, вы получите предупреждающее сообщение о том, что закрытые страницы будут отображаться без запроса доступа. Области сайта, предназначенные только для зарегистрированных пользователей, будут доступны только после публикации сайта на сервере.

Для работоспособности Пользовательского Раздела требуется поддержка Хостинг-сервером PHP-скриптов и сеансов связи. Соответствующая информация будет представлена при диагностике Сервера в разделе Тест Сайта он-лайн Панели Управления.

Родственные темы:

-

Панель управления сайтом онлайн


Окно Настройки пользователя

Настройки пользователя

Этап 4 - Расширенные настройки > Управление доступом >

Настройки пользователя

 Return to chapter overview

Окно Настройки пользователя открывается при выборе команд Новый пользователь или Редактировать... в окне Управление доступом и можете задать учетное имя и пароль для нового пользователя.

Команды для создания нового Пользователя:

§Имя и фамилия— введите имя и фамилию Пользователя, имеющего доступ к Закрытым Страницам Сайта.

§Имя пользователя / Пароль— задайте Логин и Пароль, требуемые Пользователю для просмотра доступных для него Закрытых Страниц. Программа автоматически генерирует Пароль по умолчанию. Этот Пароль можно сменить.

§Страница приветствия— эта команда позволяет перейти к Карте Сайта, где можно задать Страницу, показываемую Пользователю после ввода правильного Логина и Пароля.

§Примечание— это необязательное поле: можно написать примечание о пользователе.

§Регистрационные данные— показывается Календарь, где можно задать дату регистрации нового Пользователя.

Примечание и Регистрационные данные не добавляются в код Сайта и предназначены лишь для облегчения задач Администратора Сайта по управлению Пользователями.


Корзина

Этап 4 - Расширенные настройки >

Корзина

 Return to chapter overview
Покажите/скройте невидемый текст

В этом окне представлены инструменты и параметры для создания и управления Корзиной для продажи товаров, предлагаемых на сайте.

При создании Корзины сначала нужно создать каталог товаров, где товары организованы по категориям и подкатегориям. Для этого потребуется ввести основные данные для каждого товара, такие как название, описание и цена. Можно расширить набор этих данных, добавив для всех товаров иллюстрации или фотографии, а также указав разновидности товаров (по размеру, цвету, модели и т.д.). После создания каталога нужно продумать, как будут доставляться товары и как покупатели будут их оплачивать. Также нужно создать форму заказа и форму электронного письма, автоматически отправляемого Корзиной администратору сайта и покупателю, сделавшему заказ.

Настройки различных элементов Корзины и способы их применения организованы в следующие разделы: Товары, Управление заказами, Данные покупателя, Отправить заказ и Параметры.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Товары

Можно использовать команды этого раздела для добавления товаров в Корзину и организации их в категории.

Все добавленные в Корзину товары перечисляются в таблице по категориям. В таблице приводится их описание и цена для каждого товара.

На панели инструментов над таблицей есть следующие команды:

Вырезать [CTRL+X] - Копировать [CTRL+C] - Вставить [CTRL+V]

Можно вырезать, копировать и вставлять выбранные товары. Эти же команды есть во всплывающем меню, появляющемся при нажатии правой кнопки мыши над списком товаров.

Развернуть / Свернуть

Можно раскрывать или свертывать выбранные категории, чтобы показать или скрыть товары в них.

Импортировать товары

Можно импортировать список товаров, чтобы добавить их в Корзину прямо из внешнего файла (TXT или CSV из Microsoft Excel).

Экспортировать товары

Можно экспортировать каталог товаров в файл TXT или CSV.

Для получения информации о параметрах Импортировать товары/Экспортировать товары и о том, как создать и организовать файлы для каталога продукции, см. Как делать импорт и экспорт товаров в Корзине.

Следующие команды также относятся к созданию списка товаров в Корзине:

§Новая категория: можно добавить новую категорию товаров. Категории не имеют особых настроек и при создании добавляются непосредственно в таблицу. Для переименования категории сделайте двойной щелчок по ее названию.

Для организации каталога товаров можно также создавать подкатегории. Общее число категорий и подкатегорий практически неограниченно.

§Новый товар: эта команда открывает окно Настройки товара, где можно добавить новый товар в выбранную категорию.

§Удалить: можно удалить либо выбранную категорию и все относящиеся к ней товары, либо один товар.

§Редактировать...: эта команда открывает окно Настройки товара, где можно внести изменения в настройки выбранного товара.

Переместить товар из одной категории в другую проще всего следующим образом: выберите его в списке товаров и перетащите мышью в новую категорию. Для выбора нескольких позиций используйте клавиши CTRL и SHIFT.

Если вы добавили в Корзину категории товаров, можно использовать Объект список товаров для создания онлайн-каталога.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Управление заказами

Можно использовать команды этого раздела, чтобы указать варианты доставки и оплаты, предлагаемые клиентам интернет-магазина.

В Список видов доставки отображает все добавленные варианты доставки товаров, включая Название, Описание и Стоимость для каждого товара.

Команды создания списка способов доставки:

§Добавить...: эта команда открывает окно Тип доставки, где можно добавить новый способ доставки.

§Сделать копию: определение существующего способа доставки можно скопировать и использовать как основу для нового способа.

§Удалить: выбранный способ доставки можно удалить из списка.

§Перемещение вверх или вниз: можно изменить порядок способов доставки в списке, поместив выбранный способ перед предыдущим или после следующего способа.

§Редактировать...: эта команда открывает окно Тип доставки, где можно внести изменения в настройки выбранного способа доставки. Либо можно сделать двойной щелчок по нужному способу в списке.

Окно Список видов оплаты очень напоминает раздел список типов доставки. Здесь перечисляются все варианты оплаты товаров, приобретаемых через Корзину, включая Название, Описание и Стоимость для каждого товара.

Команды создания списка способов оплаты аналогичны командам списка доставки, но теперь у вас есть еще две кнопки: Добавить... и Редактировать... котрые открывают окно Вид оплаты.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Данные покупателя

Можно использовать команды этого раздела для создания формы заказа, используемой для совершения покупок через Интернет.

В разделе Форма заказа отображается Список полей со всеми полями, которые можно использовать в форме заказа. Вот некоторые из них: Заводские настройки и некоторые из Свои настройки, и список, определяющий, является ли поле Видимость и/или Обязательное.

Команды на верхней панели кнопок Список полей:

Добавить свое поле

Можно добавить новое поле Свои настройки к форме заказа.

Удалить поле

Можно удалить выбранное поле. Нельзя удалять поля Заводские настройки.

Переименовать поле

Можно изменить название выбранного поля. Нельзя изменить названия следующих полей Заводские настройки.

Sposta sopra / Sposta sotto

Можно изменить расположение полей в списке, перемещая выбранное поле вверх или вниз. Можно изменить порядок полей Заводские настройки и Свои настройки, но нельзя перемещать поля Свои настройки в список Заводские настройки и наоборот.

Видимое поле

Можно сделать выбранные поля в форме заказа видимыми или невидимыми.

Обязательное поле

Можно сделать выбранные поля в форме заказа обязательными или дополнительными. Обязательные поля пользователь обязательно должен заполнить, чтобы его заказ попал на обработку.

В этом списке уже собраны все поля, которые обычно бывают в форме заказа.

Поле с электронным адресом ("E-mail address») - единственное, которое нельзя сделать необязательным или скрыть, поскольку электронный адрес пользователя очень важен для правильной работы Корзины.

Внизу таблицы Список полей есть параметр:

§Отображать форму данных для доставки: если выбрать эту возможность, к форме заказа автоматически добавляется поле для адреса доставки товаров пользователю, если этот адрес отличается от платежного.

К тому же, по требованиям действующего законодательства, при сборе данных о заказе должны быть предусмотрены поля для хранения информации обо всех условиях сделки, определяющие функционирование Корзины. Причем таким образом, чтобы покупатель мог принять эти условия в явном виде.

В разделе Условия продажи есть редактор, который можно использовать для того, чтобы записать Текст условий продажи. Стандартный текст уже прописан в редакторе. Можно нажать [image] кнопку, чтобы создать ссылку для открывания, например, файла PDF, содержащего ваше описание политики работы с покупателями и условия возврата денег. Если нужно, вы можете создать свой собственный текст.

Чтобы соответствовать требованиям закона, важно, чтобы значок принятия соглашения Условия продажи располагался непосредственно перед кнопкой «Купить», подтверждающей заказ. Можно также включить следующие настройки:

§Запрос согласия с условиями продажи: поле, подтверждающее явное согласие покупателя с условиями Условия продажи добавляется в конце формы заказа, покупатель должен нажать на чекбокс, чтобы показать, что согласен с условиями.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Отправить заказ

Можно использовать команды этого раздела для того, чтобы задать, как именно передаются данные из Корзины и написать текст электронного письма для подтверждения заказа, которое будет автоматически отправляться покупателям.

Можно задать способ, который будет использоваться для передачи данных от покупателя и для отправки этих данных администатору сайта в Порядок доставки:

§E-mail адрес для приёма заказов: определяет адрес электронной почты, на который будут поступать данные при отправке заполненной формы обратной связи. Можно задать и больше одного адреса, разделяя адреса точкой с зяпятой (;).

§Приложить данные заказа в формате CSV: отправленные данные сохраняются в виде CSV-файла и прикрепляются в конце электронного письма. Данные в формате CSV - это текст, похожий на список, с элементами, разделенными точкой с запятой (;): такие файлы можно импортировать в программы обработки табличных данных (например, Microsoft Excel).

В разделе Письмо-подтверждение заказа для покупателя есть поля, в которые можно ввести Текст 'шапки' страницы письма и Текст 'подвала' страницы письма для электронного письма подтверждения заказа, которое автоматически отправляется покупателю, сделавшему заказ. Это электронное письмо содержит вводный текст, заключительный текст и описание процедуры доставки и метода платежа, выбранных покупателем.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Параметры

Можно использовать команды этого раздела для того, чтобы задать некоторые настройки для отображения графики, валюты и НДС в Корзине.

Здесь доступны следующие возможности для Настройки валюты:

§Валюта: можно указать денежные единицы, которые принимаются при размещении заказа через Корзину. Развертывающееся меню представляет список валют: нажмите на [image] кнопку, чтобы открыть окно Список валют и отредактировать этот список.

§Маска формата поля: здесь задается отображение цены; можно использовать запятую в качестве разделителя тысяч, и точку для отделения десятичных знаков (1,000.00) или наоборот (1.000,00).

§Отображать валюту справа: если выбрать этот параметр, то символ денежной единицы будет отображаться справа от цены.

§Показать разделитель десятичных разрядов: если выбрать этот параметр, то значение цены будет отображаться с двумя знаками после десятичной запятой (или точки).

Здесь доступны следующие возможности для Настройки налога:

Вид налогообложения: определяет, будут ли цены, показанные в Корзине, включать НДС или нет. Либо НДС вообще здесь неприменим.

Значение по умолчанию (%): определяет ставку НДС, которая по умолчанию будет добавлена к цене каждого товара в Корзине, за исключением тех товаров, для которых установлена иная ставка НДС с помощью параметра Налог (%) в окне Настройки товара | Общие настройки.

В разделе Параметры доступны следующие команды:

§Разрешить заказы только на минимальные количества: если выбрать этот параметр, то заказ можно будет сделать лишь на сумму, не меньше заданного значения.

§Минимальное общее количество: этот параметр доступен лишь при выборе параметра Разрешить заказы только на минимальные количества. При этом можно задать минимальную общую сумму покупки, при достижении которой можно будет сделать заказ.В подразделе Параметры можно настроить внешний вид таблиц, описывающих предлагаемые и/или добавленные в Корзину товары:

§Фон 'шапки' страницы / Текст 'шапки' страницы / Фон ячеек / Цвет текста в ячейках / Рамка таблицы: можно задать цвета различных элементов таблицы товаров.

§Закругленные уголки: можно задать свою фаску для каждого уголка таблицы товаров, либо для всех четырех уголков сразу.

§Чередовать цвет строк: можно применить два фоновых цвета, чтобы по-разному отображать четные и нечетные строки. Один из цветов определяется параметром Фон ячеек а другой задается автоматически, как более темный оттенок цвета. Применение таких переменных цветов облегчает чтение таблиц, особенно, когда таблицы длинные.

Можно использовать команды в разделе Изображения чтобы добавить на страницы Корзины изображения:

§Добавить в Корзину/ Удалить из Корзины: можно задать изображения, которые будут использоваться для оформления кнопок «Добавить в Корзину» и «Удалить из Корзины».

§Предпросмотр невозможен: можно задать изображения для отдельных товаров, у которых нет своей фотографии (в Настройки товара | Изображение), и "Изображение и текст" или "Текст и изображение" можно выбрать этот параметр как Режим отображения для карточки товара в Объект список товаров | Настройки.

После создания Корзины нужно добавить необходимую информацию и ссылки на сайт для того, чтобы потенциальные покупатели могли просмотреть сведения о товарах и совершить покупку. Это можно сделать двумя способами:

1.Добавить кнопку «Купить сейчас» на страницы презентации товаров сразу при их создании, используя ссылку Добавить в Корзину (см. Ссылка).

2.Создать страницы презентации товаров с помощью Объект список товаров для использования карточек товаров, на которых уже есть кнопка «Купить сейчас».

Когда вы создаете Корзину, специальная страница под названием «Корзина» автоматически добавляется к карте сайта, после чего можно выбрать эту страницу и настроить ее в окне Свойства страницы.

При тестировании сайта в режиме «офлайн» это сообщение предупреждает вас, что заказ не будет отправлен и вы будете автоматически перенаправлены на страницу подтверждения заказа. Корзина работает в полном объеме только после публикации сайта на сервере.

Для нормальной работы Корзины нужно, чтобы хостинг, на котором размещается сайт, поддерживал PHP и команду Mail. Соответствующую диагностическую информацию о сервере можно получить в разделе Тест Сайта Панели управления.

Если у вас есть проблемы с отправкой электронной почты, возможно, это ваш сервер не поддерживает стандартную конфигурацию. Попробуйте сменить настройки скриптов и метод отправки электронной почты, используя параметры в Расширенные настройки | Управление данными. Более подробную информацию можно получить у своего интернет-провайдера.

Лучшая практика:

- | Как делать импорт и экспорт товаров в Корзине
- | Как оформить подтверждение заказа по электронной почте

Родственные темы:

-

Панель управления сайтом онлайн


Окно Настройки товара

Корзина Окно Настройки товара .

Этап 4 - Расширенные настройки > Корзина >

Корзина Окно Настройки товара .

 Return to chapter overview
Покажите/скройте невидемый текст

Окно Настройки товара открывается при выборе команды Новый товар или Редактировать... в разделе Корзина | Товары, где можно задать и добавить новый товар.

Окно состоит из следующих разделов: Общие настройки, Изображение, Параметры, Скидка.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Общие настройки

Можно использовать команды этого раздела для дзадания основной информации о новом товаре, добавляемом в Корзина.

Вот команды для добавления нового товара:

§Наименование/Код— можно добавить или отобразить (для редактирования) название или код Товара.

§Описание— можно добавить или отобразить (для редактирования) описание Товара.

§Цена— введите цену для выбранного Товара.

§Налог (%)— если включить эту опцию, то можно указать ставку НДС, применяемую к данному Товару. Этот параметр доступен, если вы задали Вид налогообложения значение «включая НДС» или «исключая НДС» в Настройки налога в Корзина | Параметры.

В зависимости от настроек Корзины, можно либо добавлять Товары с ценами, уже включающими НДС, либо (если к разным Товарам применяются разные ставки НДС) указывать цены без НДС, а потом добавлять сумму налога отдельно для каждого Товара.

§Вес— введите массу текущего Товара, чтобы можно было рассчитать стоимость доставки (см. Оплата | Доставка).

В зависимости от типа Товара, Вес (термин условный) можно выразить в килограммах, литрах, метрах и др. Важно правильно рассчитать стоимость доставки, поэтому для каждого Товара в Корзине выберите наиболее подходящую единицу измерения.

§Ссылка (напр., на страницу продукта)— эта команда открывает окно Ссылка, в котором можно задать ссылку на текущий товар. Ссылка может быть, к примеру, на страницу сайта, где подробно описан товар.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Изображение

Можно использовать команды этого раздела для добавления фотографий товара в Корзина.

При наличии нескольких изображений можно создать Cлайд-шоу; если посетитель нажмет на изображение, в Электронной Витрине будет показана увеличенная версия этого изображения.

В Корзине будет показываться лишь первое изображение, связанное с Товаром. Все остальные изображения будут показываться в Карточке Товара, которую можно создать посредством Объект список товаров.

Для создания списка изображений, связанных с Товаром, можно использовать следующие опции:

§Добавить... / Удалить— изображения можно добавлять в список изображений Cлайд-шоу и удалять из списка. В окне Выбор Файла можно выбрать сразу несколько позиций.

§Сдвинуть вверх / Сдвинуть вниз — можно изменить положение выбранного изображения в Cлайд-шоу, поместив это изображение до предыдущего или после следующего.

§Редактировать...— эта команда открывает Редактор изображений, где можно редактировать выбранное изображение.

В разделе Параметры ShowBox доступны следующие опции:

§Максимальный размер— можно задать максимальную ширину или высоту Электронной Витрины, в которой показываются увеличенные изображения. Оставьте Сохранять пропорции выбранным, если хотите сохранить соотношение высоты и ширины (форм-фактор).

§Эффект перехода— нажмите на кнопку [image] , чтобы открыть окно Название эффекта, где можно задать тип эффекта для перехода к новой фотографии в ShowBox.

Можно настроить стиль Showbox: используя параметры раздела Стили и модели | E-mail на этапе 4 — Расширенные настройки, вы можете задать цвета, тени, прозрачность, динамические эффекты и т.д.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Параметры

Можно использовать команды этого раздела для создания списка параметров , доступных для нового товара, который вы добавляете в Корзина.

Можно добавить Опции Товара, такие как размер и цвет предмета одежды, или добавить другой вариант модели Товара. У каждого параметра могут быть дополнительные параметры. Например, «майка XY" может иметь параметры размера "S", "M" и "L": дополнительные параметры для "S" могут быть «черная», «красная» и «зеленая»; допрлнительные параметры для "M" могут быть «черная» и «белая», и т.д.

Покупатели могут посмотреть полный список возможных параметров в Корзине и в карточке товара, созданной с использованием Объект список товаров, и выбрать то, что они хотят заказать.

Команды для создания Список основных параметров следующие:

§Добавить...— можно добавить новый главный параметр для текущего товара. Он будет отображаться в Список основных параметров и можно задать его, используя параметры в разделе Настройка основных параметров .

§Удалить— выбранный основной параметр можно удалить из Список основных параметров.

§Сдвинуть вверх / Сдвинуть вниз — можно изменить положение выбранной Опции в списке, поместив ее до предыдущей или после следующей.

Можно задать главный параметр в Настройка основных параметров—

§Наименование/Код— задает название или код для главного параметра, котрый вы создаете для текущего товара

§Разница цен— определяет варианты цены для главного параметра, по отношению к Цена товара, обозначенному в Общие настройки.

§Разница веса— определяет варианты веса для главного параметра, по отношению к Вес товара, обозначенному в Общие настройки.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Скидка

Можно использовать команды этого раздела, чтобы установить размер скидки на новый товар в Корзина.При выборе параметра Разрешить оптовую скидку, вы можете создать список скидок, применяемых в соответствии с количеством заказанных товаров. Скидки показываются в списке, для работы с которым можно использовать следующие команды:

§Добавить...— в открывающемся окне Оптовая скидка можно указать размер оптовой скидки, применяемый к текущему Товару. Можно задать товар Количество , который должен быть таким же или больше, чем в заказе, чтобы скидка Скидка (%) была применена.

§Удалить— оптовую скидку можно удалить из списка.

§Редактировать...— в открывшемся окне Оптовая скидка можно изменить выбранный размер оптовой скидки. (Как вариант, для начала редактирования можно сделать двойной щелчок по нужной скидке.)


Окно Тип доставки

Корзина Окно Тип доставки .

Этап 4 - Расширенные настройки > Корзина >

Корзина Окно Тип доставки .

 Return to chapter overview
Покажите/скройте невидемый текст

Окно Тип доставки открывается при выборе команды Добавить... или Редактировать... в Список видов доставки раздела Корзина | Управление заказами. Здесь можно задавать и добавлять способы доставки для товаров в Корзине.

Окно Тип доставки состоит из трех разделов: Общие настройки, Стоимость и E-mail сообщение.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Общие настройки

Можно использовать эти команды, чтобы задать метод доставки:

§Имя— назначьте методу осмысленное и ясное название, чтобы вы потом смогли его легко вспомнить.

§Описание— можно задать развернутое пояснение для этого метода.

§Изображение— выберите изображение, соответствующее текущему методу на страницах Корзины.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Стоимость

Можно использовать команды этого раздела для указания наценки за выбранный метод доставки. Есть разные способы расчета стоимости:

§Фиксированная стоимость— можно задать фиксированную стоимость для текущего способа доставки. Покупатели платят одну и ту же сумму за доставку любых заказов, независимо от общей суммы заказа и массы груза.

§Стоимость с учетом объема заказа— для выбранного способа доставки можно определить диапазон стоимости доставки, рассчитываемой в зависимости от общей суммы заказа. Кнопки Добавить... и Редактировать... открывают окно Стоимость доставки, где можно задать значение Объем заказа, если значение такое или больше, то можно использовать определенный способ доставки Цена.

§Стоимость с учетом общего веса заказа— для выбранного способа доставки можно определить диапазон стоимости доставки, которая рассчитывается в зависимости от общей массы заказанных товаров. Кнопки Добавить... и Редактировать... открывают окно Стоимость доставки, где можно задать значение Общий вес, если значение такое или больше, то можно использовать определенный способ доставки Стоимость.

Для правильного расчета стоимости доставки важно указать массу каждого товара в Корзине в окне Настройки товара | Общие настройки.

Можно также использовать параметр:

§Налог (%)— здесь можно указать ставку НДС, связанную с данным способом оплаты. Этот параметр доступен, если вы задали Вид налогообложения значение «включая НДС» или «исключая НДС» в Настройки налога в Корзина | Параметры.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе E-mail сообщение

В разделе Электронное Сообщение можно ввести текст сообщения, описывающего данный способ доставки и дающего необходимые пояснения. Это сообщение будет вставлено в электронное письмо, отправляемое Покупателю для подтверждения заказа.

Лучшая практика:

-

Как оформить подтверждение заказа по электронной почте


Окно Вид оплаты

Корзина | Окно Вид оплаты

Этап 4 - Расширенные настройки > Корзина >

Корзина | Окно Вид оплаты

Return to chapter overview
Покажите/скройте невидемый текст

Окно Вид оплаты открывается командами Добавить... или Редактировать... в разделе Список видов оплаты в Корзина | Управление заказами, можно указать варианты доставки и оплаты, предлагаемые клиентам интернет-магазина.

Окно Вид оплаты содержит следующие разделы: Общие настройки, Тип и E-mail сообщение.

Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Общие настройки

Можно использовать эти команды, чтобы задать метод оплаты:

§Имя— назначьте методу осмысленное и ясное название, чтобы вы потом смогли его легко вспомнить.

§Описание— можно задать развернутое пояснение для этого метода.

§Изображение— выберите изображение, соответствующее текущему методу на страницах Корзины.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе Тип

Можно использовать команды этого раздела для выбора метода оплаты. Это может быть:

§Оплатить позже— сделанный заказ можно оплатить позже (например, банковским переводом).

§Оплатить сейчас— сделанный заказ нужно сразу оплатить (например, через систему PayPal или кредитной картой).

При включении опции Оплатить сейчас потребуется указать используемый Вид оплаты. Для каждого типа должны быть определены соответствующие параметры:

PayPal/кредитная карта

§Учетная запись в PayPal— здесь нужно ввести реквизиты PayPal

§Страница подтверждения успешной оплаты— здесь задается Страница, используемая для подтверждения оплаты.

§Страница сообщения об ошибке при оплате— здесь задается Страница, которая откроется в случае ошибки в процессе оплаты.

Код клиента

§Код HTML для кнопки 'Оплатить сейчас'— если используется не PayPal, а другая платежная система, выберите эту опцию и введите HTML-код, предоставленный соответствующим Поставщиком Платежных Услуг.

В HTML-код, предоставленный Поставщиком Платежных Услуг, нужно ввести номер заказа и общую сумму заказа. Для правильной работы Корзины нужно вручную ввести следующие теги:

§[ORDER_NO] — сюда вводится номер заказа;

§[PRICE] — сюда вводится общая сумма заказа.

Также можно использовать следующие опции:

§Стоимость— здесь можно указать накладные расходы, связанные с данным способом оплаты.

§Налог (%)— здесь можно указать ставку НДС, связанную с данным способом оплаты. Этот параметр доступен, если вы задали Вид налогообложения значение «включая НДС» или «исключая НДС» в Настройки налога в Корзина | Параметры.
Кликните, чтобы развернуть/уменьшить Справка: Команды в разделе E-mail сообщение

В разделе Электронное Сообщение можно ввести текст сообщения, описывающего данный способ оплаты и дающего необходимые пояснения. Это сообщение будет вставлено в электронное письмо, отправляемое Покупателю для подтверждения заказа.

Лучшая практика:

-

Как оформить подтверждение заказа по электронной почте


Экспорт сайта

Этап 5 - Экспорт сайта >

Экспорт сайта

 Return to chapter overview

Если вы закончили сеанс работы или разработку своего сайта, значит вы готовы к переходу на этап 5, где WebSite X5 позволит выполнить экспорт вашего проекта. Благодаря наличию встроенной FTP-программы, файлы Проекта можно загрузить прямо на Хостинг-сервер; эта программа поддерживает шифрованные соединения. Можно сэкономить время, работая в многосеансовом режиме и загружая на сервер лишь те файлы, которые были изменены со времени последнего экспорта. Как вариант, можно сохранить все файлы на диск локального компьютера, чтобы получить копию Проекта, готового к загрузке на Хостинг-сервер. Файлы Проекта также можно сохранить в одну папку, что позволит перенести их на другой компьютер (например, для продолжения работы с ними).

Итак, есть следующие варианты экспорта:

Выгрузка сайта в Интернет

Экспорт сайта на диск

Экспорт проекта


Экспорт сайта в Интернет

Этап 5 - Экспорт сайта >

Экспорт сайта в Интернет

 Return to chapter overview
Покажите/скройте невидемый текст

Данное окно позволяет загрузить Сайт в Интернет.

В программе WebSite X5 есть встроенный FTP-клиент, позволяющий разместить готовый Сайт прямо на Хостинг-сервере. Все необходимые файлы для правильного отображения Сайта в Интернете сохраняются на компьютере, где создавался Сайт. Для того, чтобы Сайт был доступен для посетителей, файлы Проекта должны быть загружены на Хостинг-сервер (специальный компьютер, постоянно подключенный к Интернету).

Кликните, чтобы развернуть/уменьшить Справка: Команды для подключения к серверу

При экспорте файлов Сайта сначала нужно задать Профиль сессии (эти данные можно выяснить у своего Хостинг-провайдера):

§Тип сервера— укажите, какое соединение используется для загрузки файлов Сайта на Хостинг-сервер. Выберите используемое соединение:

-FTP - (File Transfer Protocol) - протокол передачи файлов— это параметр по умолчанию. FTP — это один из старейших протоколов передачи данных, который до сих пор широко используется. FTP-клиент и FTP-сервер обмениваются незашифрованными данными согласно оригинальным спецификациям протокола FTP.

-SFTP - протокол передачи файлов для SSH— этот интернет-протокол обеспечивает шифрованную передачу данных с использованием удаленных шифрованных сеансов связи и удаленной работы с файлами.

-FTPS - это FTP по защищенному стандарту TLS/SSL— для обеспечения безопасной передачи данных, этот протокол добавляет к протоколу FTP шифрованный уровень SSL/TLS, а также определенные команды и коды ответа.

§Адрес FTP— введите в это поле свой FTP-адрес. Например, ftp.websitex5.com, где websitex5.com — доменное имя.

§Имя пользователя / Пароль— введите в эти поля свое Имя пользователя и Пароль.

§Сохранить пароль— если включить эту опцию, то введенный пароль будет сохранен и в дальнейшем его не потребуется вводить повторно.

Также есть Дополнительные параметры, которые можно не указывать для установления соединения с Сервером, хотя при желании можно ввести:

§Папка назначения— введите полный путь с именем папки назначения (его можно узнать у Хостинг-провайдера). Если не ввести здесь полный путь с именем папки назначения, то его можно будет указать в следующем окне программы WebSite X5.

§Порт— можно указать имя шлюза на Сервере, с которым будет установлено соединение (его можно узнать у Хостинг-провайдера). Как правило, можно использовать значение по умолчанию.

§Количество одновременных подключений— можно указать число одновременных соединений с Сервером, которые FTP-клиент должен создать для загрузки на Сервер файлов Сайта. Число соединений соответствует максимальному количеству файлов, которые можно экспортировать одновременно.

Сервер должен поддерживать Количество одновременных подключений. Даже если такая поддержка обеспечена, для более быстрой загрузки файлов на Сервер можно эффективно использовать лишь ограниченное число одновременных соединений. Попробуйте начать с 3 одновременных соединений с сервером, а затем постепенно увеличивайте это число до тех пор, пока не найдете оптимальное для данной полосы пропускания. Как правило, не имеет смысла использовать более 10 одновременных соединений.

§Использовать пассивный FTP— это значение выставлено по умолчанию и означает, что при экспорте файлов Проекта используется FTP в пассивном режиме. Тем самым повышается степень совместимости с Сервером.

§Разрешить сжатие gzip— это значение выставлено по умолчанию и означает, что файлы Проекта при экспорте сжимаются для более быстрой загрузки их на Сервер.

Не все серверы поддерживают gzip-сжатие. Если эта опция включена, а сервер не поддерживает gzip-сжатие, то файлы не будут сжиматься, однако Проект, тем не менее, будет загружен на Сервер. Gzip-сжатие дает отличные результаты для больших файлов (например, содержащих множество изображений или видеофайлов), но для мелких файлов его лучше не использовать.

Настроив все параметры соединения с Сервером, можно задать Режим Загрузки (то есть определить, что и как будет загружено на Хостинг-сервер). Режим выгрузки :—

§Экспорт всех файлов сайта в Интернет— весь Проект Сайта будет загружен на Хостинг-сервер и доступен в Интернете. Этот вариант рекомендуется использовать при первой загрузке Сайта, а также в случае, если в файлы Проекта было внесено много изменений.

§Экспорт только тех файлов, которые были изменены со времени экспорта {0}— при выборе этой опции на Сервер будут загружены лишь те файлы, которые были изменены с момента последнего экспорта. Этот вариант рекомендуется использовать для часто обновляемого Сайта, поскольку так можно быстрее его обновлять (по сравнению с загрузкой всех файлов Сайта).

Дата опубликования сохраняется в файл Проекта, поэтому после публикации файлов в Интернете нужно всегда сохранять изменения.

Даже если выбрать экспорт только измененных файлов, на Сервер также будут загружены HTML-страницы и файлы ресурса (из папки RES), поскольку высока вероятность того, что они были обновлены.

§Экспорт только блога и ленты RSS— при выборе этой опции будут опубликованы только PHP- и XML-файлы Блога и XML-файлы RSS-ленты (см. Этап 4 - Расширенные настройки). Этот вариант можно использовать лишь в случае, если Блог или RSS-лента уже были размещены на Хостинг-сервере. Так можно обновлять только Блог или RSS-ленту, не затрагивая другие части Сайта.
Кликните, чтобы развернуть/уменьшить Справка: Команды для перехода онлайн

После настройки всех параметров соединения с Сервером нажмите кнопку Далее, чтобы подключиться к Серверу. После установления соединения отображается список существующих папок на Сервере. Используйте доступные команды для перехода в папку, где нужно разместить файлы Проекта.

Папка, где будет размещаться Сайт, должна содержать файл index.html. Если есть сомнения по выбору папки, лучше обратиться к Хостинг-провайдеру (не все папки на Хостинг-сервере можно использовать для опубликования Сайта).

Кликните, чтобы развернуть/уменьшить

На Сервере можно использовать следующие команды:

Перейти в папку на уровень выше

Эта команда возвращает в папку на предыдущем уровне.

Обновить

Эта команда обновляет отображаемое содержимое папки.

Создать папку

Можно создать новую папку.

Удалить

Можно удалить выбранный файл или папку.

Переименовать

Можно переименовать выбранный файл или папку.

Выгрузить файл на сервер / Загрузить выбранный файл с сервера

Эти команды позволяют разместить один или несколько файлов, не являющихся частью Проекта Сайта, на Хостинг-сервере, или скачать файлы, размещенные на Хостинг-сервере, на свой компьютер.

Показать список / Показать подробно

для списка файлов можно настроить детальность отображаемой информации.

И, наконец, есть еще две опции:

§Журнал сообщений— эта опция отображает сообщения и ошибки, зарегистрированные в течение соединения с Сервером.

§Файлы в очереди— если включить эту опцию, то будет отображаться состояние загрузки файлов, передаваемых на Сервер (число загружаемых файлов зависит от заданного числа одновременных соединений). Степень загрузки каждого файла показывается в строке текущего состояния. После завершения загрузки файл удаляется из очереди.

При экспорте Проекта программа WebSite X5 копирует на Сервер все файлы из папки регистрации. Если в этой папке есть файлы с такими же именами, как уже опубликованные, последние будут заменены. Программа WebSite X5 никогда не удаляет файлы, расположенные на сервере. Это нужно сделать вручную.


Экспорт завершен

Этап 5 - Экспорт сайта > Экспорт сайта в Интернет >

Экспорт завершен

 Return to chapter overview

После того, как сайт размещен в Интернете (см. Экспорт сайта в Интернет), это окно предлагает несколько способов дать людям узнать о нем, используя такие каналы, как Галерея программы WebSite X5, Google™, Facebook и Twitter.

Можно выбрать один из этих вариантов:

Ваш сайт теперь доступен в Интернет!

Можете запустить используемый по умолчанию Браузер, чтобы открыть свой Сайт и проверить, всё ли правильно работает.

WebSite X5 Gallery

Можете зайти в Галерею сайтов WebSite X5 Answers и добавить туда свой Сайт. Эта Галерея — сборник сайтов, созданных пользователями программы WebSite X5, пожелавшими поделиться информацией о своем сайте.

Обновить карту сайта на Google

Можно сообщить поисковой системе Google о Карте Сайта (SiteMap)запущенного Сайта, чтобы поисковый робот начал его индексировать.

Рассказать о публикации на Facebook

Можно зайти в социальную сеть Facebook и разместить на своей Стене комментарий о Сайте, чтобы сообщить о нем всем своим друзьям.

Рассказать о публикации сайта на Twitter

Можно зайти на Twitter и написать сообщение («твит») о Сайте, чтобы сообщить о нем всем своим подписчикам («фолловерам»).


Экспорт на диск

Этап 5 - Экспорт сайта >

Экспорт на диск

 Return to chapter overview

В этом окне можно экспортировать копию вашего опубликованного сайта на компьютер.

Этот вариант используется для сохранения локальной копии файлов, размещенных на сервере. После этого их можно будет скопировать на другой носитель (CD-, DVD- или USB-накопитель) или внести изменения в HTML-страницы до их публикации в Интернете.

Для экспорта всех файлов проекта нужно указать следующий параметр:

§Папка назначения: введите имя папки, куда должны быть скопированы файлы проекта. Если такая папка не существует, она автоматически будет создана.

Параметр Экспорт на диск не предназначен для создания резервной копии вашего проекта, поскольку здесь происходит экспорт на ваш компьютер файлов, используемых для публикации, а не файлов проекта, которые можно редактировать.

Если вы хотите создать резервную копию проекта, из которой можно будет восстановить предыдущую версию, нужно использовать команду Backup (Резервная копия) в меню Сохранить.

Если вы хотите создать резервную копию, которую можно использовать в случае потери исходного проекта, используйте вариант Экспорт проекта в этом случае вы сделаете копию всех файлов исходного проекта.

Лучшая практика:

-

Как организовать резервное копирование вашего проекта


Экспортировать проект

Этап 5 - Экспорт сайта >

Экспортировать проект

 Return to chapter overview

Это окно позволяет экспортировать все связанные с Проектом файлы в один сжатый файл, который можно использовать для переноса Проекта на другой компьютер или в качестве резервной копии.

Для экспорта файла Проекта нужно указать следующий параметр:

§Папка назначения— введите название папки, в которую будем экспортировать проект. Если заданная папка не существует, она будет создана автоматически.

При экспорте в назначенной папке создается один сжатый файл. Имя файла совпадает с названием проекта, расширение - .IWZIP. Например, если файл Проекта называется «moyproekt», то будет создан новый файл moyproekt.iwzip. В этом сжатом файле будут сохранены IWP-файл исходного Проекта, а также все связанные с ним файлы (например, Изображения, Видеозаписи и Flash-анимации).

Перед выполнением экспорта проекта можно использовать следующие параметры:

§Добавить копию файлов предпросмотра сайта— можно включить файлы для отображения предварительного просмотра сайта на локальном компьютере в архив .IWZIP. Размер файла .IWZIP увеличится, но зато не понадобится заново создавать файлы предварительного просмотра, если вы перенесете проект на другой компьютер.

Сжатый IWP-файл можно перенести на другой компьютер и открыть в данной программе при помощи команды Импорт... в окне Выбор проекта.

Лучшая практика:

-

Как организовать резервное копирование вашего проекта


Как организовать резервное копирование вашего проекта

Лучшая практика > Общие настройки >

Как организовать резервное копирование вашего проекта

 Return to chapter overview
Покажите/скройте невидемый текст

Фундаментальный аспект организации проекта - создание его резервных копий.

Создание резервной копии проекта означает создание запасной копии для хранения на вашем компьютере или на другом накопителе на случай потери оригинала.

Если у вас есть резервная копию вашего проекта, значит вы застрахованы от следующих проблем:

§Восстановление в аварийных ситуациях - восстановление проекта после фатальных ошибок, вызванных проблемами с компьютером или нечаянным удалением данных.

§Восстановление версии - создание копий, соответствующих различным версиям проекта, так, что вы можете, например, отменить изменения, сделанные в течение последнего сеанса работы и восстановить резервную копию версии проекта, каким он был до внесения изменений.

Чтобы резервные копии были действительно полезны, вам нужно методично и систематически создавать их.

Кликните, чтобы развернуть/уменьшить Восстановление версии - Как автоматически создавать резервную копию

Чтобы автоматически создавать резервную копию вашего проекта, вам нужно:

§открыть проект,

§выбрать пункт Создать резервную копию при первом сохранении проекта в меню Сохранить,

§либо в это же время выбрать пункт Создавать резервную копию каждый раз при выгрузке сайта в меню Сохранить.

При выборе параметра Создать резервную копию при первом сохранении проекта резервная копия проекта создается в момент первого сохранения проекта, где в том случае, если вы выбираете параметр Создавать резервную копию каждый раз при выгрузке сайта резервная копия создается перед публикацией сайта в Интернет.

Все сделанные резервные копии сохраняются в папке для резервных копий Папка проектов которую вы задаете в окне Предпочтения.
Кликните, чтобы развернуть/уменьшить Восстановление версии - Как восстановить резервную копию проекта

Если вам нужно восстановить резервную копию проекта, нужно:

§открыть папку для резервных копий Папка проектов (которую вы задаете в окне Предпочтения) и выбрать файл, соответствующий резервной копии, которую вы хотите восстановить: это будет либо Backup.iwprj, созданный с помощью Создать резервную копию при первом сохранении проекта, либо Uploaded_timestamp.iwprj, созданный с помощью Создавать резервную копию каждый раз при выгрузке сайта;

§вырежьте выбранный файл в папке для резервных копий и вставьте его в Папка проектов;

§удалите файл "project.iwprj", содержащий ваш проект, и переименуйте файл резервной копии в "project.iwprj";
Кликните, чтобы развернуть/уменьшить Восстановление в аварийных ситуациях - Как создать резервную копию вашего проекта

Если вы хотите создать резервную копию своего проекта для хранения на отдельном внешнем устройстве, вам нужно:

§выбрать пункт Экспорт проекта переходя на Этап 5 - Экспорт сайта чтобы экспортировать все связанные с проектом файлы в один сжатый файл (.IWZIP);

§скопировать файл .IWZIP на накопитель данных, на котором вы собираетесь хранить резервную копию.

Кликните, чтобы развернуть/уменьшить Восстановление в аварийных ситуациях - Как восстановить резервную копию вашего проекта

Если вы хотите восстановить резервную копию своего проекта, сохраненную на отдельном внешнем устройстве, вам нужно:

§нажать на кнопку Импорт... в окне Выбор проекта для выбора архива .IWZIP, содержащего проект, который вы хотит восстановить;

§выбрать восстановленный проект, открыть его и продолжить работу.


Как автоматически переводить вводимый текст

Лучшая практика > Этап 1 - Общие настройки >

Как автоматически переводить вводимый текст

 Return to chapter overview
Покажите/скройте невидемый текст

Некоторые элементы на Страницах, созданных в программе WebSite X5, добавляются автоматически: например, ссылки на другие части Сайта, кнопки в Объект в галерее, надписи Объект-форма обратной связи, надписи и текст Корзины, а также текст на Карте Сайта.

Конечно же, текст, генерируемый для этих элементов Сайта, должен быть на нужном языке. Для этого в разделе Язык контента: окна Общие настройки нужно задать основной Язык Сайта. В программе WebSite X5 есть встроенная поддержка нескольких языков, включая английский, итальянский и немецкий. Есть готовые версии интерфейса Сайта на этих языках. Изначально имеющиеся переводы интерфейса можно изменить. Кроме того, можно добавить или импортировать другие языки, а также убрать ненужные. Для этого нажмите кнопку [image] возле опции Язык контента: окна Управление языковым контентом..

Кликните, чтобы развернуть/уменьшить Как изменить автоматический текст

Примерами текста, автоматически добавляемого Программой, являются надписи на кнопках «Отправить» и «Сбросить» в нижней части форм электронных писем.

Допустим, в качестве Языка Содержимого был выбран «английский», а потом потребовалось изменить надпись «Reset» («Сбросить») на «Ignore» («Игнорировать»).

§В окне Управление языковым контентом. нажмите на пункт английский в списке доступных Языков, чтобы отобразить различные автоматические текстовые элементы в Таблице перевода.

§В первом столбце Таблицы найдите пункт «label_form» (надпись для кнопки, которую нужно изменить). Пройдите по ряду к соответствующей ячейке в столбце английского языка. Сделайте двойной щелчок на ячейке, чтобы вызвать текстовый курсор, а затем удалите слово «Reset» и введите вместо него «Ignore».

§Сохраните сделанные изменения.
Кликните, чтобы развернуть/уменьшить Как добавить новый язык

Если нужно создать версию Сайта на Языке, изначально не включенном в список по умолчанию (например, на португальском), то во избежание автоматического добавления английского текста (напомним, что английский язык используется по умолчанию) следует добавить новый Язык в список. А также перевести все текстовые элементы, предназначенные для автоматической вставки. Разумеется, для этого потребуются навыки по переводу текста. После того, как вы добавили необходимые переводы, добавление нового языка очень просто:

§В окне Управление языковым контентом., нажмите кнопку Добавить новый язык, а затем введите «PT - португальский» в открывшемся диалоговом окне. Новый язык появится внизу списка доступных языков.

§Нажмите на пункт «PT - португальский», чтобы отобразить в Таблице перевода столбец для этого Языка.

§Наберите переводы для каждого элемента и, после окончания, закройте окно: ваша работа сохраняется автоматически.

§Установите «PT - Português» в качестве Язык контента: в окне Общие настройки.
Кликните, чтобы развернуть/уменьшить Как выполнить импорт и экспорт языка

Если разработку сайта вам нужно выполнять на двух компьютерах, на языке, не предоставляемом программой, можно выполнить экспорт нового языка, созданного на одном из компьютеров и импортировать его на другом.

§На первом компьютере нажмите кнопку Добавить новый язык чтобы открыть окно Управление языковым контентом. и начать перевод на новый язык.

§Выберите новый язык из списка возможных языков и нажмите на кнопку [image] Экспорт выбранного языка: файл *.XML для нового языка будет сохранен в указанной папке.

§Перенесите файл *.XML на другой компьютер.

§Откройте программу и перейдите в окно Управление языковым контентом.. Нажмите на [image] Импортировать новый язык для выбора файла *.XML для выполнения импорта.

Если импортируемые языки уже входят в список, они не дублируются. Новые элементы добавляются, а прежние - обновляются.

Лучшая практика:

-

Как создать многоязычный сайт


Как использовать сервис Google Webmaster Central™

Лучшая практика > Этап 1 - Общие настройки > Работа с Google >

Как использовать сервис Google Webmaster Central™

 Return to chapter overview

Google Webmaster Central™ это бесплатный сервис фирмы Google™, призванный помочь веб-администраторам в создании сайтов, и предлагающий методы анализа. Предоставляемые веб-инструменты помогают диагностировать проблемы на сайте, а при правильном применении также могут улучшить выдачу сайта в результатах поиска.

Чтобы использовать сервис Google Webmaster Central™, сначала нужно завести учетную запись в системе Google и подтвердить, что вы являетесь владельцем сайта, который нужно будет анализировать. Для такого подтверждения можно, например, вставить мета-тег, предоставляемый Google™, в первую секцию <head> главной страницы вашего сайта перед секцией <body> .

Для этого нужно сделать следующее:

§Заведите учетную запись в сервисе Google™.

§Зайдите на главную страницу Google Webmaster Central™ и войдите в систему.

§Нажмите Add a Site («Добавить сайт») на главной странице и введите полный URL-адрес добавляемого сайта. Нажмите Continue (продолжить).

§На странице Verification Page («Проверка сайта»).в качестве метода проверки выберите «Metatag» (мета-тег).

§Скопируйте мета-тег, предоставляемый Google™, и вставьте его в поле Мета-тег для распознавания в Google Webmaster Central в окне Общие настройки | Эксперт программы WebSite X5: программа поместит этот мета-тег в соответствующее место HTML-кода главной страницы.

§Проверочный мета-тег сервиса Google™ выглядит примерно так:

<meta name="verify-v1" content="VOPYsjbR4uw/YqV+MWLB0lVmJt0niwdkv9PQTsTREHQ=" />

§Разместив сайт в Интернете, зайдите на страницу Site Verification (Проверка сайта) сервиса Google Webmaster Central™ и нажмите Verify (Проверить), чтобы завершить процедуру проверки.


Как отслеживать работу сайта при помощи статистических сервисов, таких как Google Analytics™

Лучшая практика > Этап 1 - Общие настройки > Работа с Google >

Как отслеживать работу сайта при помощи статистических сервисов, таких как Google Analytics™

 Return to chapter overview

В Интернете можно найти немало инструментов для отслеживания статистических параметров сайтов, а одним из самых популярных является Google Analytics™. Этот бесплатный сервис предоставляет множество отчетов для отслеживания посещений сайта и их анализа. Google Analytics™ можно использовать как для простого анализа вроде подсчета числа посещений, так и для более сложного, такого как оценка эффективности рекламных кампаний, осуществляемых в рамках программы Google AdSense™.

Для использования сервиса Google Analytics™ нужно сообщить сервису Google, какой Сайт анализировать и какие Страницы отслеживать. Для этого в Страницы Сайта следует вставить специальный код Google.

Для этого нужно сделать следующее:

§Заведите учетную запись в сервисе Google™.

§Зайдите на домашнюю страницу Google Analytics™ и войдите в систему.

§На странице Analytics Settings («Настройки анализа») нажмите на ссылку Add website profile («Добавить сайт») и введите URL-адрес сайта, который нужно анализировать.

§После создания профиля перейдите на страницу Overview («Обзор») и нажмите кнопку Edit («Редактировать») в столбце Actions («Действия») сайта, который нужно анализировать.

§На странице Profile Settings («Настройки профиля») будет показываться статус "Unknown tracking" («Неизвестное отслеживание»). Нажмите на ссылку Status check («Проверка статуса»), чтобы отобразить код, который будет использован для отслеживания страниц сайта.

§Скопируйте этот код и вставьте в поле Пользовательский код в окне Общие настройки | Эксперт программы WebSite X5, задав, что код нужно добавить перед закрытием секции <head> .

Код, который Google™ использует для отслеживания статистики, выглядит примерно так:

<script type="text/javascript">

var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");

document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));

</script>

<script type="text/javascript">

try {

var pageTracker = _gat._getTracker("UA-110367-1");

pageTracker._trackPageview();

} catch(err) {}</script>


Как создать карту сайта SiteMap и ссылку на нее

Как создать карту сайта и ссылку на нее

Лучшая практика > Этап 1 - Общие настройки > Работа с Google >

Как создать карту сайта и ссылку на нее

 Return to chapter overview
Покажите/скройте невидемый текст

WebSite X5 может создать карту вашего сайта XML SiteMap.

SiteMap — это XML-файл, содержащий список всех страниц сайта. Использование такого файла было введено поисковой системой Google (теперь SiteMap также используется поисковыми системами Yahoo! и MSN) для более быстрой и эффективной индексации сайтов. Иначе говоря, если создать файл SiteMap и предоставить его веб-мастеру, то он сможет обеспечить индексацию поисковой системой (например, Google) сайта и всех его страниц, включая страницы, которые не могут быть найдены поисковыми роботами обычным способом.

Файл SiteMap также можно использовать для сообщения поисковой системе о необходимости индексации особого содержимого сайта, такого как видеозаписи, изображения, новости и т.д. Этот файл также может содержать дополнительную информацию о частоте обновления страниц, дате их последнего изменения и важности каждой страницы в рамках данного сайта (этот параметр не оказывает влияния на местоположение страницы в результатах поиска).

Кликните, чтобы развернуть/уменьшить Как активировать карту сайта

Для создания карты сайта (SiteMap) и получения ссылки на нее следует оставить включенным параметр Автоматически создать карту сайта (включен по умолчанию) в окне Общие настройки | Эксперт.

Теперь можно добавить дополнительную информацию о каждой странице, например:

§На этапе 2 — Создание карты сайта выбрать страницу, с которой вы хотите работать.

§Нажмите кнопку Свойства... для открытия окна Свойства страницы и перейдите в раздел Эксперт.

§Оставьте параметр Добавить эту страницу к карте сайта как есть (активным) и выберите Приоритет контента и Частота обновления.

§Повторите эту процедуру для всех страниц сайта.
Кликните, чтобы развернуть/уменьшить Как включить изображения в карту сайта

Карту сайта можно использовать для передачи поисковой системе Google дополнительной информации об изображениях, размещенных на сайте, тем самым помогая ей найти изображения, которые иначе не были бы индексированы (например, изображения, включенные в модули JavaScript), и распознать более важные изображения. Так, если не добавить на карту сайта те изображения, которые являются частью графического шаблона или используются исключительно для украшения страниц, то Google сочтет их менее важными, чем другие.

Google™ определяет максимум 1000 изображений, которые могут быть указаны на карте сайта. При этом индексация всех изображений и учет всей дополнительной информации не гарантируется.

Когда вы создали свою карту сайта, в нее нетрудно добавить информацию об изображениях:

§Дважды щелкните на Изображение объекта нужного изображения — откроется окно Изображение объекта.

§Откройте раздел Карта сайта и выберите команду Добавить изображение к карте сайта.

§Поля Заголовок, Заголовок, Местоположение (например, адрес, город и т.д.) и URL файла с лицензией являются необязательными.

§Повторите эту процедуру для всех важных изображений сайта.

Для получения дополнительной информации см. Изображение объекта | Карта сайта.
Кликните, чтобы развернуть/уменьшить Как включить видео в карту сайта

Карту сайта также можно использовать, чтобы сообщить поисковой системе Google™ о видеозаписях на вашем сайте. И снова, Google™ не дает никаких гарантий, однако включение видеозаписей в карту сайта повышает вероятность их индексирования и добавления в результаты поиска сервиса Google Video™.

Карту сайта можно использовать для добавления дополнительной информации, такой как название, описание и длительность видео, что может облегчить поиск. Эта и другая информация включается в страницы результатов поиска (Search Engine Results Pages, SERP). Однако Google™ при генерации страницы результатов поиска может использовать текст на странице с видео, а не текст, указанный для данной видеозаписи на карте сайта, если эти тексты не совпадают.

Добавить информацию о видео на карту сайта очень просто:

§Дважды щелкните на Аудио-видео объект нужной видеозаписи — откроется окно Аудио-видео объект.

§Откройте раздел Карта сайта и выберите параметр Добавить видео к карте сайта.

§Добавьте на карту сайта все обязательные данные: Заголовок, Заголовок и Картинка для предпросмотра видео.

§При желании можно добавить на карту сайта и следующие данные: Категория, Ключевые слова сайта, Дата публикации, Длительность (сек) и Контент, подходящий всем.

§Повторите эту процедуру для всех видеозаписей, которые нужно добавить на карту сайта.

Для получения дополнительной информации см. Аудио-видео объект | Карта сайта.
Кликните, чтобы развернуть/уменьшить Как удалить страницу из карты сайта

По умолчанию при создании карты сайта в нее вносятся все страницы сайта. Если вам не нужно, чтобы поисковые системы индексировали какую-то страницу, просто удалите ее из карты сайта:

§Выберите страницу, которую хотите исключить из карты сайта в окне на этапе 2 — Создание карты сайта.

§Нажмите кнопку Свойства... для открытия окна Свойства страницы и перейдите в раздел Эксперт .

§Отключите параметр Добавить эту страницу к карте сайта.

§Подтвердите и сохраните сделанные изменения.

Источники:

- | Карта сайта (en.wikipedia.org)
- | О карте сайта (Goggle WebMaster Central)
- | Добавление информации об изображениях к карте сайта (Google WebMaster Central)
- | Создание карты сайта для видео (Google WebMaster Central)


Как работать с шаблонами

Лучшая практика > Этап 1 - Общие настройки > Графические шаблоны >

Как работать с шаблонами

 Return to chapter overview
Покажите/скройте невидемый текст

С помощью программы WebSite X5 очень удобно работать с графическими шаблонами (это основа вашего сайта), потому что они очень гибкие и легкие в применении. Благодаря готовым шаблонам с обширными возможностями настройки и, более того, возможности самим создавать свои шаблоны, можете быть уверены, что получите именно такой внешний вид сайта, как вам хочется.

Можно импортировать и экспортировать шаблоны (извлекая их из проектов, для которых они изначально создавались), и это невероятно упрощает обмен ресурсами.

Кликните, чтобы развернуть/уменьшить Как использовать готовый шаблон

WebSite X5 предоставляет галерею из более 1.500 готовых шаблонов. Выбрать один из них, самый подходящий для вас, просто:

§Откройте окно Выбор шаблона и отфильтровать по типу меню , который вас интересует (горизонтальное или вертикальное).

§Посмотрите шаблоны с помощью предварительного просмотра, чтобы выбрать лучший.

§Выберите шаблон, с которым собираетесь работать и нажмите на кнопку Далее чтобы применить его к своему проекту, затем откройте Редактировать шаблон где можно добавить элементы к верхней и нижней секциям страницы.
Кликните, чтобы развернуть/уменьшить Как настроить свой шаблон

Если вы создали шаблон с помощью внешнего графического редактора, его можно применить к вашему проекту в WebSite X5 в качестве собственного шаблона:

§Откройте окно Выбор шаблона и используйте фильтр для категорий , чтобы показать только собственные шаблоны.

§В списке будет, как минимум, один шаблон. Можно выбрать его и нажать на кнопку Редактировать... (или дважды щелкнуть на шаблоне), чтобы открыть окно Настроить шаблон.

§Если же вы решили создать свой шаблон с нуля, чтобы затем добавить его в галерею, нажмите на кнопку Новый шаблон: задайте имя новому шаблону и начинайте работать над ним.

Все созданные пользователем шаблоны добавляются к галерее шаблонов. Их можно использовать в проектах.
Кликните, чтобы развернуть/уменьшить Как создать новый шаблон на основе готового шаблона

Часто готовый шаблон - хорошее начало для создания собственного шаблона, если вас в целом устраивает макет, но вы хотите привнести какие-то свои собственные идеи. Для этого нужно сделать следующее:

§Откройте окно Выбор шаблона и используйте фильтры, чтобы определить и выбрать готовый шаблон, с которого вы хотите начать.

§Нажмите на кнопку Сделать копию , чтобы создать копию шаблона: эта копия сохраняется среди готовых шаблонов.

§Выберите копию, которую вы только что создали и нажмите кнопку Далее, чтобы открыть окно Настроить шаблон, где можно выполнить необходимые изменения.
Кликните, чтобы развернуть/уменьшить Как выполнить импорт и экспорт шаблона

Можно выполнить экспорт шаблона проекта, чтобы его затем можно было использовать на другом компьютере или другим людям.

Чтобы выпонить экспорт шаблона:

§Откройте окно Выбор шаблона, выберите шаблон и нажмите кнопку Экспорт...: в указанной для экспорта папке создается файл *.IWTLP.

§Скопируйте этот файл .IWTLP на компьютер, на котором хотите выполнить импорт шаблона.

Чтобы выполнить импорт экспортированного шаблона с помощью программы WebSite X5:

§Откройте окно Выбор шаблона на втором компьютере и нажмите кнопку Импорт... : выберите файл .IWTPL из файлов для импорта.

§Импортированный шаблон будет добавлен к списку пользовательских шаблонов.

Файлы .IWTLP содержат только изображения и настройки для относительных шаблонов: при экспорте они не содержат информации о проекте.

Для экспорта проекта нужно использовать команды на Этапе 5 - Экспорт сайта.

Лучшая практика:

-

Где можно найти новые шаблоны для программы WebSite X5


Где можно найти новые шаблоны для программы WebSite X5

Лучшая практика > Этап 1 - Общие настройки > Графические шаблоны >

Где можно найти новые шаблоны для программы WebSite X5

 Return to chapter overview

Если требуется новый шаблон для создания или изменения оформления Сайта, в разделе Шаблоны WebSite X5 официального сайта WebSite X5 по адресу http://answers.websitex5.com/templates можно найти множество интересных идей.

Раздел «Шаблоны WebSite X5» (WebSite X5 Templates) содержит немало новых графических шаблонов, созданных фирмой Incomedia и пользователями программы WebSite X5. Среди шаблонов есть как бесплатные, так и платные (как правило, недорогие). Можно загрузить их и использовать в своих проектах.

Вы и сами можете помочь нам в пополнении нашей библиотеки шаблонов. Если веб-дизайн — Ваше призвание, почему бы не поделиться с нами некоторыми шаблонами? Более подробная информация дается здесь: http://answers.websitex5.com/templates.

Советуем регулярно посещать раздел «Шаблоны WebSite X5», чтобы узнавать, что нового там появилось. Можете также подписаться на RSS-ленту, чтобы всегда быть в курсе событий.


Как создать карту сайта и работать с ней

Лучшая практика > Этап 2 - Создание карты сайта >

Как создать карту сайта и работать с ней

 Return to chapter overview
Покажите/скройте невидемый текст

На Карте Сайта программы WebSite X5 представлена типичная древовидная структура сайта. Она всегда начинается с Домашней Страницы, ниже которой могут располагаться отдельные Страницы (в случае сайта с простой структурой) или группы связанных Страниц, организованных по Уровням. На любом сайте есть главная страница и различное количество других страниц, доступных по ссылкам через меню. По мере добавления страниц вы организуете их на разных уровнях меню.

Имейте в виду, что уровни в WebSite X5 это просто категории, а не страницы с контентом. Уровни содержат страницы.

У разделителей контента нет. Они используются для визуальной организации меню навигации по сайту.

Кликните, чтобы развернуть/уменьшить
Пример карты и соответствующего меню

При составлении карты сайта ваша задача - создать логическую структуру содержимого сайта, чтобы посетители легко могли найти нужную информацию.

Кликните, чтобы развернуть/уменьшить Как создать карту сайта

Создание и развитие карты сайта в программе WebSite X5 очень просто:

§В окне на этапе 2 — Создание карты сайта используем кнопки Новый уровень, Новая страница и Разделитель для добавления новых уровней, страниц и разделителей на свою карту.

§Выбирать имена для элементов карты нужно внимательно: эти имена появятся в меню навигации по сайту и в виде имен файлов. Если нужно переименовать элемент, дважды щелкните по нему или нажмите на кнопку Переименовать.

§Карту можно редактировать в любое время, перемещая страницы, уровни и разделители: выбираем элемент, который надо передвинуть, и тащим его мышкой в новое положение. Или можно использовать кнопки Сдвинуть вверх / Сдвинуть вниз.
Кликните, чтобы развернуть/уменьшить Как работать с картой сайта (команды и клавиатурные сокращения)

Есть несколько клавиатурных сокращений для удобства быстрой работы с картой сайта:

§Нажмите второй раз на выбранный уровень, страницу (включая главную) или разделитель, чтобы переименовать их (вместо нажатия кнопки Переименовать). Еще можно переименовывать псевдонимы специальных страниц в папке Меню, но не сами специальные страницы.

§После выбора страницы нажмите на Подробный заголовок или Описание , чтобы изменить их текст (либо можно отредактировать его в окне Свойства страницы).

§Можно дважды щелкнуть по уровню, чтобы развернуть его и посмотреть все страницы на этом уровне. А затем снова дважды щелкнуть, чтобы свернуть его (так быстрее, чем нажимать кнопки Развернуть и Свернуть). Уровень также можно разворачивать и сворачивать нажимая на стрелку напротив его названия.

§Дважды щелкните на странице, чтобы открыть окно Создание Страниц, где можно создать страницу.

§Дважды щелкните на специальной странице, чтобы открыть окно Этап 4 - Расширенные настройки, где можно создать или отредактировать такую страницу.

§Выберите уровень и перетащите его в новое положение, перенося вместе с ним все страницы (вместо того, чтобы нажимать на кнопки Сдвинуть вверх / Сдвинуть вниз ).

§Выберите одну или несколько страниц и перетащите их в новое положение (вместо того, чтобы нажимать на кнопки Сдвинуть вверх / Сдвинуть вниз ). Используйте сочетания клавиш CTRL + нажатие и SHIFT + нажатие для выбора нескольких объектов. Объекты могут включать в себя скрытые или закрытые страницы.

§Выберите папку Меню и скройте меню навигации по сайту, нажатием кнопки Скрытая страница в меню.

§Выберите специальную страницу и перетащите ее в папку Меню (к страницам и уровням, которые составляют меню навигации по сайту), так вы создадите уровень, который работает как псевдоним для специальной страницы. Этот уровень будет иметь такое же имя, как специальная страница и содержать ссылку на нее. Таким способом вы создаете ссылку в меню, которая сразу приводит на страницу результатов поиска по сайту (с помощью встроенного механизма), страницу приветствия, блог, защищенную область сайта или в Корзину.

§Выберите одну или несколько страниц и сможете копировать их и вставлять на новом месте в этом или другом проекте, открытом в другом окне программы. Можно использвать команды на панели инструментов, в выпадающем меню (по нажатию правой кнопки мыши) или клавиатурные сокращения CTRK+C и CTRL+V. Не забудьте, что нельзя копировать и вставлять специальные страницы.


Как создать страницу, используя шаблоны страниц

Как создать страницу, используя таблицу макета страницы

Лучшая практика > Этап 3 - Создание Страниц >

Как создать страницу, используя таблицу макета страницы

 Return to chapter overview
Покажите/скройте невидемый текст

WebSite X5 использует уникальный метод разработки макета страницы, где вы сразу видите внешний вид страницы, над которой работаете.

Страница отображается в виде таблицы, где можно задать количество строк и столбцов, в ячейках которой и размещается разнообразный контент.

Объекты, составляющие содержимое ячеек, можно легко перетаскивать мышкой в ячейки.

Кликните, чтобы развернуть/уменьшить Справка: Как настройить таблицу макета страницы

По умолчанию таблица состоит из 2 строк и 2 столбцов, но вы можете создавать новые строки и столбцы таким образом, чтобы у вас хаватало ячеек для всего контента. А потом вы добавляете объекты нужного типа в ячейки.

Используйте кнопки [image] [image] на панели инструментов, чтобы добавлять строки и столбцы. МАксимально в таблице может быть до 64 строк и до 12 столбцов.

По умолчанию все строки и столбцы Таблицы Макета Страницы имеют одинаковую высоту и ширину. Можно изменить ширину столбца, выраженную как абсолютное (в пикселах) или относительное (в процентах) значение, перетаскивая указатели внизу Таблицы налево или направо.

§Для изменения ширины столбца нажмите на указатель и перетащите его. Перемещение происходит на свободном пространстве шагами по 10 пиксел. Для получения большей точности нажмите клавишу CTRL при смещении линии с шагом в 1 пиксел.

Кликните, чтобы развернуть/уменьшить

§Нажмите на указателе правую кнопку мыши и выберите во Всплывающем Меню опцию Задать Ширину Столбца, чтобы ввести ширину столбца в пикселах.

Кликните, чтобы развернуть/уменьшить

§Нажмите на указателе правую кнопку мыши и выберите во всплывающем меню опцию Сбросить Ширину Столбцов, чтобы вернуть используемую по умолчанию одинаковую ширину столбцов.
Кликните, чтобы развернуть/уменьшить Справка: Как добавлять контент в таблицу макета страницы

После того, как вы задали размер таблицы макета страницы, можно ввести контент страницы, добавляя объекты в ячейки. Чтобы разместить Объект на Странице, выделите его значок в списке Доступных Объектов и перетащите этот значок в нужную Ячейку Таблицы Макета Страницы.

В каждую Ячейку Таблицы Макета Страницы можно вставить не более одного Объекта. Однако Объект может занимать как одну Ячейку, так и несколько Ячеек (по горизонтали и по вертикали). Как вариант, можно потянуть значок за «ручку» (используемую для изменения его размеров) так, чтобы он увеличился и занял больше одной Ячейки. Объекты можно даже перетаскивать в подходящие ячейки.

Если Объект, занимающий больше одной Ячейки, нужно переместить на другое место на Странице, то размер Объекта (число занимаемых Ячеек) при этом сохраняется, если это не мешает другим Объектам. Возможно, для работы с Макетом Страницы будет удобнее использовать клавиши со стрелками:

§клавиша со стрелкой — нажатие такой клавиши позволяет выбрать другую Ячейку Таблицы Макета Страницы.

§CTRL + клавиша со стрелкой — использование такого сочетания клавиш перемещает выбранный Объект из одной Ячейки в другую (с сохранением его размера).

§SHIFT + клавиша со стрелкой — использование такого сочетания клавиш изменяет размер выбранного Объекта при его перемещении по Ячейкам; Объект увеличивается или уменьшается в зависимости от того, содержат ли другие Ячейки какие-то Объекты.

Если щелкнуть правой кнопкой мыши по значку Объекта в Ячейке или по пустой Ячейке, то откроется Всплывающее Меню со следующими командами: Вырезать, Копировать, Вставить, Удалить, Стиль Ячейки, Вставить Строку, Вставить Столбец, Удалить Строку и Удалить Столбец .

Эти команды позволяют, например, скопировать Объект в одной Ячейке и вставить его в другую Ячейку (или на другую Страницу) или удалить Объект из Ячейки. Можно удалять объект, перетащив его за пределы таблицы макета страницы, или нажав клавишу DEL. Чтобы удалить Объект, можно также перетащить его за пределы Таблицы Макета Страницы или выбрать этот Объект и нажать клавишу DELETE. Если вставить Объект в Ячейку, уже содержащую другой Объект, то старый Объект будет автоматически удален и замещен новым.

Команды Скопировать стиль и Вставить стиль в подменю Стиль ячейки команды позволяют применить настройки, заданные в окне Стиль ячейки для одной Ячейки, к другой Ячейке.

После вставки Объекта в Ячейку можно настроить содержимое этого Объекта. (Текстовый объект, Изображение объекта, Объект таблица, Объект в галерее, Аудио-видео объект, Объект-форма обратной связи, Объект гостевая книга, Объект социальной сети, , Объект Flash-анимации, Объект список товаров, Объект HTML и виджеты), Для этого нужно либо сделать двойной щелчок по Ячейке, содержащей Объект, либо выбрать Объект и нажать кнопку [image] Содержимое Объекта.

Необязательно заполнять все Ячейки Таблицы Макета Страницы. Однако не следует забывать, что пустая ячейка соответствует пустому месту на готовой Странице.

Чтобы наиболее эффективно использовать возможности по компоновке страницы, важно понимать, как работает Программа:

§Ширина Страницы определяется Шаблоном.

§Ширина столбца Таблицы Макета Страницы получается делением ширины страницы на число вставленных столбцов. По умолчанию все столбцы имеют одинаковую ширину, но при желании это можно изменить.

§Все Ячейки в строке Таблицы Макета Страницы имеют одинаковую высоту. Высота Ячейки определяется высотой самого большого Объекта в этой строке.

§Размеры вставленных Объектов автоматически подгоняются под размеры соответствующих Ячеек Таблицы Макета Страницы.

Родственные темы:

-

Блочная модель WebSite X5


Как работать в Стиль ячейки

Лучшая практика > Этап 3 - Создание Страниц >

Как работать в Стиль ячейки

 Return to chapter overview
Покажите/скройте невидемый текст

Если вы работаете в Создание Страниц и перетащили объект в ячейку таблицы раскладки страницы, то вы можете задать стиль этой ячейки, нажав на [image] кнопку и используя параметры в окне Стиль ячейки.

Кликните, чтобы развернуть/уменьшить Как создать фоновое изображение, чтобы оно подходило по размерам ячейки

Стиль ячейки можно настроить различными способами: можно импортировать изображение (файл в формате JPG, GIF или PNG) и использовать его в качестве фона для ячейки. В зависимости от типа изображения, которое вы импортировали, можно выбрать параметр Фоновое изображение и задать настройки для параметров Положение и Выравнивание или использовать параметр Подогнать к Фону Ячейки чтобы получить наилучший результат.

Пример 1

Размер импортированного изображения совпадает с размером ячейки.

Фон: Фоновое изображение

Положение: Без повтора

Выравнивание: С левого верхнего угла

Кликните, чтобы развернуть/уменьшить

Пример 2

Импортированное изображение не является паттерном: у него нет горизонтальной или вертикальной точки схождения по которой два или более одинаковых изображений можно было бы разместить встык.

Фон: Фоновое изображение

Положение: Повторять в обоих направлениях

Выравнивание: С левого верхнего угла

Кликните, чтобы развернуть/уменьшить

Пример 3

Импортированное изображение - это рамка, которая легко приспосабливается к изменению размеров.

Фон: Подогнать к Фону Ячейки

Ширина блока / Высота блока: задайте наилучший размер для блоков.

Кликните, чтобы развернуть/уменьшить

Для того, чтобы лучше понять, как работает параметр Подогнать к Фону Ячейки, что такое блоки и как задать правильные размеры, изучите следующие рисунки:

Рисунок 1 | Рисунок 2 | Рисунок 3

Исходное изображение (Рис. 1) это обрамляющая рамка, которую можно легко разделить на блоки и приспособить к любым размерам: украшения по углам - фиксированного размера, а растушевку можно повторять как паттерн без резких цветовых переходов.

На рисунке 2 видны блоки, размеры которых должны быть жестко заданы (с помощью параметров Ширина блока и Высота блока). Ширина и высота одинаковые для всех блоков и заданы в процентах от исходного изображения: соотношение может изменяться от 5% до 45%. В этом примере изображение и по вертикали и по горизонтали обрезано на уровне 35%: это значение гарантирует, что в каждом из блоков есть уголок.

Рисунок 3 показывает как можно из исходных блоков A, B, C и D получить 5 других блоков - a,b,c,d и е: на такие блоки программа нарезает изображение, чтобы получить все части картинки, составляющей полный фон ячейки. Блоки A, B, C и D остаются неизменными и размещаются по углам ячейки, а другие пять блоков - a,b,c,d и e - повторяются, чтобы заполнить оставшееся пространство.

Следовательно, такое заполнение фона ячейки очень удобно применять для одной и той же картинки и ячеек разных размеров.

Кликните, чтобы развернуть/уменьшить Как пользоваться библиотекой стилей ячеек

С помощью библиотеки вы можете сэкономить время: если нужно применить один и тот же стиль к нескольким ячейкам, можно задать его для одной ячейки, сохранить стиль и потом применить его к другим ячейкам.

Чтобы создать новый стиль:

§В таблице раскладки страницы выберите ячейку, с которой собираетесь работать и нажмите на [image] кнопку, чтобы открыть окно Стиль ячейки.

§Используйте параметры в разделах Стиль и Текст для получения такого вида, который вас устраивает.

§Откройте раздел Библиотека и нажмите на кнопку Добавить: по вашим настройкам создается новый стиль. Изображение для предварительного просмотра стиля, который вы только что создали, добавляется к списку стилей Пользовательский.

Чтобы применить стиль к ячейке:

§В таблице раскладки страницы выберите ячейку, с которой собираетесь работать и нажмите на [image] кнопку, чтобы открыть окно Стиль ячейки.

§Перейдите к разделу Библиотека и выберите изображение предварительного просмотра стиля, который хотите применить из списка стилей Заводские настройки или из стилей списка Пользовательский.

§Нажмите на кнопку Применить.

Родственные темы:

-

Блочная модель WebSite X5


Как создать многоязычный сайт

Лучшая практика > Этап 4 — <%S4_MAP_LBLWIZTITLE%>. >

Как создать многоязычный сайт

 Return to chapter overview
Покажите/скройте невидемый текст

Интернет стирает государственные границы и вполне возможно, что на Сайт будут заходить посетители из других стран. Поэтому иногда имеет смысл делать многоязычные сайты.

Добавление дополнительных языков может усложнить Проект Сайта, однако программа WebSite X5 значительно облегчает задачу, предоставляя удобный набор инструментов. Разумеется, для профессионального Сайта потребуется качественно переведенный текст.

Прежде всего, нужно отметить, что программа WebSite X5 генерирует все HTML-файлы Страниц Сайта, используя кодировку UTF-8 (Unicode Transformation Format, 8 bit), для полноценной поддержки всех языков, включая те, что используют алфавит не на основе латинского, например, греческий, кириллица, армянский, иврит, арабский, китайский, японский и корейский. Помимо создания Сайта на любом языке, на одном и том же сайте можно использовать разные языки безо всяких проблем с правильным отображением букв и символов из разных алфавитов. Например, на странице можно разместить русский текст, а рядом с ним — английский перевод.

При создании Сайта программа WebSite X5 позволяет связать основной (используемый по умолчанию) язык с Проектом (выберите опцию Язык контента: в окне Общие настройки | Основной). Это важно сделать для правильной обработки текста, автоматически вставляемого Программой. В программе WebSite X5 по умолчанию включена поддержка нескольких языков. Если какой-то язык еще не включен в список языков, откройте окно Управление языковым контентом. и нажмите кнопку [image] для того, чтобы создать или импортировать другие языки или изменить слова в уже доступных языках (см. Как автоматически переводить вводимый текст).

Также можно сделать многоязычный сайт и предложить посетителю выбрать один из нескольких языков. Всё, что для этого требуется, это создать Проект Сайта для каждого языка и связать их вместе, как будто это разделы одного сайта. Это можно сделать двумя способами: либо используя Страницу Приветствия, либо добавив кнопки выбора языка в Заголовок Шаблона.

Кликните, чтобы развернуть/уменьшить Как создать Многоязычный Сайт, используя Страницу Приветствия

Представим себе, что нам нужно создать Сайт с тремя языками: английским, итальянским и португальским. Программа WebSite X5 позволяет легко добавить переключатель языка на Страница приветствия , которую посетитель видит до открытия Домашней Страницы.

§Сначала рассмотрим создание английской версии сайта, зададим структуру и контент, и в Общие настройки | Основной определим "EN = English" в качестве Язык контента:.

§Перейдя к Этапу 4 - Расширенные настройки, нажмите кнопку Страница приветствия и в открывшемся окне выберите опцию Показывать страницу приветствия , задав изображение или анимацию для применения в качестве Фон страницы и выполним все необходимые настройки для получения желаемого стиля.

§Нажмите на Показывать ссылки на другие языки для создания кнопки выбора языков.

§Используйте возможные команды для создания Список языков. Выберите в качестве недоступных языков «Deutsch», «Español» и «Français» и нажмите кнопку Удалить . Нажмите кнопку Добавить..., чтобы открыть окно Языковые настройки и добавить португальский язык. Введите слово «португальский» в поле Отображение названия языка и выполните импорт файла с изображением, связанным с ними (часто это национальный флаг).

§Теперь выберите в Списке «английский» и «итальянский» языки и нажмите кнопку Редактировать..., чтобы открыть окно Языковые настройки и добавьте изображение флага для этих языков.

§Поскольку текущий проект содержит английскую версию (с которой и будет связана Страница Приветствия), выберите в Список языков «английский» язык и нажмите кнопку По умолчанию.

§Порядок языков в Списке Языков можно изменить, используя кнопки Сдвинуть Вверх и Сдвинуть Вниз .

После добавления изображений флагов, нужно создать ссылки на них. Сайт создается для каждого языка и публикуется в Интернет, так что можно создать ссылку с адресом URL:

§В окне Список языков выберите «Italiano» язык и нажмите кнопку Редактировать..., чтобы открыть окно Языковые настройки.

§Нажмите на [image] кнопку для параметра Ссылка для данного языка (например, показать сайт на этом языке), а затем выберите Файл или URL в окне Ссылка и введите адрес URL для своего сайта на итальянском, например, http://www.mywebsite.ru/it/index.html, если вы собираетесь опубликовать сайт на итальянском, на сервере создается подпапка «it».

§Повторите те же действия для создания сайта на португальском, создав ссылку на нее по адресу, например, http://www.mywebsite.ru/pt/index.html, если вы собираетесь опубликовать сайт на португальском, на сервере создается подпапка «pt».

Теперь посетитель Сайта сможет выбрать один из доступных языков, однако еще предстоит добавить содержимое на итальянском или португальском языках.

§Чтобы сэкономить время при создании итальянского Сайта, можно использовать копию английской версии. Для этого в первом окне Выбор проекта выберите проект сайта на английском и нажмите кнопку Сделать копию . Затем нажмите кнопку Переименовать для смены названия нового проекта на итальянском.

§Откройте копию проекта и в Общие настройки | Основной, установите «IT - Italian» в качестве Язык контента:: переведите все тексты и другие элементы, которые зависят от языка.

§Перейдя к Этапу 4 - Расширенные настройки, перейдите к окну Страница приветствия и снимите выделение с параметра Показывать страницу приветствия.

§Когда вы завершите проект на итальянском, сделайте то же самое для своего сайта на португальском.

Следуйте инструкциям по загрузке Сайтов на Сервер:

§Загрузка английской версии Сайта — помните, что Страница Приветствия связана с используемой по умолчанию английской версией Сайта. После загрузки на хостинг-сервер английской версии Сайта создается файл index.html, соответствующий Странице Приветствия, который сохраняется в папке по умолчанию (т. е. в папке «EN»). Также создаются подпапки для остальных языков, включенных в Список Языков (в данном случае, «IT» для итальянской версии и «PT» для португальской версии).

После загрузки на Сервер английской версии Сайта, он будет доступен для посетителей. Все кнопки переключения языка на Странице Приветствия будут активны, хотя пока будет работать только кнопка с английским флагом.

§Загрузка итальянской версии Сайта — кнопка с итальянским флагом заработает после загрузки файлов итальянской версии Сайта в подпапку «IT» на Хостинг-сервере.

§Загрузка португальской версии Сайта — кнопка с португальским флагом заработает после загрузки файлов португальской версии Сайта в подпапку «PT» на Хостинг-сервере.

После того, как все три версии загружены в свои папки на Сервере, посетители Сайта смогут использовать все кнопки переключения языка на Странице Приветствия.

Можно использовать параметр Ссылка для данного языка (например, показать сайт на этом языке) в окне Языковые настройки, чтобы ассоциировать любое из действий с изображением, представляющим различные языки (обычно это национальный флаг). Это означает, что вместо того, чтобы иметь ссылку на весь сайт, как мы видели в примере, можно дать ссылку лишь на одну страницу или сообщение, чтобы сказать, что сайт на определенном языке еще не доступен, но скоро будет, или на документ PDF, где размещена вся информация на нужном языке, или что-то другое.
Кликните, чтобы развернуть/уменьшить Как создать Многоязычный Сайт, используя кнопки в Заголовке Шаблона

Попробуем создать воображаемый Сайт с тремя языками: английским, итальянским и португальским. Как вариант (или как дополнительный способ выбора языка), можно предоставить посетителям выбор предпочитаемого языка, используя соответствующие кнопки в Заголовке Шаблона Сайта (а не только на Страница приветствия). Этот способ хорош тем, что позволяет сменить язык в любое время и с любой Страницы Сайта.

§Сначала рассмотрим создание английской версии Сайта, а потом перейдем к итальянской и португальской версиям. Общие настройки | Основной определим «EN = English» в качестве Язык контента:.

§Откройте окно Редактировать шаблон для работы с заголовком сайта и создайте кнопки, чтобы посетители могли выбрать язык, который они могут использовать.

§Нажмите кнопку [image] Вставить изображение, чтобы импортировать файл [flag_en.jpg], содержащий картинку с английским флагом. Если нужно добавить эффект для наведения курсора мыши на кнопку, можно использовать опцию Файл изображения, отображаемого при наведении мыши, чтобы импортировать файл [flag_b_en.jpg] , содержащий вторую картинку, немного отличающуюся от первой.

§Повторите эту процедуру для создания кнопок для итальянского и португальского флагов.

§Сейчас создается английская версия, поэтому выберите кнопку с итальянским флагом и нажмите кнопку [image] Вставить ссылку на этот объект Ссылку. В открывшемся окне Ссылка выберите Файл или URL, а затем выберите Файл в Интернет и введите адрес Домашней Страницы итальянского Сайта после публикации в Интернете (например, http://www.mywebsite.ru/it/index.html).

§Повторите эти действия, чтобы создать кнопку с португальским флагом и связать ее с адресом http://www.mywebsite.ru/pt/index.html).

Поскольку работа ведется над Проектом английского Сайта, нет необходимости создавать ссылку на кнопку с английским флагом.

§Чтобы сэкономить время при создании итальянского Сайта, можно использовать копию английской версии. Для этого в первом окне Выбор проекта выберите проект сайта на английском и нажмите кнопку Сделать копию. Затем нажмите кнопку Переименовать для смены названия нового проекта на итальянском.

§Откройте копию проекта и в окне Общие настройки | Основной установите «IT - Italian» в качестве Язык контента:: переведите все тексты и другие элементы, которые зависят от языка.

§Перейдите к окну Редактировать шаблон и завершите привязку кнопки или флага: английскому флагу назначьте ссылку на относительный адрес URL (например, http://http://www.mywebsite.ruen/index.html. Удалите ссылку с кнопки с итальянским флагом.

§Когда вы завершите работу над итальянским сайтом, сделайте то же самое для сайта на португальском. Не забудьте поставить ссылки на кнопки для английского и итальянского языков и удалите все ссылки на португальский.

Кнопки выбора языка будут работать лишь после загрузки всех трех версий Сайта на Хостинг-сервер.

§Создайте две подпапки в основной папке Сайта на Хостинг-сервере и назовите их IT и PT.

§Опубликуйте проект на английском (основной, язык по умолчанию) в главную папку на сервере, а проесты для итальянского и португальского сайтов, соответственно, в подпапки «it» и «pt».

Лучшая практика:

-

Как автоматически переводить вводимый текст


Как управлять комментариями через панель управления

Как управлять комментариями в блоге и гостевой книге с помощью панели управления

Лучшая практика > Этап 4 — <%S4_MAP_LBLWIZTITLE%>. >

Как управлять комментариями в блоге и гостевой книге с помощью панели управления

 Return to chapter overview
Покажите/скройте невидемый текст

Блог — это разновидность интернет-дневника, где можно размещать сообщения на любые темы, предоставив возможность посетителям комментировать их. Набрав активное сообщество путем размещения разнообразных сообщений, можно развернуть интересные обсуждения.

Кликните, чтобы развернуть/уменьшить Как настроить управление сообщениями в WebSite X5

Если вы хотите, чтобы посетители могли оставлять комметарии к вашим сообщениям, нужно настроить блог с помощью параметров в окне Блог | Комментарии:

§Выберите параметр Разрешить посетителям вашего блога оставлять комментарии.

§Введите полный путь к папке Папка на сервере с правами на запись, в которую PHP-скрипт может производить запись данных.

§Для добавляемых комментариев можно включить анти-спам фильтр CAPTCHA («капча»).

§Введите электронный адрес Адрес электронной почты пользователя, на который будут автоматически доставляться письма, уведомляющие о каждом новом комментарии, оставленном посетителями.

§Укажите, должны ли комментарии сразу публиковаться или проходить предварительную модерацию.

После этого можно приступить к добавлению сообщений и публикации блога. Внизу каждого сообщения автоматически размещается форма для добавления и отправки комментариев. Форма запрашивает имя, электронный адрес, сайт, и текст комментария. Все поля, кроме сайта - обязательные.
Кликните, чтобы развернуть/уменьшить Как управлять комментариями через панель управления

Если вы настроили свой блог на премодерирацию, когда посетитель оставляет комментарий, на электронный адрес администратора сайта приходит уведомление о новом комментарии. Если выбран вариант Отображать комментарии после одобрения администратором, то администратор должен разрешить публикацию комментариев прежде, чем они появятся в Интернет. В программе WebSite X5 есть для этого команда на панели управления.

Панель управления находится по адресу http://www.mywebsite.ru/admin (где http://www.mywebsite.ru URL-адрес сайта, с которым связан блог). Все пользователи, состоящие в группе администраторов, имеют доступ к панели управления (см. раздел Управление доступом на этапе 4 — Расширенные настройки.

В разделе «Блог» панели управления есть два развертывающихся меню, где показывается список категорий и список связанных с ними сообщений. Можно выбрать сообщение, комментарии к которому вы хотите просмотреть. В списке комментариев показывается автор комментария, его электронный адрес, а также дата и время комментария. Если посетитель указал адрес своего сайта, то этот адрес автоматически становится ссылкой.

Для управления комментариями нужно сделать следующее:

§Перейдите на панель управления, войдите в систему и откройте раздел блог.

§В развертывающихся меню категорий и сообщения выберите сообщение, комментарии к которому хотите просмотреть.

§Просмотрите список комментариев и для управления ими используйте следующие команды:

-Удалить: для удаления комментария: комментарий не будет опубликован в блоге и будет удален из списков комментариев на панели управления.

-Одобрить/Не одобрить одобренный комментарий будет опубликован в блоге; неодобренный комментарий будет удален из списка сообщений в блоге, но останется в списках на панели управления.

Чрезвычайно важно проверять комментарии до их опубликования в блоге, чтобы защититься от спама и оскорбительных, посторонних или неуместных по иным причинам комментариев.


Как задать содержание для подтверждения заказа по электронной почте

Создание электронного письма подтверждения Заказа

Лучшая практика > Этап 4 — <%S4_MAP_LBLWIZTITLE%>. > Корзина для электронной коммерции >

Создание электронного письма подтверждения Заказа

 Return to chapter overview

Если клиент заказывает товар, имеет смысл отправить ему электронное письмо, подтверждающее получение его Заказа и содержащее необходимую информацию об оплате.

На основе данных Заказа программа WebSite X5 автоматически генерирует электронное письмо для его подтверждения.

Это электронное письмо выглядит следующим образом:

Вводный текст
Описание: | Это текст в начале электронного письма. Это вводный абзац, где клиента благодарят за покупку и кратко излагают содержимое письма.
Пример: | Уважаемый покупатель! Благодарим Вас за то, что обратились именно к нам! Ниже Вы найдете краткое описание своего заказа, включая Ваши покупки, данные счета-фактуры, транспортные данные и выбранный Вами способ оплаты.
Где задается информация: | В Корзина | Отправить заказ, в разделе Текст 'шапки' страницы письма.
Данные Клиента
Описание: | Здесь повторяются данные счета-фактуры, введенные Клиентом в Форме Заказа.
Где задается информация: | Форму Заказа можно настроить в разделе Корзина | Данные покупателя.
Краткое Описание Заказа
Описание: | В этой таблице перечисляются заказанные Товары и приводятся количество каждого Товара, частичные суммы и общая сумма Заказа.
Где задается информация: | Эта таблица автоматически генерируется для Заказа.
Тип Оплаты
Описание: | В этом разделе Клиенту даются точные инструкции по оплате согласно выбранного способу оплаты.
Пример: | Для «банковского перевода»: Получателем денег выступает: XXX YYY ZZZ После совершения оплаты, пожалуйста, отправьте нам Номер Заказа и копию документа, подтверждающего банковский перевод.
Где задается информация: | Раздел E-mail сообщение окна Вид оплаты.
Тип Доставки
Описание: | Здесь указывается выбранный способ доставки. По возможности, приводятся сведения о дате и подробностях доставки, а также прочая полезная информация.
Пример: | Для «Службы Срочной Доставки»: Доставка Службой Срочной Доставки. Товары будут доставлены в течение 1-2 рабочих дней.
Где задается информация: | Раздел E-mail сообщение окна Тип доставки.
Завершающий текст
Описание: | Стандартный абзац для завершения делового письма.
Пример: | Пожалуйста, обращайтесь к нам по любым вопросам касательно заказа. С уважением, Название Фирмы
Где задается информация: | Опция Корзина | Отправить заказ раздела Текст 'подвала' страницы письма.

Как и в случае прочих электронных писем, автоматически генерируемых и отправляемых Программой, графическое оформление письма подтверждения Заказа настраивается в разделе Стили и модели | E-mail.

Также отправляется копия письма подтверждения Заказа в виде неформатированного текста.

Лучшая практика:

-

Как делать импорт и экспорт товаров в Корзине


Как делать импорт и экспорт товаров в Корзине

Лучшая практика > Этап 4 — <%S4_MAP_LBLWIZTITLE%>. > Корзина для электронной коммерции >

Как делать импорт и экспорт товаров в Корзине

 Return to chapter overview

После создания Корзины может быть полезным выполнить экспорт каталога товаров для использования его в другом проекте или с другой программой, например, для бухучета. Еще важна возможность импортировать каталог товаров, чтобы вам не пришлось его создавать заново с самого начала.

В программе WebSite X5 можно выполнять импорт и экспорт каталога товаров с помощью окна Корзина | Товары. При экспорте каталога товаров создается файл в формате *.TXT или *.CSV, который можно легко открыть в любом текстовом редакторе (например, в Блокноте) или в Microsoft Excel.

Следуйте дальнейшим указаниям, если вы вручную редактируете экспортированный файл каталога товаров или создаете новый, чтобы его импортировать:

§Первая строка должна содержать заголовки полей со следующими названиями:

ID;Category;Name/Code;Description;Price;Enable VAT;VAT Value;Weight;Options;Enable Discounts;Discounts

§Если вы удаляете поле из заголовка, этим вы удаляете такие данные для всех товаров. Обязательные поля (Category, Name/Code, Description and Price) удалять нельзя.

§После заголовка каждоая строка соответствует одному товару.

§Все параметры должны разделяться точкой с запятой (;).

§Следующие параметры должны быть заданы для каждого товара: Category name, Product name, Product description, Product price (категория, наименование товара, описание и цена). Все другие поля - необязательные и их можно опустить (ничего не писать между символами «;» при перечислении полей.

§Идентификатор товара (product ID) генерируется программой: если вы добавляете новый товар, оставьте это поле пустым.

§Все пробелы в файле при импорте удаляются.

Параметры в файле .TXT или .CSV следующие:

Параметр: ID (идентификатор)

Обязательный

нет

Описание

Уникальный идентификатор товара.

Значение

Генерируется программой и привязывается к товару автоматически.

При обновлении файла .TXT или .CSV от предыдущего экспорта никогда не исправляйте идентификатор! Для новых товаров оставьте это поле пустым . При импорте каталога программа проверяет дубли по каждому идентификатору и при необходимости создает новые.

Параметр: Category (категория)

Обязательный

да

Описание

Категория (рубрика) товара.

Значение

Используйте символ > для обозначения пути в категориях и подкатегориях.

Например, майка в подкатегории «Повседневная» в категории «Мужская одежда» обозначается в файле *.TXT или *.CSV так:

... ; Мужская одежда > Повседневная ; ...

Таким способом можно добавить все необходимые подкатегории.

Параметр: Name/Code (наименование, код товара)

Обязательный

да

Описание

Наименование или код товара.

Значение

При экспорте каталога в файл *.TXT или *.CSV этот параметр берется из поля Наименование/Код в окне Настройки товара | Общие настройки.

Параметр: Description (описание)

Обязательный

да

Описание

Описание товара.

Значение

При экспорте каталога в файл *.TXT или *.CSV этот параметр берется из поля Описание в окне Настройки товара | Общие настройки.

Параметр: Price (цена)

Обязательный

да

Описание

Цена товара.

Значение

При экспорте каталога в файл *.TXT или *.CSV этот параметр берется из поля Цена в окне Настройки товара | Общие настройки.

Параметр: Enable VAT (НДС)

Обязательный

нет

Описание

Обозначает конкретный НДС на этот товар.

Значение

При экспорте каталога в файл *.TXT или *.CSV этот параметр берется из поля Налог (%) в окне Настройки товара | Общие настройки. Этот параметр доступен только при выборе Вид налогообложения «включая НДС» для Настройки налога в Корзина | Наличие. Используется для привязки конкретного значения НДС к товару, если это значение отличается от общего для других товаров каталога. В этих случаях цены показываются без учета НДС.

Параметр имеет значение 0, если не выбран параметр Налог (%), или 1, если выбран.

Параметр: VAT Value (значение НДС)

Обязательный

нет

Описание

НДС, применяемый к цене товара, для которого не указано особое значение НДС

Значение

При экспорте каталога в файл *.TXT или *.CSV этот параметр берется из поля Налог (%) в окне Настройки товара | Общие настройки, где этот параметр доступен только если Корзина | Наличие в Вид налогообложения выбран параметр «включая НДС» для Настройки налога.

Если параметр Налог (%) в окне Настройки товара | Общие настройки выбран, но значение его не задано, то используется Значение по умолчанию (%) указанное в Настройки товара | Наличие.

Параметр: Weight (вес)

Обязательный

нет

Описание

Вес товара.

Значение

При экспорте каталога в файл *.TXT или *.CSV этот параметр берется из поля Вес в окне Настройки товара | Общие настройки.

Параметр: Options (параметры)

Обязательный

нет

Описание

Список возможных вариантов товара.

Значение

При экспорте каталога в файл *.TXT или *.CSV этот параметр берется из поля Список основных параметров в окне Настройки товара | Параметры.

При создании файла *.TXT или *.CSV для импортирования, варианты товара в списке разделяются символом |, как в примере:

... ; Вариант1 |Вариант2 | Вариант3 ; ....

Таким способом можно добавить все необходимые варианты.

Параметр: Enable Discounts (разрешенные скидки)

Обязательный

нет

Описание

Указывает на оптовую скидку.

Значение

При экспорте каталога в файл *.TXT или *.CSV этот параметр берется из поля Разрешить оптовую скидку в окне Настройки товара | Скидка.

Параметр может иметь значение 1 или 0, в соответствии с выбором параметра Разрешить оптовую скидку.

Параметр: Discounts (скидки)

Обязательный

нет

Описание

Список возможных оптовых скидок.

Значение

При экспорте каталога в файл *.TXT или *.CSV этот параметр берется из поля Разрешить оптовую скидку в окне Настройки товара | Скидка.

При создании файла *.TXT или *.CSV для импортирования, список оптовых скидок нужно записать так:

... ; количество : скидка | количество : скидка ; ...

Таким образом, если применяется скидка 10% при заказе более 20 наименований и скидка 15% при заказе более 50 наименований, нужно написать:

... ; 20 : 10 | 50 : 15 ; ...

Для добавления всех нужных скидок используйте символ |.

При импорте файла *.TXT или *.CSV от предыдущей операции экспорта или если вы создаете такой файл самостоятельно, возможно, программа его донастроит, например, впишет недостающие идентификаторы. Если вы хотит получить уже исправленную версию своего файла, нужно сделать повтроный экспорт каталога товаров.

Лучшая практика:

-

Как оформить подтверждение заказа по электронной почте


Веб-браузер и встроенный браузер WebSite X5 .

Родственные темы >

Веб-браузер и встроенный браузер WebSite X5 .

 Return to chapter overview
Покажите/скройте невидемый текст

Браузер - это программа, позволяющая пользователю просматривать информацию (текст, изображения и т.д.) и взаимодействовать с ней на веб-странице. Самые известные браузеры это Microsoft Explorer®, Firefox®, Safari® и Google Chrome™.

Для отображения информации браузеры используют механизм рендеринга. Механизм рендеринга это программа, которая загружает содержимое (например, HTML-страницы) и отображает информацию в соответствии с некоторыми заданными форматами (например, на основе файла CSS) на экране. Браузеры используют множество различных механизмов рендеринга, которые отличаются качеством рендеринга в отношении соответствия стандартам и скорости работы. Таким образом, страницы могут выглядеть по-разному в зависимости от того, через какой из браузеров мы их смотрим. Однако, поскольку веб-страницы не печатаются, определенные различия вполне допустимы, если при этом не нарушается восприятие инфорации пользователем.

Лучший способ получить веб-страницы, которые совместимы с большинством браузеров и их многочисленным версиями, состоит в том, чтобы создать чистый код, полностью соответствующий стандартам.

WebSite X5 автоматически создает код HTML5 и соответствующий ему CSS 2.1 или 3 и гарантирует полную совместимость со всеми основными браузерами и мобильными устройствами, например, мобильными телефонами, планшетными компьютерами и смартфонами.

Кликните, чтобы развернуть/уменьшить Встроенный браузер WebSite X5

При работе над проектом нужно иметь возможность проверять, как будет выглядеть конечный результат, как будет отображаться сайт после публикации. Для этого программа WebSite X5 предлагает кнопку Предпросмотр, которая всегда видна (см. Рабочая среда). Эта кнопка позволяет предварительно просмотреть сайт на своем компьютере. Информация (см. Обновлять файлы предпросмотра при работе над проектом в окне Предпочтения).

Для предварительного посмотра WebSite X5 использует собственный встроенный браузер на основе Chromium (http://www.chromium.org/), это браузер с открытым исходным кодом, который называется Google Chrome™. В браузере доступны следующие команды:

Назад

Возврат к ранее просмотренной странице.

Вперед

Идет вперед, к ранее просмотренной странице.

Главная страница

Эта команда открывает главную страницу сайта.

Адресная строка

В этой строке показывается путь к отображаемой странице. Здесь можно ввести путь к странице, которую нужно открыть.

Перейти

Загружает страницу, путь к которой указан в адресной строке. Можно также загрузить страницу нажатием клавиши Enter.

Редактировать страницу

Мы возвращаемся в программу, где открывается страница, отображаемая в браузере в окне Создание Страниц таким образом, что ее можно редактировать. Если страница является частью блога, пользовательского раздела или Корзина, то эта кнопка открывает соответствующий раздел Этапа 4 - Расширенные настройки.

Если окно браузера открыто для предварительного просмотра проекта, то при внесении изменений в эту страницу она автоматически обновится в браузере.

Наличие встроенного браузера для предварительного просмотра создаваемого сайта дает ряд преимуществ:

§предварительный просмотр не заменяет сайт, отображаемый в используемом по умолчанию браузере.

§предварительный просмотр сайта обновляется в окне встроенного браузера. При этом не открываются дополнительные окна используемого по умолчанию браузера.


Встроенная поисковая система WebSite X5

Как работает встроенная поисковая система программы WebSite X5

Родственные темы >

Как работает встроенная поисковая система программы WebSite X5

 Return to chapter overview
Покажите/скройте невидемый текст

Программа WebSite X5 Шапка' страницы / Подвал' страницы шаблона (см. Редактировать шаблон | Вставить поле поиска), таким образом, ваши посетители смогут использовать встроенный поисковый механизм, чтобы найти что-нибудь на вашем сайте. Механизм ищет страницы, изображения, видео, товары в Корзине и информацию в блоге: результаты поиска упорядочены по релевантности и отображаются на страницах, созданных программой автоматически.

Кликните, чтобы развернуть/уменьшить Как работает поисковый движок?

Чтобы получить максимальную пользу от поискового механизма, встроенного в программу WebSite X5, вам нужно знать, что:

§Страницы

Поисковая Система учитывает следующие элементы Страницы: Название, Описание и Ключевые Слова (см. Свойства страницы |Общие ), а также Содержимое.

§Изображения / видеозаписи

Поисковый движок учитывает только те изображения и видеозаписи, которые внесены в карту сайта (см. Изображение объекта | Карта сайта или Аудио-видео объект | Карта сайта) и анализирует всю информацию, заданную для: Заголовок, Заголовок и Местоположение (например, адрес, город и т.д.) изображений; Заголовок, Заголовок, Категория, Ключевые слова сайта и Дата публикации видео.

§Товары в Корзине

Поисковый движок расширяет свою зону поиска, включая в нее все товары, которые можно добавить в Корзину, анализируя Наименование/Код и связанные с ними Описание (см. Настройки товара | Общие настройки).

§Блог

Все страницы вашего блога включаются в поиск. Поисковый механизм анализирует Заголовок, Автор, Категория, Тэги, Заголовок и Контент для каждого сообщения.

§Пользовательский Раздел

Закрытые Страницы, для доступа к которым требуется Логин и Пароль (см. Пользовательский Раздел), не учитываются Поисковой Системой, если в данный момент нет ни одного авторизованного пользователя.

§Скрытые Страницы

Встроенная Поисковая Система учитывает Скрытые страницы .

§Исключить Страницу из Поиска

Чтобы Поисковая Система не учитывала при поиске какую-то Страницу, следует выбрать ее на Карте Сайта, открыть окно Свойства страницы и в разделе Эксперт отменить выбор параметра Добавить эту страницу к карте сайта.

§Различение заглавных и прописных букв

Встроенная Поисковая Система ведет поиск без учета регистра, т. е. не различает заглавные и прописные буквы.

Различные параметры поискового механизма имеют разную важность: например, встречаемость элементов в заголовках страницы считается очень важной. Таким образом, встречаемость некоторых параметров автоматически умножается на коэффициент коррекции перед тем, как сравниваться с другими включениями. в зависимости от количества встречаемости, подсчитывается важность элемента. И уже на ее основе выстраиваются поисковые результаты на странице.
Кликните, чтобы развернуть/уменьшить Страницы Результата Поисковой Системы

Страницы результатов поиска генерируются программой автоматически и отображают:

§поисковое поле, которое видно в верхней или нижней части страницы;

§боковое меню, где можно выбрать, отображать ли результаты для страниц, блога, Корзины, изображений или видео. Рядом с каждым элементов в квадратных скобках приводится количество найденных результатов. Если по определенно категории результатов нет, то элемент не включается в меню;

§список результатов поиска, упорядоченный в соответствии с вычисленной релевантностью (важностью).

Помните, что на страницах результатов поиска, где показаны изображения и видео, можно просто нажать на них, чтобы открыть страницу, где они встречаются.

Встроенный поисковый движок особенно полезен для сайтов с большим каталогом товаров: поисковые страницы содержат не только полное описание товаров, но и включают в себя кнопку «Купить сейчас», чтобы посетители смогли сразу же заказать товар онлайн.

Результаты поиска отображаются на Страницах, автоматически генерируемых Программой. Графическое оформление этих Страниц настраивается в разделе Этап 4 - Расширенные настройки, в разделе Стили и модели и в боковом меню можно задать в разделе Стиль меню страницы.


Блочная модель WebSite X5

Рамочная модель в программе WebSite X5

Родственные темы >

Рамочная модель в программе WebSite X5

 Return to chapter overview

В программе WebSite X5 Страницы создаются при помощи Таблицы Макета Страницы, а дизайн и компоновку Страницы можно улучшать, настраивая параметры полей Внешние поля и Внутреннее поле в Стиль ячейки | Стиль.

Для ясного понимания того, что имеется в виду под Полем, и правильной компоновки содержимого, нужно иметь представление об используемой Рамочной модели.

Когда веб-мастер пишет код веб-страницы, все элементы HTML рассматриваются как рамки, а набор параметров, определяющих внешний вид каждой рамки, называется Рамочной моделью. Каждая рамка состоит из базового набора компонентов — полей, кромки, заполнения и собственно содержимого. Каждый из этих компонентов модифицируется CSS-свойствами.

На иллюстрации (см. ниже) показаны различные компоненты Рамочной модели:

По умолчанию Таблица Макета Страницы в программе WebSite X5 состоит из нескольких Ячеек, куда можно добавлять содержимое Страницы. Для каждой Ячейки используется Рамочная модель.

Элементы рамки:

§Содержимое (зеленый цвет)— добавляется в Ячейку перетаскиванием в нее имеющихся Объектов.

§Заполнение (розовый цвет)— пространство между содержимым и кромкой.

§Кромка — окружает заполнение и содержимое. Внешнее оформление кромки можно настроить в окне Стиль ячейки.

§Поле (желтый цвет)— пространство между кромкой и линиями Таблицы Макета Страницы.

С учетом этих определений, (горизонтальное или вертикальное) пространство между двумя смежными Объектами равно сумме толщин Полей, заданных для Ячеек, в которые помещены Объекты.


Панель управления сайтом онлайн

Родственные темы >

Панель управления сайтом онлайн

 Return to chapter overview

Программа WebSite X5 автоматически добавляет он-лайн Панель Управления на каждый Сайт. Администратор Сайта может использовать Панель Управления для управления комментариями к сообщениям в Блоге и сообщениями в Гостевой Книге, а также для просмотра информации по диагностике Сайта и поисковой оптимизации.

Каждый член группы Администраторы , созданной в разделе Управление доступом на Этапе 4 - Расширенные настройки может получить сюда доступ.

Как получить доступ к Панели Управления:

§Пройдите по ссылке вида http://www.mywebsite.ru/admin (где http://www.mywebsite.ru — URL-адрес Сайта).

§Введите свой логин и пароль.

После того, как вы ввели учетные данные, вы увидите следующие разделы панели управления:

§Блог — можно управлять комментариями, оставленными посетителями к сообщениям в Блог Сайта (см. Как управлять комментариями к Сообщениям в Блоге посредством он-лайн Панели Управления).

§Гостевая Книга — можно управлять сообщениями, оставленными посетителями в Гостевой Книге Сайта (для добавления Гостевой Книги можно использовать соответствующий Виджет в Объект гостевая книга.

§Тест Сайта — можно просмотреть диагностическую информацию по Сайту и по Хостинг-серверу, на котором размещается Сайт. Диагностика выполняется по следующим пунктам:

-Версия PHP — Хостинг-сервер должен поддерживать язык PHP, чтобы правильно обрабатывать электронные письма (электронные письма используются в Объект-форма обратной связи и Корзина ) и предоставлять доступ к Закрытым Страницам при вводе Логина и Пароля. Выполняется проверка поддержки языка PHP вообще, а также выясняется, какая версия языка PHP поддерживается.

-Поддержка сессий — помимо поддержки PHP, Хостинг-сервер должен поддерживать сессии, чтобы предоставлять доступ к Закрытым Страницам.

-Папка с правами записи — Чтобы можно было сохранять и управлять комментариями к сообщениям в Блог и Объект гостевая книга, нужно задать путь к папке на Сервере, куда можно записывать данные. Выполняется проверка существования такой папки и наличие прав записи для нее.

-Поддержка MySQL и настройки базы данных — если используется Объект-форма обратной связи, то можно настроить сохранение данных, собираемых из заполненных форм электронного письма, в базе данных (опция «Отправлять данные в Базу данных» в разделе Объект-форма обратной связи | Отправить. Для этого потребуется задать параметры доступа к базе данных на Сервере. Выполняется проверка поддержки MySQL Сервером, а также наличие доступа к Базе данных при заданных настройках.


Разработчики и права

Информационную и техническую поддержку

Информационную и техническую поддержку

 Return to chapter overview

осуществляет Incomedia продукт

www.websitex5.com

www.incomedia.eu

Copyright 2013 Incomedia. Все права защищены.

В программе WebSite X5 используется библиотека DotNetZip по лицензии MS-PL (Microsoft Public License)

WebSite X5 использует метод связи, подпадающий под лицензию LBSD 3.

WebSite X5 использует Cef Sharp, подпадающий под лицензию LBSD 2.

Для получения дополнительной информации или технической поддержки посетите наш сайт: www.websitex5.com/help


License BSD 3

License BSD 3

Copyright (c) 2008-2012 Marshall A. Greenblatt. Portions Copyright (c)

2006-2009 Google Inc. All rights reserved.

Redistribution and use in source and binary forms, with or without

modification, are permitted provided that the following conditions are

met:

* Redistributions of source code must retain the above copyright

notice, this list of conditions and the following disclaimer.

* Redistributions in binary form must reproduce the above

copyright notice, this list of conditions and the following disclaimer

in the documentation and/or other materials provided with the

distribution.

* Neither the name of Google Inc. nor the name Chromium Embedded

Framework nor the names of its contributors may be used to endorse

or promote products derived from this software without specific prior

written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS

"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT

LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR

A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT

OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,

SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT

LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,

DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY

THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT

(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE

OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


License BSD 2

License BSD 2

Copyright (c) 2012, Anthony Taranto.

Redistribution and use in source and binary forms, with or without

modification, are permitted provided that the following conditions are

met:

* Redistributions of source code must retain the above copyright

notice, this list of conditions and the following disclaimer.

* Redistributions in binary form must reproduce the above

copyright notice, this list of conditions and the following disclaimer

in the documentation and/or other materials provided with the

distribution.

* Neither the name of Google Inc. nor the name Chromium Embedded

Framework nor the name CefSharp nor the names of its contributors

may be used to endorse or promote products derived from this software

without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS

"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT

LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR

A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT

OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,

SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT

LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,

DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY

THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT

(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE

OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


Microsoft Public License (Ms-PL)

Microsoft Public License (Ms-PL)

 Return to chapter overview

This license governs use of the accompanying software. If you use the software, you accept this license. If you do not accept the license, do not use the software.

1. Definitions

The terms "reproduce," "reproduction," "derivative works," and "distribution" have the same meaning here as under U.S. copyright law.

A "contribution" is the original software, or any additions or changes to the software.

A "contributor" is any person that distributes its contribution under this license.

"Licensed patents" are a contributor's patent claims that read directly on its contribution.

2. Grant of Rights

(A) Copyright Grant- Subject to the terms of this license, including the license conditions and limitations in section 3, each contributor grants you a non-exclusive, worldwide, royalty-free copyright license to reproduce its contribution, prepare derivative works of its contribution, and distribute its contribution or any derivative works that you create.

(B) Patent Grant- Subject to the terms of this license, including the license conditions and limitations in section 3, each contributor grants you a non-exclusive, worldwide, royalty-free license under its licensed patents to make, have made, use, sell, offer for sale, import, and/or otherwise dispose of its contribution in the software or derivative works of the contribution in the software.

3. Conditions and Limitations

(A) No Trademark License- This license does not grant you rights to use any contributors' name, logo, or trademarks.

(B) If you bring a patent claim against any contributor over patents that you claim are infringed by the software, your patent license from such contributor to the software ends automatically.

(C) If you distribute any portion of the software, you must retain all copyright, patent, trademark, and attribution notices that are present in the software.

(D) If you distribute any portion of the software in source code form, you may do so only under this license by including a complete copy of this license with your distribution. If you distribute any portion of the software in compiled or object code form, you may only do so under a license that complies with this license.

(E) The software is licensed "as-is." You bear the risk of using it. The contributors give no express warranties, guarantees or conditions. You may have additional consumer rights under your local laws which this license cannot change. To the extent permitted under your local laws, the contributors exclude the implied warranties of merchantability, fitness for a particular purpose and non-infringement.


print_copyright

print_copyright

© Copyright 2013 Incomedia. All rights reserved.

Le informazioni contenute in questo manuale possono essere soggette a modifiche senza alcun preavviso. Nessuna parte di questo manuale può essere riprodotta o trasmessa in qualsiasi forma o con qualsiasi mezzo, elettronico o meccanico, per qualsiasi scopo, senza l'espresso consenso scritto di Incomedia.

Si ricorda che filmati, suoni o immagini che si desidera utilizzare nei progetti possono essere soggetti a diritto d'autore. L'inserimento non autorizzato di tali materiali potrebbe, dunque, rappresentare una violazione dei diritti di autore ed è bene accertarsi di poterne fare uso liberamente o ottenere i permessi necessari dai rispettivi autori o dagli enti preposti.

Incomedia, WebSite X5, WebSite X5 Evolution sono marchi registrati di Incomedia s.r.l. Altri marchi o nomi di prodotti citati nel presente documento sono marchi o marchi registrati dei rispettivi proprietari.

Scritto e impaginato da Incomedia s.r.l.